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Preface

Purpose of This Guide
This guide describes how to use the applications you receive with
DECwindows Motif for OpenVMS software.

Who Should Use This Guide
This guide is intended to serve as a companion manual to
the Using DECwindows Motif for OpenVMS manual for all
DECwindows Motif for OpenVMS users.

Structure of This Guide
This guide covers the following DECwindows Motif for OpenVMS
applications:

Use This
Application To

Bookreader Display online documentation on your workstation
screen

Calculator Perform mathematical operations

Calendar Keep track of your scheduled appointments and plan
your time

Cardfiler Organize your information with index cards and
card files

CDA Viewer Display the contents of many different types of files
on your workstation screen

Clock Display the time of day (in both analog and digital
format) and the date on your workstation screen

DECsound Record, play, and mail audio messages
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Use This
Application To

DECterm Create a window that emulates a VT300 series
terminal

LinkWorks
Manager

Control your hyperinformation environment

Mail Exchange messages with other computer users

Paint Create a simple picture, an illustration, or a map

Print Screen Take a snapshot of your entire screen or just
a portion of it and print the file containing the
snapshot

Puzzle Display a video version of a number puzzle that
contains squares you arrange in ascending order

Appendix A describes how to compose characters from your
keyboard.

For More Information
For complete information about using each application, pull down
the Help menu on any window and choose the menu item for the
area in which you need help:

Menu Item Function

On Context Describes each object in the window, such as a menu or
push button, and how to use that object to perform tasks

On Window Outlines the function of the window and the tasks you
can perform using the window

On Help Activates the Help system and tells you how to find the
information you need

On Version Provides information about the specific version of the
application

For general information about using DECwindows, see Using
DECwindows Motif for OpenVMS, which explains how to
get started with DECwindows Motif, how to customize your
DECwindows environment, and how to use advanced techniques.

For information about additional documentation available
for DECwindows Motif for OpenVMS, see the Overview of
DECwindows Motif for OpenVMS Documentation.
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Conventions
In this manual, every use of DECwindows and DECwindows Motif
refers to DECwindows Motif for OpenVMS software.

The following conventions are used in this manual:

mouse The term mouse is used to refer to
any pointing device, such as a mouse,
a puck, or a stylus.

MB1 (Select)
MB2 (Drag)
MB3 (Menu)

MB1 indicates the left mouse button,
MB2 indicates the middle mouse
button, and MB3 indicates the right
mouse button. (The buttons can be
redefined by the user.)

Ctrl+x A sequence such as Ctrl+x (or Ctrl/x)
indicates that you must hold down
the key labeled Ctrl while you press
another key or a pointing device
button.

PF1 x A sequence such as PF1 x indicates
that you must first press and release
the key labeled PF1, then press and
release another key or a pointing
device button.

Return In examples, a key name is shown
enclosed in a box to indicate that you
press a key on the keyboard.

boldface text Boldface text represents the
introduction of a new term.

Boldface text is also used to show
user input in online versions of the
book.
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1
Using Bookreader

With Bookreader, you can read online documentation on your
screen.

This chapter provides a quick summary of how to

• Start Bookreader

• Open libraries, bookshelves, books, and sections

• Read text and navigate sections

• Close sections and books and exit Bookreader

• Copy text from the Bookreader Topic window

• Print books and topics

• Search for information

• Use LinkWorks features

• Exit Bookreader

For detailed information, refer to the Bookreader online help.
To access Help, start Bookreader (see Starting Bookreader), pull
down the Help menu, and choose Overview.

Starting Bookreader
To start Bookreader, choose Bookreader from the Session
Manager’s Applications menu. Libraries of books available from
Bookreader appear in the library window.
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Libraries contain groups of related book titles. Each library and
title has an icon to the left of it to indicate whether it is a library
or a book.

The following table shows the tasks you can perform from the
library window.

To Do This

See the list of books in a library
or bookshelf

Double click on the library or
bookshelf name. Or, click on the
name, and then choose Expand from
the View menu.

Open a book Double click on the title.
Or, click on the title, and then choose
Open Book from the File menu. Or,
click on the title, and then press
MB3 and choose Open Book from the
pop-up menu.
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To Do This

Open a book in a second Topic
window

Click on the title; then choose Open
Book in New Window from the File
menu. Or, click on the title, and then
press MB3 and choose Open Book in
New Window from the pop-up menu.

Open a book not shown in the
Library window

Choose Open Book... from the File
menu.

Search through one or more
books for a word or phrase

Select the book(s), then choose Search
Book(s)... from the Search menu.

Search for a word or phrase in
the titles listed in the Library
window

Select the library, bookshelf, or book
titles, then choose Search Book
Titles... from the Search menu.

Close an expanded library or
bookshelf

Double click on the library or
bookshelf name. Or, click on the
name, and then choose Collapse from
the View menu.

Close all expanded libraries and
bookshelves

Choose Collapse All from the View
menu.

Switch to a different library Choose Switch Library... from the
File menu.

Switch back to the default
library

Choose Switch to Default Library
from the File menu.

Note

The procedures in this chapter use the quick method of
double clicking MB1 to select and open shelves, books, and
topics.

For descriptions of other methods, such as using pull-down
and pop-up menus and entering commands from the
keyboard, refer to Bookreader’s online help.
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Opening a Book
To open a book that is listed in the library window, double click
on the book’s title. The library window remains on the screen and
the navigation window appears. The navigation window contains
the table of contents for the book you opened.
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Creating and Displaying Your Own Books
You might want to read a book that is not included in the default
libraries. Using the VAX DOCUMENT or DECwrite products,
you can create Bookreader formatted book files that have the
.DECW$BOOK extension. You can store these books in your
directory and then use Bookreader to display these files on your
screen.
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To open a book from your directory:

1. Choose Open Book... from the File menu.

The Open Book dialog box appears.

2. In the Directories list box, double click on the directory where
the book resides.

3. In the Files list box, double click on the book’s DECW$BOOK
file name. The file name appears in the Selection entry box.

4. Click on OK. The book’s navigation window appears.

Locating Topics in the Navigation Window
The navigation window contains the main sections of the book,
which are typically:

Contents
Figures
Tables
Examples
Index

To display the topics for a section, double click on the section. You
see the topics listed under the section.

Some topics are preceded by arrows:

• An arrow that points to the topic indicates that the topic
contains subtopics that do not appear on the screen at the
moment.

• An arrow that points downward indicates that the subtopics
appear on the screen.

To display subtopics, double click on the topic’s arrow. You see the
subtopics. Alternatively, you can choose Expand or Fully Expand
from the View menu.

Opening a Topic
To open a topic that is listed in the navigation window, double
click on the topic. The navigation window remains and the topic
appears in a new window (the topic window).
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Reading Text and Navigating a Book
When you open a text topic from the table of contents or index,
the text appears in the topic window. You can use the buttons and
arrows at the bottom of the window to move through the text:

Close
• To close the topic that is displayed on the screen, click on the

Close button.

Go Back
• To go back to one or more of the topics you viewed previously,

click on the Go Back button until you reach the topic you
want.

Topic
• To move to the next topic or the previous topic, click on the

arrow to the right or the left of the word Topic.

Screen
• To move to the next screen or the previous screen, click on the

arrow to the right or the left of the word Screen. If the end of
the current topic appears, moving to the next screen opens the
next topic.

Using the Scroll Bars
The width or length of the text might be greater than the window
can display. To read text that is hidden by the window boundaries,
use the horizontal or vertical scroll bar. For information about
using the scroll bars, see Using DECwindows Motif for OpenVMS.

Displaying Figures, Tables, and Examples
When you open a topic that is a figure, table, or example, that
topic is displayed in a separate window. The window is sized
according to the dimensions of the topic. If the topic is large—
for example, if its dimensions exceed those of the window—you
can either use the scroll bars to navigate the topic or drag the
window’s border to resize the window.

When you are ready to close the window in which a figure, table,
or example is displayed, click on the Close button at the bottom of
the topic window.
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Using Hotspots
Most books contain cross-references to figures, tables, examples,
other chapters, and other sections. If you move the pointer over
a reference, a box appears around it indicating that the reference
is a hotspot. Hotspots enable you to go directly to the referenced
area.

• For references to figures, tables, examples, and footnotes,
double click on the reference. The reference appears in a
separate window.

• For references to text topics, double click on the reference.
The cross-referenced text replaces the current text in the topic
window. For example, double clicking on ‘‘Chapter 1’’ in the
text causes that chapter to appear in the topic window.

To open the referenced section in a new window, move the
pointer over the hotspot, press MB3, and choose Open Topic in
New Window from the pop-up menu.

By default, hotspots are highlighted only when you point to them.
To highlight all hotspots without having to point to each one,
choose Hotspots from the Topic window’s View menu. A shaded
check button to the left of the Hotspot menu item indicates that
highlighting of all hotspots is enabled.

Closing a Section
To close a section, click on the Close button at the bottom of the
Topic window.

The Topic window disappears, but the Navigation and Library
windows remain.

Closing a Book
To close a book, choose Close Book from the Navigation window’s
File menu, or double click on the book title in the Library window.

The Navigation and Topic windows disappear, but the Library
window remains.
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Copying, Extracting, and Printing Text
You can copy information, extract one or more topics (or an entire
book), and print text from Bookreader. The sections that follow
describe how to perform these tasks.

Note

Because of copyright protections or other similar reasons,
the author of a document can choose to suppress the
ability to copy, extract, or print information from it. If you
attempt to copy, extract, or print text from one of these
books, you will see a message stating that the author has
disallowed that operation.

Copying Information
You can copy information from the Bookreader Topic window and
paste it into another window, such as a DECterm window. You
cannot paste information into a Bookreader Topic window. You
can only copy from it.

There are two methods you can use to copy text:

• Copy and Paste—To move data from the Topic window to
another window that supports clipboard operations, such as
a DECterm window. When you use Copy and Paste, data is
transferred through the clipboard.

• Copy Selection—To move text directly from the Topic window
to another window that also supports Copy Selection, such as
a DECterm window. When you use Copy Selection, data does
not go to the clipboard but goes directly to the destination you
specify.

Extracting Text to a File
You can save one or more topics or an entire book to a text file for
printing later.

When you extract a topic to a text file, Bookreader converts the
text to ASCII format. Graphics are not included. Tables are
formatted as closely as possible to the original.
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The Print dialog box also contains other fields that you might
want to use. For more information about those fields, click on the
Help button in the Print dialog box.

Printing Topics or Books
You can print the topic you are reading, one or more topics from
the book that is open, or an entire book.

Two types of formatting are available:

• POSTSCRIPT—Bookreader generates a POSTSCRIPT file that
closely resembles the information you see online. Graphics,
tables, and other elements are printed as well.

• ASCII text—Bookreader generates a text file in ASCII format.
The text is converted to a monospaced font, graphics are not
included, and tables are formatted as closely as possible to the
online version.

You can also extract the topic or book to a file (see Extracting Text
to a File) for printing later by using the same menu option on the
File menu.

The Print dialog box also contains other fields that you might
want to use. For more information about those fields, click on the
Help button in the Print dialog box.

Bookreader places a copyright statement at the beginning of all
printed information. If the book contains a copyright section,
Bookreader uses that information in its copyright statement.
Otherwise, it uses a Digital copyright statement.

Searching for Information
You can search through Bookreader libraries, bookshelves, books,
and topics to locate a specific word or phrase. Each window has
a Search menu. Table 1–1 describes the various ways you can
search for information in the Bookreader windows.
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Table 1–1 Ways to Search for Information

To Search Through Do This

One or more libraries,
bookshelves, or books listed
in the Library window

In the Library window, select the
titles, then choose Search Book(s)...
from the Search menu.

The list of book titles displayed
in the Library window.
(Bookshelf and library titles
are not searched.)

In the Library window, select the
library, bookshelf, or book titles, then
choose Search Book Titles... from the
Search menu.

The book you have open In the Navigation window or the
Topic window, choose Search Book...
from the Search menu.

One or more sections listed in
the Navigation window

In the Navigation window, select
the sections, then choose Search
Topic(s)... from the Search menu.

The list of entries displayed in
the Navigation window

In the Navigation window, choose
Search Entry Titles... from the
Search menu.

If Bookreader does not find any matches, it displays a message to
that effect.

If Bookreader locates any matches, it displays the Search Results
dialog box and lists the section names in the Subject list box. To
read a section, follow one of these procedures:

• Double click on a section name in the Subject list box to
display the section in the Topic window but leave the Search
Results dialog box displayed.

• Click on a section name in the Subject list box, then click on
the OK button to display the section in the Topic window and
dismiss the dialog box.

When you begin a search, the Search button changes to Stop
Search. You can stop a search at any time by clicking on the Stop
Search button. The Search Results dialog box remains displayed
and any sections located up to that point are still available for
use.
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Search Error Messages
Sometimes a Bookreader search generates error messages. When
Bookreader encounters errors during a search, it displays all the
error messages in the Search Messages Box at the conclusion of
the search.

Using LinkWorks Features
Note

This feature is not available on all operating systems. If
your version of Bookreader has an active Link menu in
each window, then you can use the features described in
this section.

Bookreader supports LinkWorks features. Through the Link
menu, you can make and follow links between pieces of
information (linkable objects). The linked information can be
another Bookreader object or an object accessed by any other
application that supports LinkWorks.

Bookreader’s linkable objects are:

• Any book or library

• Any title in the Navigation window

• Any section in the Topic window

For example, you can link the title of a book to a section of the
same book or another book. You can link a section of a book to a
Cardfiler card or a Calendar timeslot. However, you cannot link a
sentence or word within a paragraph to anything.

For information about linking Bookreader objects, choose Help
Mode from the Help menu. When the pointer changes to a
question mark, click on the Link menu.

Exiting Bookreader
To exit Bookreader, choose Exit from the Library window’s File
menu.
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2
Using Calculator

Calculator performs simple arithmetic functions—addition,
subtraction, multiplication, division—and computes percentages
and square roots. In addition, Calculator also performs
trigonometric and inverse trigonometric functions, generates
random numbers, and performs other more advanced operations.

Unlike a handheld calculator, DECwindows Motif Calculator has
two displays. The top display is the accumulator, which shows
the number being entered or the current result, and the bottom
display is the memory.

This chapter describes how to

• Start Calculator

• Change from decimal mode to hexadecimal or octal mode

• Enter data

• Perform arithmetic functions

• Use the memory

• Perform special functions

• Transfer data to or from other applications

• Save customized settings

• Exit Calculator
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Starting Calculator
To start Calculator, choose Calculator from the Session Manager’s
Applications menu. Calculator, in decimal mode, appears on
your screen. You can move and change the size of the calculator
window.
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Changing the Mode
Mode

Hexadecimal

Octal

Decimal Ctrl+D

Ctrl+H

Ctrl+O

To change Calculator to hexadecimal mode, choose Hexadecimal
from the Mode menu. Calculator, in hexadecimal mode, appears
on your screen.
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To change Calculator to octal mode, choose Octal from the Mode
menu. Calculator, in octal mode, appears on your screen.
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Entering Data
You can use Calculator with either the mouse or the keyboard.

• With the mouse, point to the appropriate button and click
MB1.

• From the keyboard, press the keys listed in the following
table.
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Keyboard
Key

Keypad or
Special-Function
Key Produces

All Modes

0–9 0–9 Numbers 0–9
(0–7 in octal mode)

/ PF2 /

* PF1 *

– – –

+ , +

= Enter =

MC Ctrl+F4 MC

MR Ctrl+F5 MR

M+ Ctrl+F6 M+

M– Ctrl+F7 M–

Decimal Mode

. . .

P �

N PF3 +/-

% PF4 %

C Shift+F1 Clear

E Shift+F2 Clear Entry

D Ctrl+F8 deg (switches the trigonometric
argument type: deg, rad, or
grad)

! Ctrl+F9 x! (x factorial)

~ Ctrl+F10 1/x

R Ctrl+F11 Rnd

I Shift+F3 Inv (switches sin, cos, and tan to
the inverse)

S Shift+F4 sin (sine)

O Shift+F5 cos (cosine, or arccosine if Inv is
on)
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Keyboard
Key

Keypad or
Special-Function
Key Produces

Decimal Mode

T Shift+F6 tan (tangent, or arctangent if Inv
is on)

LO Shift+F7 log (or 10 to x if Inv is on)

LN Shift+F8 ln (or e to x if Inv is on)

Q Shift+F9
�

^ Shift+F10 y^x (or y to the 1/x if Inv is on)

Hexadecimal and Octal Modes

& Ctrl+F8 and

| Ctrl+F9 or

^ Ctrl+F10 xor

Ctrl+F11 nor

~ Shift+F9 not

! Shift+F10 neg

C Shift+F1 Clear. Octal key.

E Shift+F2 Clear Entry. Octal key.

Hexadecimal Mode

A Shift+F3 A

B Shift+F4 B

C Shift+F5 C

D Shift+F6 D

E Shift+F7 E

F Shift+F8 F

Ctrl+C Shift+F1 Clear

Ctrl+E Shift+F2 Clear Entry
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Clear Last Entry
from Accumulator

Clear Accumulator

Clear Memory

Memory

Accumulator

of Accumulator
Change Sign

Subtract Contents
of Accumulator
from Memory

Replace Contents
of Accumulator with
Contents of Memory

Add Contents
of Accumulator
to Memory

When you enter data into the accumulator, notice that Calculator
uses a radix separator (. or ,) to distinguish between entered
digits and an operand. See what happens as you enter the
following data:

1. Enter 1134 and notice that a radix separator does not appear
in the accumulator.

2. Enter a plus sign ( + ). Calculator inserts a decimal point after
the number 1134 to signify the completion of an operand.

Depending on the contents of the accumulator, you can use one of
the following methods to correct mistakes in computation:

• To erase the last digits you entered into the accumulator,
press the Delete key (<x ).

Using Calculator 2–7



• To void the last operand entered, click on the CE button.

• To reverse the last operation, choose Undo from the Edit
menu. For example, choose Undo to restore the last operand
or to remove the previous paste operation.

Performing Arithmetic Functions
Calculator displays numbers in the range of plus or minus
99,999,999,999,999. Calculator performs all calculations in
left-to-right order and treats operators with equal importance.

For example, to evaluate the equation 6 + 5 * 3:

1. Find the sum of 6 + 5.

Calculator displays an 11.

2. Figure the product of 11 * 3.

The result is 33.

Also note the way Calculator computes percentages. For example,
to determine 6 percent of 195:

1. Enter 195.

Calculator displays the number in the accumulator.

2. Enter * and Calculator inserts a decimal point.

3. Enter 6.

The number 6 appears in the accumulator.

4. Enter %.

The result, 11.7, appears in the accumulator.

Storing Values in Memory
Use the memory display to store results and values for later
computation. The figure in memory starts as zero. You can
add the contents of the accumulator to memory or subtract the
contents of the accumulator from memory, using the M+ and
M– buttons, respectively. To enter the contents of memory into
the accumulator, click on the MR button. Clear the contents of
memory with the MC button.
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Performing Special Functions
Calculator performs trigonometric and inverse trigonometric
functions as well as other special functions.

The special-function keys in decimal mode are as follows:

Key Description

deg Degree key. Selects the units for angular measurement. By
default, Calculator is in degree mode. Clicking on the deg key
places Calculator in the radian mode, which is indicated by
the key label changing to ‘‘rad.’’ Clicking on the key again
places Calculator in gradient mode, which is indicated by the
key label changing to ‘‘grad.’’ The angular mode has no effect
on Calculator unless the trigonometric functions are being
used.

x! Factorial key. Calculates the factorial ������ ���� � �����������
of the displayed integer x, ��������� � � by definition.

1/x Reciprocal key. Divides the displayed value x into 1, if x is
not 0.

Rnd Random number generator key. Generates a random number
between 1 and the integer of the display. It does not generate
negative numbers or numbers less than 1.

Inv Inversion key. By default, Calculator performs noninverted
trigonometric functions. When you activate the inversion
key by clicking on it (which is indicated by the key becoming
darkened), Calculator performs inverted trigonometric, log,
and exponent functions.

sin Sine key. Instructs Calculator to find the sine (or arcsine if
Inverse is on) of the displayed value.

cos Cosine key. Instructs Calculator to find the cosine (or
arccosine if Inverse is on) of the displayed value.

tan Tangent key. Instructs Calculator to find the tangent (or
arctangent if Inverse is on) of the displayed value.

log Common logarithm key. Calculates the common logarithm
(base 10) of the number x in the display, if x is greater than 0.
If Inverse is on, calculates 10 to x.

ln Natural logarithm key. Calculates the natural logarithm (base
e) of the number x in the display, if x is greater than 0. If
Inverse is on, calculates e to x.

�
Square root key. Calculates the square root of the number x in
the display. The x value cannot be negative.
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Key Description

y^x y to the xth power key. Raises the displayed value y to the xth
power (or y to the 1/x power if Inverse is on). Order of entry is
y y^x x. The y value cannot be negative, but both x and y can
be fractionals.

The special-function keys in hexadecimal and octal modes are as
follows:

Key Description

Hexadecimal Mode

A Enter hexadecimal number A (decimal 10).

B Enter hexadecimal number B (decimal 11).

C Enter hexadecimal number C (decimal 12).

D Enter hexadecimal number D (decimal 13).

E Enter hexadecimal number E (decimal 14).

F Enter hexadecimal number F (decimal 15).

Hexadecimal and Octal Modes

and In Boolean algebra, calculates logic AND (both propositions
are true).

or In Boolean algebra, calculates logic OR (either proposition is
true or both propositions are true).

xor In Boolean algebra, calculates logic XOR (either of the
propositions is true).

nor In Boolean algebra, calculates logic NOR (both propositions
are false).

not In Boolean algebra, calculates logic NOT (negation).

neg In Boolean algebra, calculates NEG (the complement of x).
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Copying Text

Copy

Paste

Undo Alt+Delete

Ctrl+Insert

Shift+Inser t

Edit You can copy numbers from other applications into Calculator’s
accumulator and from Calculator’s accumulator or memory into
another application.

To transfer data from the active display in the calculator window
to another application window, choose Copy from the Edit menu.
For example:

1. Click on the accumulator display.

2. Enter a number into the accumulator.

3. Choose Copy from the Edit menu, or for greater speed, press
and hold MB3 to display a pop-up menu and choose the Copy
menu item.

Now you can paste the data to another application’s window.

To copy data from another application, choose Paste from the Edit
menu. The data can be copied directly from another window, or
it can be the result of an equation copied from another window.
Calculator treats the contents of a paste operation just as if you
typed in the data from the keyboard.

Using Calculator 2–11



ZK−2871A−GE

HelpFile Edit CardSearch

Card: inventory

Brand X 4147.4 *24 =

HelpModeFile Edit

Calculator

Inv sin cos tan

log ln y^x

*

=

/

%

−

+

+−
C

CE
1 2 3

4 5 6

7 8 9

0

0.

99537.6

d i g t a li

MC MR M+ M−

deg x! 1/x Rnd

2–12 Using Calculator



Saving Customized Settings
If you change the screen placement and size of Calculator during
a session and want to save those settings, choose Save Geometry
from the File menu. The next time you start Calculator, the
display reflects the new settings.

To restore the default size and placement of Calculator, choose
Restore System Settings from the File menu.

Exiting Calculator
To exit Calculator, choose Exit from the File menu.
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3
Using Calendar

Jan
1

Calendar combines the functions of a desktop calendar and an
appointment book to help you keep track of your meetings and
plan your time. Calendar lets you look at the display for a full
year or month and also to review your scheduled appointments a
day at a time.

You can create several different calendars to use for specific
purposes. For example, you can create one calendar to keep track
of your personal engagements and another calendar to schedule
conference room reservations.

This chapter describes how to

• Start Calendar

• Move around within Calendar displays

• Create, modify, and delete timeslot entries

• Use the clock

• Enter day notes

• Mark special days

• Work with multiple calendars

• Customize your calendar

• Integrate your Calendar use with other applications

• Exit Calendar
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Starting Calendar
To start Calendar, choose Calendar from the Session Manager’s
Applications menu.

By default, the month display appears on your screen.
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The month display shows the current month and year, with the
days of the month arranged in weekly rows. The current day has
a box surrounding it.

Moving Around in Calendar Displays
Calendar has three main displays: month, day, and year. You can
use the following techniques to move among and within displays:

• Double click on a day or year number or a month name to
move from one display to another. For example, double click
on a day number in a month display to change the calendar
window to a display of the selected day; or double click on the
year number in a day display to change the window into a
calendar of the current year.

• Use vertical or horizontal scroll bars to move backward and
forward within a display. For example, in the day display you
can use the bar under the months or the bar to the right of
the timeslots.
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• Use the View menu to display a selected item, the day display
for today, or the specified type of display (month, day, year).

Creating a Timeslot Entry
The day display shows the timeslots for that day. You can type
entries, such as appointments, directly into the timeslots; or you
can use the entry editor to type longer entries and specify other
options, such as alarms to remind yourself of appointments.

To record a short entry directly into a timeslot:

1. Display the day in which you want to make the entry.

2. Click (and drag to expand, if necessary) on the desired
timeslot.

3. Enter the text in the timeslot.

4. Click in the highlighted area at the left of the timeslot (where
the times are displayed). This action completes the timeslot
entry.
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When a day has at least one entry in it, its day number changes
from a normal font (nn) to an italic font (nn) wherever it is
displayed. On a color workstation, the day number for days with
entries appears in blue. You can then distinguish between days
containing appointments and free days in the month and year
displays.

To create a long entry or to specify options for the entry, use the
timeslot entry editor:

1. Double click on the desired timeslot in the day display.

The Entry Editor dialog box is displayed.

2. Enter the text. You can use the Tab key, the space bar, the
Return key, and the arrow keys to format the text.

3. Adjust the alarms and repeat intervals as required (see
Setting Alarms).

4. If you wish, click on icons to add or remove them from the
entry display.

These icons are symbols that act as reminders for the contents
of the entry. Calendar attaches no particular meaning to
them.

The icons you select appear in the handle of your entry. The
handle is the area between the timeslot time and the two
resize knobs (small squares connected by a thin vertical line).

5. Click on OK to confirm the entry and to dismiss the Entry
Editor.
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If you exit the editor without entering any text, or if you delete
all the text describing a previous entry, the timeslot remains
unscheduled.

Changing the Size of a Timeslot
To enlarge or reduce a timeslot:

1. Select the timeslot.

2. Press and hold MB2 on the top or bottom resize knob (located
between the handle and the entry text).

3. Drag MB2 down or up, depending on whether you want
to extend the appointment later or earlier. The timeslot is
redrawn to the new size.

If you reduce the size of a timeslot, some text may no longer fit in
the display, but it is not lost. The text reappears when you expand
the timeslot again.

Setting Alarms
By default, when you type an appointment entry in the Entry
Editor, alarms sound and a message is displayed 5 minutes before
the appointment and at the time of the appointment. You can
disable these options by clicking on them.

You can set alarms to sound at any combination of the following
times:

• At the time of the scheduled appointment (this is on by
default)

• 1 to 15 minutes in advance (this is on by default, with 5
minutes as the preset option)

• 1 to 60 minutes in advance

• 1 to 24 hours in advance

• 1 to 14 days in advance
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To set one or more alarms:

1. Double click on the desired timeslot in the day display.

The Entry Editor is displayed.

2. Enter the text the entry if you have not already done so.

3. Click on the bell of the alarm you want to set.

The scale adjusts to provide the correct intervals for the
alarm.

4. Move the arrow in the scale to adjust to the time you want.

5. Click on OK to save the settings and to dismiss the Entry
Editor dialog box.

You can also modify the default intervals for all alarms by
choosing Alarms... from the Options menu and making the
desired changes in the Alarms dialog box.
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Calendar: Alarms
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By clicking on the appropriate bell and moving the slider in the
slider bar, you can set alarms up to 14 days in advance and adjust
the number of minutes and hours the alarms sound before an
entry. If you change the defaults, you can save them for future
Calendar sessions by choosing Save Settings from the Options
menu. Choosing Restore Settings causes Calendar to revert to the
previous settings; choosing Use Defaults causes Calendar to revert
to the system defaults.
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Setting Repeating Alarms
You can also set alarms to ring at any of the following times by
displaying the Repeat Options menu in the Entry Editor dialog
box and choosing the desired option from the following list:

Daily
Weekly
Every two weeks
Every four weeks
Monthly
Every two months
Every three months
Every four months
Every six months
Annually

Once you choose an option, you can specify when you want the
alarm to sound:

• For the intervals Monthly through Annually, you can specify
the alarm frequency by using the Options menu to the right.
For example, if you specify Monthly and today is Thursday,
February 21, you can use the Options menu to specify whether
you want the alarm to repeat on the 21st; 7 days before the
month end; on the third Thursday of the month; or on the first
Thursday before, on, or after a specified date.

• For all intervals except None, if you click on the But button,
you can specify that if the day is a work day or nonwork day,
you want the alarm to be skipped, moved forward, or moved
backward. (You can specify work days and nonwork days by
choosing General... from the Options menu.)

If you change or delete an entry that is repeated, a dialog box
is displayed asking whether you want to make the change or
deletion in just this instance, from this point on, or every time,
including past instances.
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Deleting an Entry
To delete an entry from the calendar:

1. Click on the handle or text area of the entry you want to
delete.

2. Choose Delete... from the Entry menu.

For a nonrepeating entry, a warning box is displayed asking
whether you really want to delete this entry.

For a repeating entry, a dialog box is displayed asking
whether you want to delete just this instance, this and all
future instances, or all instances.

3. For a nonrepeating entry, click on Yes to delete it.

For a repeating entry, click on the desired deletion option,
then click on OK.

Moving an Entry from One Timeslot to Another

Cut

Copy

Paste

Clear

Select All

Mark

Shift+De l

Ctrl+Ins

Shift+Ins

Edit

You can copy or move the entire contents of an entry, or just a
piece of text, to another timeslot. If you select the handle, any
alarms or repeat intervals associated with the entry move along
with the text to the new timeslot. If you select the text, only the
text moves; neither the default alarms nor any repetition intervals
transfer.

To move or copy an entry:

1. Select the handle (for the entire entry) or the text (for the text
only) of the entry to be copied or moved.

2. Choose Cut or Copy from the Edit menu. Choosing Cut places
the text in the clipboard and removes the original, whereas
choosing Copy makes a copy of the original and places it in
the clipboard.

3. Select the timeslot into which you want the entry to be copied
or moved. (If this timeslot is in a different day, select that day
display first.) Resize the timeslot if necessary.

If you want to copy or move the entire entry to the same
timeslot on a different day, you do not need to display the new
day. After you select the day in the month or year display,
choose Paste from the Edit menu. The entry is inserted into
that day, at the same time.
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4. Choose Paste from the Edit menu. The text appears in the
new location.

To move an entry to a different timeslot on the same day, a quick
method is to press MB2 on the entry’s handle or text and drag
until you reach the desired new timeslot.

Creating Overlapping Entries
To create an entry in a timeslot that is partially or completely
occupied by an existing entry, click MB1 or press and drag MB1
to the start time. Calendar opens a new entry for you at the
specified time. You can overlap as many entries as you like.

By default, overlapping entries are stacked so that the left side
of each entry is always visible. To change the stacking so that
you see the first line of each entry, choose Day View... from
the Options menu. When the Day View dialog box appears,
choose Show Text from the Stacking menu. To view a hidden or
overlapped entry, click on its icon; the entry moves to the top of
the stack.

Using the Clock in the Day Display

1:23pm The clock at the bottom of the day display provides a digital
display of the current time.

When you click MB1 on the clock, the day display returns to the
current day if you have been displaying a different day. Clicking
on the clock also causes the timeslots that are visible in the day
display to adjust so that the first timeslot contains the time in the
current increment that directly precedes the actual time.

For example, if you set the timeslots in the day display at half-
hour intervals and you click on the clock at 10:57, the day display
adjusts so that the first timeslot contains the time 10:30.

This adjustment is continuous; as a timeslot passes, it scrolls off
the top of the display. This scrolling is convenient if you reduce
the size of the day display significantly; only the most immediate
timeslots remain in view.

To stop the automatic scrolling, move the timeslot by any other
method, such as adjusting the scroll bar.

If you are making an entry in a timeslot when it is about to scroll,
the entry does not disappear. The scroll mechanism waits until
the next interval is over, then the mechanism catches up.
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The Show AM/PM customizing option (choose General... from
the Options menu) allows you to choose between a 12-hour and a
24-hour time display.

Entering Day Notes
You can enter information in a day note that is specific to a
particular day but is not tied to a particular time. For example,
you can use day notes to identify birthdays and other days of
personal interest.

To enter a brief day note, click on the day note indicator (on the
left side of the box below the date in the day display). Enter the
text for your day note. To complete the entry, click again on the
day note indicator.

To enter a longer day note, double click on the day note indicator
to display the entry editor. You can then enter text, modify an
existing entry, or adjust the alarm settings and repeat intervals.

Marking Special Days
Edit

Cut

Copy

Paste

Clear

Select All

Mark

Shift+Del

Ctrl+Ins

Shift+Ins

Default

Work Day

Non−Work Day

Normal

Special

You can mark days of particular importance, such as major project
milestones, holidays, or birthdays. Marking a day alters the
display font of its number in the month and year displays so
that you can distinguish the day from other days in the various
Calendar displays.

To mark a day:

1. Select the desired day from any of the displays.

2. Pull down the Edit menu and display the Mark submenu.

Any items that already apply to the selected day are dimmed.

3. Choose the desired menu item from the Mark submenu:

Choose To Produce

Default The font a day had before it was marked with the
Work Day or Non-Work Day menu item.
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Choose To Produce

Work Day Bold font.

Once you choose the Work Day menu item,
the marked days continue to display as Work
even if you change the setting for that day of
the week to Non-Work in the dialog box of the
General... menu item on the Options menu.

Non-Work Day Standard Calendar font.

Once you choose the Non-Work Day menu
item, the marked days continue to display as
Non-Work even if you change the setting for
that day of the week to Work in the dialog box
of the General... menu item on the Options
menu.

Normal The font in which a day appeared before you
marked it with the Special menu item.

Special Bold, larger font; on color workstations, displayed
in red.

Working with Multiple Calendars
You can create, open, save, print, and delete calendars. You
can create different calendars to use for specific purposes.
For example, you could designate one calendar for business
appointments and another for social engagements.

You can use the Open... menu item to open a calendar even if you
do not have privileges to modify it. This feature lets you use a
calendar to share information.

For example, a group secretary can create a calendar for events
of groupwide interest, so that everyone on a team can see when
group activities occur. Only one person at a time can write in
this calendar, and you cannot read the calendar while it is being
modified. If no one is modifying the file, an unlimited number of
people can read it simultaneously. For more information about
making a calendar accessible to a group of people, see your system
manager.
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Creating a New Calendar
To create a new calendar:

1. Choose Open... or Open in New... from the File menu. Open...
opens the calendar in the current Calendar window, whereas
Open in New... opens the calendar in a separate window.
Either menu item displays a File Selection dialog box.

2. Enter a unique file name for the new calendar in the Selection
entry box, and click on OK. (On OpenVMS systems, Calendar
uses DWC as the default file type.)

A warning box states that the specified Calendar file does not
exist and asks whether you want to create a new file.

3. Click on Yes to create a new calendar.

By default, the new calendar is presented in a month display
containing the current day.

You can change the calendar file name later if necessary (see
Renaming a Calendar).

Opening an Existing Calendar
To open an existing calendar, follow the steps in the preceding
section (Creating a New Calendar), but specify the name of an
existing Calendar file in the file selection dialog box.

If you specify the name of a calendar that you are not allowed
to read, the Open operation fails and a message box is displayed
explaining the cause of the failure.

Renaming a Calendar
To rename the current calendar, choose Name As... from the File
menu. A dialog box is displayed.

Using Calendar 3–15



OK Cancel

Calendar: Name As

New File Name

Help
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In the text entry box, enter the new calendar name and click on
OK. (On OpenVMS systems, Calendar uses DWC as the default
file type.) You can rename only those calendars in which you are
allowed to write.

Closing a Calendar
If you have opened a calendar in a new window (Open in New...
from the File menu), you can close it without exiting Calendar by
choosing Close from the File menu.

If you have not opened the current calendar in a new window, the
Close menu item is dimmed.

Deleting a Calendar
To delete a calendar, choose Delete... from the File menu.
Calendar displays a warning box that asks whether you really
want to delete the calendar. If you do not have sufficient privileges
to delete the specified calendar, an error message is displayed.
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Customizing a Calendar

General...

Day View...

Icon...

Alarms...

Save Settings

Restore Settings

Restore System Settings

Options
You can specify many options to customize the appearance and
behavior of Calendar displays. These options fall into four
categories:

• General options define the work week, the start of the year,
and the behavior of various displays.

• Day View options control the size and content of components
of the day display, as well as other aspects of this display.

• Icon Box options control the content of the icon used when
you minimize the Calendar application. (This control does not
pertain to icons in the day display and Entry Editor; Day View
options control those icons.)

• Alarms options specify the default alarms for timeslot entries.

You can change these options by choosing menu items from the
Options menu. The following sections describe the options. For
information about the alarm option, see Setting Alarms.

Note

The defaults for many options vary depending on the
country for which Calendar is designed. For example, in
the American version the default time display is 12-hour
(AM and PM) and the default first day of the week is
Sunday. However, in some other versions the defaults
include 24-hour time display and Monday as the first day
of the week.

Customizing General Features
To customize general features of Calendar, choose General... from
the Options menu.

A dialog box is displayed.
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Calendar: General
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Show Week Numbers

Friday

Saturday
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January

MonthFirst View

Don’t Mark Past Days

Past Days
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Right to Left

From this dialog box, you can modify any of the following
Calendar options.

Work Week
Use the Work Week settings to identify the standard work days in
your work week.

The check buttons identify work days and nonwork days. The
settings affect the behavior of certain alarm repetition options (for
example, repeat monthly, but if a nonwork day, move the alarm
forward to the next work day).

Start Iconized
If you want Calendar to appear as an icon when it starts, click on
the Start Iconized check button.
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Show AM/PM
In its day display, Calendar has either a 12-hour time system,
using AM and PM to differentiate morning and afternoon/evening
timeslots, or a 24-hour time system, in which 1:00 PM becomes
13:00, 2:00 PM becomes 14:00, and so on.

For a 12-hour display, enable the Show AM/PM check button; for
a 24-hour display, disable the button.

’Live’ Scrolling
Normally, when you move the slider on the scroll bars in the day,
month, and year displays, the displays do not move until after
you have moved the slider. When you enable the ’Live’ Scrolling
check button, the displays change dynamically when you move the
slider.

Right to Left
If you enable the Right to Left check button, the time and day
note indicators and the entry handles appear on the right side of
the day view, and the vertical scroll bar appears on the left side of
all displays.

Fill Blank Days
If you enable the Fill Blank Days check button, any days at the
top and bottom of the month display that are not in the current
month appear in the display. If you disable the check button,
these days do not appear.

For example, assume that March 1 is a Friday and March 31 is a
Sunday. If you enable Fill Blank Days, February 24–28 and April
1–6 also appear (that is, if Sunday is the first day of the week).
If you disable Fill Blank Days, the days from February and April
are blank in the March display.

Print Blank Days
If you enable the Show Week Numbers setting, you can select a
week number and then choose Print... from the File menu to print
Calendar entries for that week.

If you enable Print Blank Days, all days in the selected week
print, whether or not you have entries in them.

If you disable Print Blank Days, days with no entries do not print.
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Box Current Day
If you enable the Box Current Day setting, Calendar puts a box
around the current day number.

Show Week Numbers
If you enable the Show Week Numbers setting, the leftmost
column in every month display lists the number of each week in
the year.

The date for week 1 is controlled by a separate option in this
dialog box.

First Day of Week
To designate the first day of the week in month displays, display
the Options menu and choose the correct day.

Date for Week No. 1
This option lets you specify the first week of the year. Its effect is
visible if you enable the showing of week numbers,

Use the Date for Week No. 1 option menu to choose the desired
month and use the slider to choose the desired day in that month.
For example, if your fiscal year starts the first week of July and
you want to designate that week as the first week of the year,
choose July from the list of months and choose a day number from
the first week. Note, however, that if you want to increase the
probability that the date always falls in the first full week of the
month, you should choose day 6.

First View
Use the First View Options menu to specify whether the day,
month, or year display appears when you start Calendar.

Past Days
Use the Past Days Options menu to determine whether or not
past days are marked and, if so, how:

• Don’t Mark Past Days — no marking

• Strike Out Past Days — marked with a slash

• Cross Out Past Days — marked with X
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Customizing the Day Display
You can customize the day display by choosing Day View... from
the Options menu.

The Day View dialog box is displayed.

Calendar: Day View
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From the Day View dialog box, you can modify any of the following
day display features:
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Timeslot Size
Use the Timeslot Size Options menu to specify the interval for
each timeslot.

Increment
In each timeslot, the resize knob lets you create a Calendar entry
that is larger or smaller than the timeslot size.

Use the Increment Options menu to specify the time that each
incremental resizing movement adds to or subtracts from the time
for the entry.

The Increment value is always less than the timeslot size. For
example, if your timeslot size is 30 minutes, the Hour option on
the Increment Options menu is dimmed because you can only
resize the entry in increments less than or equal to the timeslot
itself. The Increment value also always divides evenly into the
Timeslot Size value.

Stacking
Use the Stacking Options menu to control the display of
overlapping timeslot entries:

• Show Length — the left side of each entry is always visible.

• Show Text — the first line of each entry is visible.

By default, overlapping entries are stacked so that you always see
the left side of each entry. This is the effect of the Show Length
option on the Stacking Options menu.

To view a hidden or overlapped entry, click on its icon; the entry
moves to the top of the stack.

Calendar does not save any changes you make to the stacking
order for a given set of entries.

Horizontal Spacing
The Horizontal Spacing option lets you adjust the width of the
timeslots.

To modify the timeslot width, press and drag MB1 on the slider;
the greater the number, the greater the width.
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Vertical Spacing
The Vertical Spacing option lets you set the height of a timeslot
entry. The larger the number, the more readable the text. If you
select a smaller number, more timeslots are displayed in the same
space.

To modify the timeslot height, press and drag MB1 to select the
desired value. The available values are simply relative values.

Timebar Width
The Timebar Width option controls the thickness of the two
timebars. Timebars are vertical columns on the sides of the
timeslot area. One timebar represents just the times visible in the
window; the other timebar represents a 24-hour period. Working
hours, nonworking hours, and times with entries are distinguished
visually.

The greater the number, the thicker the timebar. If you select
zero (0), the timebars do not appear.

To modify the timebar width, press MB1 on the slider and drag to
the number you want.

Font Size
You can select small, medium, or large font for Calendar timeslot
entries. Your choice affects the size of the time values, text, and
timeslot boxes, as well as the number of timeslots what will fit
within the timeslot area of the day view.

Icon Size
You can select small, medium, or large for the size of icons that
appear in the handles of Calendar entries.

Working Hours
You can click on the hour and minute buttons as often as needed
to specify standard working hours.

In the timebars (vertical columns on the sides of the timeslot
area), working and nonworking hours are represented in visually
distinct ways.

Note that you can make any entries in any timeslot, whether or
not it is during standard working hours.
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Lunch Hours
You can click on the hour and minute buttons as often as needed
to specify a standard lunch period.

In the timebars (vertical columns on the sides of the timeslot
area), the lunch period is represented in the same way as
nonworking hours.

Note that you can make any entries in any timeslot, whether or
not it is during the standard lunch period.

Times on the Line
If you disable the Times on the Line setting, the starting time
of a timeslot is centered between the top and bottom lines of the
timeslot. If you disable the setting, the starting time of a timeslot
is centered in the top line of the timeslot.

Show Full Times
By default, timeslots that are not on the full hour display as the
number of minutes after the full hour. For example, the timeslot
for 2:00 is displayed as 2:00, but the timeslot for 2:30 is displayed
as 30.

To cause Calendar to display the hour as well as the minutes for a
timeslot that does not occur at the full hour, enable the Show Full
Times setting. This action causes 2:30 to be displayed as 2:30.

Show Day Notes
Normally, the day note entry box appears below the date in the
day display.

To remove the day note entry box, disable the Show Day Notes
setting. If you disable day notes, existing day notes are not
deleted; they just do not appear.

Show Months
By default, Calendar displays the current month and the next
month at the top of a day display. You can disable this option by
clicking on the Show Months setting.

Auto Click on Clock
You control autoscrolling (automatic scrolling of timeslots as the
day progresses) by clicking on the clock when you display the day
view. Enabling the autoclick option causes autoscrolling to start
when you open the day display (as if you had clicked on the clock
to start autoscrolling).
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If you disable Auto Click on Clock, autoscrolling is not in effect
when you first bring up the day display, and you must click on the
clock manually to start autoscrolling.

Flag
When you enable the Flag option, days that contain day notes or
timeslot entries are ‘‘flagged.’’ Flagging means that the font of the
specified day number changes in the month view to highlight that
day. On color workstations, the color of the flagged day number
also changes.

When you disable Flag, day numbers appear in the same font,
regardless of whether they contain day notes or entries.

Icon (day note and timeslot entry)
Directly under the word Icon are two buttons: the top button is
the default icon for day notes; the bottom button is the default
icon for timeslot entries.

To change the default icon for these types of entries, follow these
steps for each one:

1. Click on the appropriate button under the word Icon.

2. Click on the icon that you want to be the default for that type
of entry. The icon can be any of those displayed, regardless of
where it appears.

You can also associate multiple icons with a particular entry by
using the Entry Editor. For more information, see Creating a
Timeslot Entry.
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Customizing the Calendar Icon
You can customize the Calendar icon by choosing Icon Box... from
the Options menu.

The Icon dialog box is displayed.

OK Apply

Calendar: Icon box

Show Day Name

Show Time

Reset Cancel Help
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Full Day Name

From this dialog box, you can modify any of the following
Calendar icon options:

Text entry box
The text entry box lets you specify text to appear along with the
day name in the icon.

The check button to the left of the text entry box enables or
disables the display of the text.

Show Day Name
Use the Show Day Name option to enable or disable the display of
the name of the day of the week in the icon.

Full Day Name
Use the Full Day Name option to control whether the name of the
day is in abbreviated or full form.

Show Time
Use the Show Time option to control whether or not the time
appears in the icon.
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Saving Options and Restoring Defaults
To save your customized settings, choose Save Settings from the
Options menu. Your new settings are used whenever you start a
Calendar session. The sizes and placements of all your displays
are also saved.

To restore your settings to the currently saved defaults, choose
Restore Settings from the Options menu.

To restore your settings to the system defaults, choose Restore
System Settings from the Options menu.

Integrating Calendar Use with Other Applications
This section contains information and suggestions to help you
integrate your use of Calendar with other applications and
commands.

Using Hyperapplication Features

Visit

Show Links...

Step Forward

Go To

Go Back

Start Link

Turn Highlight Off

Show History...

Highlight...

Shift+Find

Alt+Find

Alt+Next

Alt+up

Alt+Selec t

Complete Link Alt+down

Complete Link...

Link Calendar is a hyperapplication. Through the Link menu, you
can make and follow links between pieces of information
(linkable objects). The information at the other end of any
link can be another Calendar object or an object accessed by
any other hyperapplication. For detailed information about
hyperapplications and the Link menu, see the chapter on
hyperapplication features in Using DECwindows Motif for
OpenVMS.

Calendar’s linkable objects are:

• Timeslot entry

• Day

• Month

• Year

For example, you can link a timeslot entry to another timeslot
entry, or to a Bookreader topic, or to a Cardfiler card. However,
you cannot link a portion of text within an entry to something
else.

Timeslot entries that are linked can be highlighted. If
highlighting is enabled, Calendar highlights linked entries by
including a light bulb icon in the entry handle. If highlighting is
not enabled and you want to see which entries have links, choose
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Turn Highlight On from the Link menu. (To prepare for the
reverse action, the menu item changes to Turn Highlight Off.)

Sending and Receiving Calendar Entries Through
Mail
You can send and receive calendar entries through electronic mail.
To do so, you must display both the Calendar entry (or just the
correct day view if you are receiving the entry) and a Create–Send
window in DECwindows Mail.

To send an entry through electronic mail, open a Create–Send
window in Mail. Select the entry from Calendar, then use MB2 to
perform a quick-copy operation on the entry into the Mail window.

To receive an entry through electronic mail:

1. Open the day view and use MB1 to select the text from an
existing mail message.

2. Use MB1 to give Calendar input focus.

3. Use MB2 to quick copy the mail message into Calendar.

You can also use the Copy and Paste items on the Edit menu to
copy information from calendar entries to mail messages and vice
versa.

Saving and Printing a Part of a Calendar

Open...

Open in New.. .

Include...

Close

Name As...

Delete...

Print...

Exit

File You can copy a timeslot entry or all of the entries in a day or a
week to a printable file.

To print a part of a Calendar display:

1. Display the day that relates to the entry or entries you want
to print.

For example, if you want to print a timeslot, display the day
that contains the timeslot. If you want to print the entries in
a day, display the day itself; to print the entries in a week,
display a day that falls in that week. You can also select the
day or week number that you want to print from any display
in which it appears.

2. Click on the time, day number, or week number, as
appropriate.

3. Choose Print... from the File menu.
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The Print dialog box is displayed.

Monday the 19th of December, 1994

OK Options...Cancel Help

Line Limit

1

CALENDAR.PS

Send File To Printer
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Calendar:Print

The Print dialog box shows the time period you selected and
provides a default name for the file you want to print. The
dialog box also lets you limit the number of lines you want
to print per entry by clicking on the Limit Lines per Entry
setting and moving the scale to set the desired limit.

4. If you want, you can change the default name provided by the
dialog box. Confirm your request by clicking on OK.

The requested section (timeslot, day, or week) is copied to the
named file. You can then send the file to a printer.

Exiting Calendar
To exit Calendar and close all open calendars, choose Exit from
the File menu.
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4
Using Cardfiler

Cardfiler lets you create an electronic box of index cards. This
electronic file box is called a card file. Card files contain cards,
which can hold any kind of information you like, such as names,
addresses, and telephone numbers. For example, you could have
a card file called Food that is filled with cards containing recipes
and names of restaurants.

By organizing your cards into card files, you can keep one group of
cards separate from another group; for example, you can separate
your business cards from your personal cards.

This chapter describes how to

• Start Cardfiler

• Create and add cards to a card file

• View topics in a card file

• Search a card file for text

• Edit a card

• Incorporate images

• Open an existing card file

• Save a card file

• Merge two card files

• Exit Cardfiler
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Starting Cardfiler
To start Cardfiler, choose Cardfiler from the Session Manager’s
Applications menu.

The Cardfiler window appears. Initially, the card file is empty, but
it fills up with index topics as you add cards.
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Cardfiler: untitled

HelpFile Link Search Card

Creating or Opening a Card File

Open...

Merge...

Save...

Save As

Print

Print...

Exit

Restore System Settings
Save Geometry

File You can create a card file first and then add cards to it, or you can
create cards and then save them into a card file. For example, you
could create a card file called Clients, and then fill it with cards
that contain the names and telephone numbers of your clients.

To create a new card file or open an existing card file:

1. Choose Open... from the File menu. The Select File dialog box
appears.
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Cardfiler: Select File

Filter

Selection
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FilesDirectories
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SUPPLIES.DIR

$USERS:[JONES]

Filter Cancel HelpOK

PLANNING.DIR

2. To create a new card file, click on the Selection entry box and
enter the name of the card file you want to create. By default,
card files have the file type CARD.

Click on OK. Cardfiler displays a message telling you the file
was not found and that a new file is being opened. Click on
Acknowledged.

3. To open an existing card file, double click on the name of the
file in the Files list box. The new card file appears.

If you try to open a new card file without first saving changes you
made to the current file, a dialog box appears and asks whether
you want to save your changes. To save your changes, click on
Yes. To discard your changes, click on No.
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Creating Cards
Card

Ctrl+CCreate Card

Cards contain units of information, such as a person’s name and
telephone number, and are organized in card files.

You can create a series of cards and save them in a card file, or
you can open a card file and then add cards to it. As you add
cards, they are sorted alphabetically according to the topic you
choose. Most likely, this topic will be the name of something, such
as a person or business. By displaying the topic of each card, the
card file window lists the contents of the card file.

To create a card:

1. Choose Create Card... from the Card menu.

A dialog box prompts you to enter the topic of the new card.

2. Enter the topic in the index entry box.

3. Click on OK.

Cardfiler displays a blank card in the card window. The text
you entered is added to the title bar at the top of the card
window and to the contents of the Cardfiler window.

4. Enter any information you want on the card.

Using the Return key, space bar, and Tab key, enter the
text as you want it to appear. Cards can contain up to 4000
characters and up to 64K bytes of images (see Adding Images
for more information).

5. When you are finished with the card, choose Close from the
File menu. The card window closes and the card is added to
your card file.

You can open another card in the card file without closing the
current card. When you choose Create Card... from the Card
menu in the Cardfiler window, Cardfiler automatically saves any
changes you made to the current card and returns it to the card
file before it opens a new card in the file.

If you create a series of cards before you create a card file, you can
save them in a new card file.

To save existing cards in a new card file:

1. Create your cards from the empty, untitled card file you see
when you start Cardfiler.

4–4 Using Cardfiler



2. Choose Save from the File menu to save cards under the index
topic you chose previously.

3. Choose Save As... from the File menu to save under a new file
name. The Select File dialog box appears.

In the Selection entry box, enter the name of the card file into
which you want to put your cards. For example, if you created
a series of cards that contain information about office supplies
your department purchased, you might name the card file
Supplies.

Click on OK. The new card file name appears at the top of the
Cardfiler window with a list of all the cards in that card file.

Viewing the Contents of a Card File

Cardfiler: untitled

Supplies

Diagrams

Numbers

Managers

HelpFile Link Search Card

Although you can look at only one card at a time, you can switch
easily from one card to another by selecting a card from the card
file window. When your card file contains too many cards to list in
a window, you can use the scroll bar to move through the file. You
can also search the contents of a card file for a given text string.

Opening an Existing Card
To display the contents of an exiting card, double click on the
card’s index topic.

The card’s topic becomes shaded and the contents of the card
appear in the card window.

Scrolling Through a Card File
As you accumulate cards, the cards cannot be listed all at once in
the card file window. To scroll through the list of cards in your
file, press and hold MB1 on the stepper arrow.

Locating Text
You can search a card file for any text string. The text can be a
word, a number, or any other characters that you can type on your
keyboard. Because Cardfiler treats spaces as text, you can search
for two or more words.

Cardfiler searches either the index topics or the contents of the
index cards.
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To search the index topics in a card file for specific text:

1. Choose Search Index... from the Search menu in the card file
window. A dialog box appears.

Cardfiler: Search Index
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Go to Card

CancelOK

2. In the text entry box, type the text string you want to locate.

3. Click on OK.

Cardfiler searches the topics of all cards in the file and displays
the first card in your file whose index contains the text string.

You can continue to search for a text string by choosing Find
Next from the Search menu in the Cardfiler window. Cardfiler
continues to search the card file for the text and displays each
card that contains that text.

To search the contents of each card in the card file for specific text:

1. Choose Search Card... from the Search menu in the card file
window. A dialog box appears.

Card: Search Card
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Find Text in Card

CancelOK

2. In the text entry box, type the text string you want to locate.

3. Click on OK.
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Cardfiler searches all cards in the file and displays the first card
that contains the text string.

You can continue to search for a text string by choosing Find Next
from the Search menu in the cardfile window. Cardfiler continues
to search the card file for the text and displays each card that
contains that text.

Editing a Card

Undo

Copy

Cut

Paste

Select Graphic

Deselect Graphic

Alt+Delete

Ctrl+Insert

Shift+Remove

Shift+Insert

Edit Cardfiler editing commands let you copy, delete, and rearrange
text on a card. If you decide you do not want to save your edits,
Cardfiler restores the card to its original state.

Renaming a Card
You can change the topic of a card by modifying its index topic.

To modify a card’s index topic:

1. Select the card you want to rename from the Cardfiler window
by pointing to the card and double clicking MB1.

2. Choose Rename... from the Card menu in the card window.

3. Use the arrow keys to move the text cursor. Use the Delete
key (<x ) to erase unwanted text.

4. Type the new topic under which you want to file the card.

5. Click on OK.

The card is renamed and remains displayed. If you want to close
the card, choose Close from the card’s File menu.

Moving the Text Cursor
When you create a new card, the text cursor appears in the upper
left corner of the card’s work area. When you open an existing
card, the text cursor remains where it was when you last edited
the card.

If you are creating a new card and want to move the text cursor,
use the Return key, or place the pointer where you want the text
cursor and click MB1. You can use this method to move the text
cursor on an existing card, or you can use the arrow keys to move
the text cursor anywhere in the existing text (except to the index
topic).
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Selecting Text
To delete, move, or copy text, you must first select that text.

To select text in a card:

1. Place the pointer at the start of the text. Press and hold MB1.

2. Drag the pointer over the text, then release MB1. This action
highlights the selected text. Cardfiler stores this text until
you are ready to use it.
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marketing expertise for manufacturers of
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Close

Deleting Text
To delete small amounts of text on your card, use the Delete key
(<x ). If you selected text for deletion, press any key to delete the
highlighted text.

Moving and Copying Text
Because Cardfiler saves the last text you selected and deleted, you
can move or copy text from one location on a card to another or
between cards.

To move or copy text within a card:

1. Select the text you want to move to another location on the
card.

2. Choose Cut or Copy from the Edit menu. Choosing Cut places
the text in the clipboard and removes the original, whereas
choosing Copy makes a copy of the original and places it in
the clipboard.
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3. Move the text cursor to where you want to insert the deleted
text by using the Return and arrow keys or by positioning the
pointer and clicking MB1.

4. Choose Paste from the Edit menu. The text appears in the
new location.

To move or copy text from one card to another:

1. Select the text you want to move or copy to another card.

2. Choose Cut or Copy from the Edit menu. Choosing Cut places
the text in the clipboard and removes the original, whereas
choosing Copy makes a copy of the original and places it in
the clipboard.

3. In the Cardfiler window, click on the topic of the card to which
you want to move the text. The new card appears.

4. Move the text cursor to where you want to insert the deleted
text by using the Return and arrow keys or by positioning the
pointer and clicking MB1.

5. Choose Paste from the Edit menu. The text appears in the
new location.

Adding Images
You can add images (graphics) to cards, such as those images you
create with Paint, Print Screen, and VAXimage Services. Cardfiler
places an image at the top of a card, keeping the picture’s original
size, and relocates text to the remaining space.

To add an image that has been saved as a file:

1. Open a card.

2. Choose Include Image... from the card window’s File menu.

A dialog box appears that lists all files in the current directory
that have the file type IMG.

3. Select one of the listed files, display a different set of files
using the File Filter, or type the name of the file you want in
the Selection entry box.

Click on OK. The image appears on the card. If the image is
larger than the current size of the card, you can enlarge the
window by dragging the window’s border.
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To copy part or all of an image directly from the Paint application:

1. Display the image you want to use in the Paint window.

2. Select the portion of the image you want to copy to your open
card.

3. Choose Cut or Copy from Paint’s Edit menu. Choosing Cut
causes the image to disappear from the Paint window, whereas
choosing Copy simply makes a copy of it.

4. Give the opened card input focus by clicking on it, and choose
Paste from the Edit menu.

The image appears on the card. If the image is larger than the
current size of the card, you can display enlarge the window
by dragging the window’s border.

You can also copy images from a card to Paint and between cards
by selecting the image, copying it to the clipboard, and pasting it
in the new location.

To delete an image from the card:

1. Select the image by clicking on it. Alternatively, you can
choose Select Graphic from the Edit menu.

2. Choose Cut from the Edit menu. Cardfiler deletes the image.
To restore the image, choose Undo from the Edit menu.

Using Hyperapplication Features

Visit

Show Links...

Step Forward

Go To

Go Back

Start Link

Turn Highlight Off

Show History...

Highlight...

Shift+Find

Alt+Find

Alt+Next

Alt+up

Alt+Selec t

Complete Link Alt+down

Complete Link...

Link Cardfiler is a hyperapplication. Through the Link menu,
you can make and follow links between pieces of information
(linkable objects). The information at the other end of any
link can be another Cardfiler object or an object accessed by
any other hyperapplication. For detailed information about
hyperapplications and the Link menu, see the chapter on
hyperapplication features in Using DECwindows Motif for
OpenVMS.

Cardfiler’s linkable object is any card. For example, you can link
one card to another. You can also link a card to a Mail message.
However, you cannot link a sentence within a card to anything.
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If highlighting is enabled, Cardfiler highlights linked objects by
using the light bulb icon. If highlighting is not enabled and you
want to see which objects have links, choose Turn Highlight On
from the Link menu. (To prepare for the reverse action, the menu
item changes to Turn Highlight Off.)

Saving a Card File
Whether you create a new card file or make changes to an existing
card file, such as adding or deleting a card or changing any
information on a card, you need to save that card file when you
are finished working with it.

To save a new card file or change the name of an existing one:

1. Choose Save As... from the File menu in the Cardfiler window.

The Select File dialog box appears, prompting you for the
name of the file.

2. Using the Delete key (<x ) and the arrow keys, delete any text
in the Selection entry box and type in the name of the file.
The default file type for card file names is CARD.

3. Click on OK.

If you saved a new card file, notice that the name of the card
file in the title bar has changed from ‘‘untitled’’ to the new file
name. If you changed the name of an existing card file, the
new file name replaces the previous one.

To save the current card file, choose Save from the File menu in
the Cardfiler window.

Merging Card Files
You can merge the contents of the current card file with another
card file to create a card file that combines and sorts the contents
of both files. The card file whose contents were merged with the
current card file remains unchanged.

To merge the contents of the current card file with another card
file:

1. Choose Merge... from the File menu on the Cardfiler window.
A dialog box appears.
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2. In the Files list box, double click on the name of the file you
want to merge with the current file. The contents of the two
card files are merged and sorted alphabetically.

Saving Customized Settings
If you change the size or screen position of Cardfiler and would
like to save the new settings, choose Save Geometry from the File
menu. The new settings are used in future sessions. To restore
the system defaults, choose Restore System Settings from the File
menu.

Exiting Cardfiler
To exit Cardfiler, choose Exit from the File menu in the Cardfiler
window.

If you have not saved any changes or additions to the current file,
Cardfiler displays a dialog box:
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Cardfiler: Exit Question

Do you want to save the current data
before exiting?

Cancel No

?

Yes

• To save your changes and exit Cardfiler, click on Yes.

• To exit Cardfiler without saving your changes, click on No.

• To return to the Cardfiler window, click on Cancel.
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5
Using CDA Viewer

CDA Viewer displays the contents of compound documents and
graphics, image, and text files on your screen. CDA Viewer works
with the CDA converters. Therefore, the converters that are
installed on your system determine the specific file types that you
can view.

This chapter describes how to

• Start CDA Viewer

• View files

• Specify POSTSCRIPT paper size options

• Control the Files list box

• Specify supported file formats

• Create an options file

• Specify supported processing options

• Exit CDA Viewer

Starting CDA Viewer
Start CDA Viewer by either of the following methods:

• Choose CDA Viewer from the Session Manager Applications
menu.

• At the VMS prompt, enter the following DCL command:

$ VIEW/INTERFACE=DECWINDOWS

The CDA Viewer window appears. A dialog box (Open) also
appears, which lets you select the file to be displayed. The Open
dialog box includes buttons for Options File and Paper Size, each
of which activates a separate dialog box in which you can specify
optional instructions about how the file should look.
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Open

File Filter

AREA_CHART.DDIF;1

Files

$USERS:[JONES]

BOX_PARTS.DDIF;1

WALL.DDIF;1

CDA_ICON.DDIF;1
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DDIF_EXAMPLE.DDIF;3

File Format

DDIF

Open File

^

Directories

OK

Options File...

Filter

Display Options...

Cancel Help

Page...

c

DDIF
DTIF
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TEXT
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Viewing Files
The following steps form the basic procedure for viewing a file:

1. In the Directories list box, click on the name of the directory
that contains the file you want to view.

2. In the File Format list box, click on the format name (also
called the keyword) that applies to the file. If you do not
know the format, refer to Specifying Supported File Formats
in this chapter for more information.

3. (Optional) Click on Options File... to open a dialog box that
lets you select an existing options file to control the display.
(Refer to Creating an Options File and Specifying Supported
Processing Options in this chapter for information describing
how to create an options file and supported processing
options.) In the Directories list box, click on the name of the
directory that contains the options file. Then select the file
from the Files list box.

Options File

Options File Filter

$USERS:[JONES]*.CDA$OPTIONS

Options File

^

Directories Files
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MY_OPT.CDA$OPTIONS;1
PS_OPT.CDA$OPTIONS;7

HelpCancelFilterOK
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Note

By convention, options file names include the extension
CDA$OPTIONS. If your file name does not follow this
convention, the file will not be listed unless you modify the
Options File Filter entry box to match the actual file name
and then click on the Filter button.

4. (Optional) Click on Display Options... to open a dialog box in
which you can set the size of the display. The paper size you
specify is used only if the document has no inherent format
(page size) or if you override the document’s format.

You can select a paper size from the available list, or you can
supply your own values in characters,1 inches, or millimeters.
To supply your own values, first click on the desired unit of
measurement; then enter the desired values in the Width and
Height entry boxes.

Click on the Override Document Format if you want to
override the existing format with your own.

The Display Options dialog box includes several options that
apply only to POSTSCRIPT files. If you specify any format other
than POSTSCRIPT, the check buttons for these options are
dimmed. Refer to Specifying PostScript Display Options in
this chapter for an explanation of these options.

Click on the OK button to return to the Open dialog box.

1 The characters unit corresponds to the size of a character in the
12-point Courier font, which is CDA Viewer’s default font and which is
also similar to the standard font used by most printers. In 12-point
Courier, and in the character unit as interpreted by CDA Viewer, there
are 10 columns per inch (0.1 inch per character horizontally) and 6
rows per inch (0.167 inch per character vertically).

5–4 Using CDA Viewer



ZK−2688A−GE

Display Options

A0

A1

A2

A3

Default Paper Size Width

Height

characters

inches

mm

Override Document Format

Additional PostScript (PS) Options

Use Comments

Use Bitmap Widths

Use Fake Trays

Watch Progress

Scale Factor

Orientation

1.0

OK Cancel

^

Using CDA Viewer 5–5



Note

Processing options, paper size values, and the Override
Document Format option apply only to the next file you
open. The appearance of the currently displayed document
does not change.

5. In the Files list box, double click on the name of the file that
you want to view, or click on the file name and then click on
OK.

Note

If the Files list does not include the file that you want
to view, refer to Controlling the Files List Box in this
chapter.

The Open dialog box closes, and the selected file is displayed
in the CDA Viewer window. The title bar shows the name
of the file, as does the CDA Viewer icon. The number of the
currently displayed page and the total number of pages appear
in the lower right corner of the window.

You can do the following things:

• Move through the file. Click on the inner arrow buttons
at the bottom of the window to move forward or backward
one page, or on the outer arrow buttons to move to the
beginning or end of the document. You can also specify
a page number by clicking on the Page... button and
entering the desired page number in the Page dialog box.

• Halt POSTSCRIPT processing. If you are viewing a
POSTSCRIPT file, a Cancel button is displayed at the
bottom of the window. While CDA Viewer is formatting a
page, you can click on Cancel to stop processing. Clicking
on this button does not close the file; it merely halts
processing of the current page.

• Display information about the file you are viewing.
Choose Document Information... from the File menu. If
the file contains the information, CDA Viewer displays the
product name (the name of the application that produced
the file), title, author, version, and creation date.
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• Display diagnostic information. Choose Diagnostic
Information... from the File menu to display information
such as warnings and errors that occurred while you were
formatting the file. (This menu selection is dimmed if no
diagnostic information is available.)

• Close the file. Choose Close File from the File menu to
clear the display.

• Open a new file. Choose Open File... from the File menu
and repeat from step 1.

• Exit CDA Viewer. Choose Quit from the File menu.
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Viewing Files With Audio Content
If you open a DDIF document with audio content, CDA Viewer
displays an audio button next to the arrow buttons at the bottom
of the window.

The audio button looks like one of the following:
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The solid audio button indicates that there is audio content on
the page being displayed. When you click on this button, CDA
Viewer displays one or more audio buttons on the page. These
audio buttons indicate the location of the audio content on the
page; click on these buttons to play back the audio content.

When you click on the solid audio button in the bottom of the
window, the button changes to the button with the X through it.
Click on this button to disable the display of the audio buttons on
the page.

The outline audio button indicates that there is audio content in
the document, but there is none on the page being displayed.

Note

Special hardware is required to enable the playback
of audio content. If your computer does not have this
hardware, you will not hear any sound when you click on
the audio buttons in the document.

Specifying PostScript Display Options
The following options appear in the Display Options dialog box
and are valid for POSTSCRIPT files only:

• Orientation radio box
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The Orientation radio box lets you specify the orientation for
displaying POSTSCRIPT files. By default, CDA Viewer displays
files in the same mode (portrait or landscape) in which they
were created. You can use the Orientation radio box to select
different orientations to view files in reverse landscape mode
or upside down.

• Scale Factor slider

The Scale Factor option lets you scale the page display size of
your POSTSCRIPT file. The number you select tells CDA Viewer
to shrink or enlarge the page display. If the scale factor is less
than 1.0, the page display shrinks. If the number is greater
than 1.0, the page display expands.

You can specify a scale factor in the range of 0.1 to 4.0 times
the size of the original page display. By default, a typical page
display has a scale factor of 1.0. Using a scale factor greater
than 1.0 can result in slower processing.

• Use Comments check button

The Use Comments option tells CDA Viewer to interpret File
structure comments that often appear in POSTSCRIPT files.
This enables CDA Viewer to detect the location of page breaks
in a POSTSCRIPT file, for example.

The Use Comments option is enabled by default. This is
indicated by the highlighted Use Comments check button.

You can disable the Use Comments option by clicking on it
before opening your POSTSCRIPT file. This is recommended in
instances where the POSTSCRIPT file contains comments that
are not correct, causing the CDA Viewer either to display the
POSTSCRIPT file incorrectly or to generate an error message.
In most cases, disabling the Use Comments option and
reopening the file corrects the problem.

• Use Bitmap Widths check button

The Use Bitmap Widths option adjusts the display of your
POSTSCRIPT file for improved viewing on the screen. By
default, a printed POSTSCRIPT file has a finer resolution, or
more dots per inch, than a POSTSCRIPT file displayed on a
screen. If you try to view the printed format of a POSTSCRIPT
file on line, the page layout is the same, but the text might be
dense and difficult to read.

5–10 Using CDA Viewer



To clarify your POSTSCRIPT file for online viewing, you can
specify the Use Bitmap Widths option so that CDA Viewer
uses spacing formulas designed for bitmaps (screen images)
instead of those designed for print.

The Use Bitmap Widths option is disabled by default. If you
choose the Use Bitmap Widths option, the next time you open
a POSTSCRIPT file, CDA Viewer uses bitmap widths to display
your file. Text characters appear well spaced and easy to
read. However, the file might look slightly different on screen
than it would when printed. Columns might not be aligned
precisely, or a paragraph formatted for right justification
might appear with a ragged right margin instead.

• Use Fake Trays check button

The Use Fake Trays option lets you view a POSTSCRIPT file
that contains tray-size directives. Tray-size directives are
instructions that tell the printer what paper tray size to use.
These directives, however, are specific to certain printers (such
as the LPS40) and are not part of the Display POSTSCRIPT
language.

By default, CDA Viewer ignores tray size directives if you
try to display a POSTSCRIPT file that contains them. To
override that default behavior and view tray size directives
in a POSTSCRIPT file (to identify occurrences of nonstandard
POSTSCRIPT for example), click on the Use Fake Trays option
and reopen the file.

• Watch Progress check button

The Watch Progress option lets you view a POSTSCRIPT file
while it is being processed for display in the CDA Viewer
window. You can view a page as it is being processed,
rather than waiting to view the entire page after it has been
processed.

Controlling the Files List Box
Choosing from the Files list box is often the simplest way to
specify the file that you want to view, and the file selection
window is designed to make it as easy as possible to do so.
However, in some cases you might need to do one of two things:
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• Enter the file specification directly in the Selection entry box.
(You always have this option as an alternative to choosing a
file name from the list.)

• Modify the entry in the Options File entry box, called the
filter mask, in order to display a list that includes the desired
file.

To choose the file from a list (rather than enter the specification
directly), you must modify the filter mask if either of the following
conditions is true:

• The file is located on a node other than the node where you
are logged on. In this case, modify the beginning of the filter
mask to include the correct node.

Note

If you change the node specification, be sure to check the
directory specification. The filter mask must not refer to a
directory that is not valid on the specified node.

• The file name does not include the default extension for the
specified format. (The default extension appears in the filter
mask when you click on the format name.) In this case,
modify the end of the filter mask to include the extension
actually used in the file name.

After modifying the filter mask, click on Filter (or press Return).
If you changed the node specification, double click on the correct
directory name. Then select the desired file.

Specifying Supported File Formats
The file format you specify depends on the application (or the
conversion) that produced the file you want to view.

The following table summarizes the file formats supported by CDA
converters on all systems running DECwindows Motif software.
Your system might also support converters for additional formats.
All formats that are supported on your system are listed in the
Open dialog box.
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Keyword Description
Default File
Extension

DDIF DIGITAL Document Interchange
Format files created by and for
applications such as DECwrite and
DECchart

DDIF

DTIF DIGITAL Table Interchange Format
files created by and for applications
such as DECdecision

DTIF

PS POSTSCRIPT files to be printed on
supported output devices

PS

TEXT Text files that can be edited with a
text editor

TXT

Note

You can view POSTSCRIPT files only if the Display
POSTSCRIPT Extension is installed on your server. If the
server does not have this software, the PS (POSTSCRIPT)
choice does not appear in the Open dialog box.

Most formats have an associated default file extension. The
preceding table includes the default file extension for each
supported format. The default extension for the format that you
select automatically appears in the filter mask, which determines
which files are listed. For example, if you specify the TEXT
format, the filter mask ends in TXT, and the Files list box shows
files with that extension.

Not all file names have the default extension for their format. You
must specify the actual format of the input file, regardless of its
extension.

Creating an Options File
You can create an options file prior to starting the CDA Viewer
application. An options file is a text file with a default file
extension of CDA$OPTIONS.

The options file contains all the processing options for your input
file format. Processing options help ensure minimal format and
content changes while CDA Viewer processes your input file for
display.
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An options file is not required. Default processing options are
applied automatically when you open a file for display. However,
you might require an options file if you need to use a setting other
than the default.

Use the following guidelines to create an options file:

• Begin each line of the options file with the keyword for the
input format, followed by one or more spaces or tabs or by a
slash ( / ).

• Specify only one processing option on each line.

• Use uppercase and lowercase alphabetic characters, numerals
(0–9), dollar signs ( $ ), and underscores ( _ ) to specify the
processing options.

• Use one or more spaces or tabs to precede values specified for
a processing option.

Specifying Supported Processing Options
You can create an options file containing processing options that
apply to any CDA supported tabular file format for which there is
an input converter. Data tables and spreadsheets are examples of
tabular file formats.

Precede each of these processing options with the DTIF_TO_DDIF
format name. DTIF (Digital Table Interchange Format) is a
standard format for the storage and interchange of data table and
spreadsheet files.

The following list describes the DTIF_TO_DDIF processing
options.

COLUMN_TITLE
Displays the column titles as contained in the column attributes
that are centered at the top of the column.

CURRENT_DATE
Displays the current date and time in the bottom left corner of
the page. The value is formatted according to the document’s
specification for a default date and time.
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DOCUMENT_DATE
Displays the document date and time as contained in the
document header in the top left corner of the page. The value is
formatted according to the document’s specification for a default
date and time.

DOCUMENT_TITLE
Displays the document title or titles as contained in the document
header that is centered at the top of the page, one string per line.

PAGE_NUMBER
Displays the current page number in the top right corner of the
page.

PAPER_SIZE
Sets the paper size. Valid values are as follows:

Value Size

A0 841 x 1189 mm (33.13 x 46.85 in)

A1 594 x 841 mm (23.40 x 33.13 in)

A2 420 x 594 mm (16.55 x 23.40 in)

A3 297 x 420 mm (11.70 x 16.55 in)

A4 210 x 297 mm (8.27 x 11.70 in)

A5 148 x 210 mm (5.83 x 8.27 in)

B4 250 x 353 mm (9.84 x 13.90 in)

B5 176 x 250 mm (6.93 x 9.84 in)

C4 229 x 324 mm (9.01 x 12.76 in)

C5 162 x 229 mm (6.38 x 9.02 in)

DL 110 x 220 mm (4.33 x 8.66 in)

10x13_ENVELOPE 13 x 254 mm (15.600 x 10 in)

9x12_ENVELOPE 12 x 229 mm (14.400 x 9 in)

BUSINESS_ENVELOPE 9.5 x 105 mm (11.400 x 4.13 in)

EXECUTIVE 10 x 191 mm (12.000 x 7.5 in)

A 8.5 x 11 in

B 11 x 17 in

C 17 x 22 in
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Value Size

D 22 x 34 in

E 34 x 44 in

LEDGER 11 x 17 in

LEGAL 8.5 x 14 in

LETTER 8.5 x 11 in

LP 13.7 x 11 in

VT 8 x 5 in

The A paper size (8.5 x 11 inches) is the default.

PAPER_HEIGHT
Selects a paper height, in combination with the DTIF_TO_
DDIF PAPER_WIDTH processing option, other than one of the
predefined values provided. The default paper height is 11 inches.

PAPER_WIDTH
Selects a paper width, in combination with the DTIF_TO_DDIF
PAPER_HEIGHT processing option, other than one of the
predefined sizes provided. The default paper width is 8.5 inches.

PAPER_TOP_MARGIN
Selects the width of the margin provided at the top of the page.
The default value is 0.25 inches.

PAPER_BOTTOM_MARGIN
Selects the width of the margin provided at the bottom of the
page. The default value is 0.25 inches.

PAPER_LEFT_MARGIN
Selects the width of the margin provided on the left side of the
page. The default value is 0.25 inches.

PAPER_RIGHT_MARGIN
Selects the width of the margin provided on the right side of the
page. The default value is 0.25 inches.
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PAPER_ORIENTATION
Selects the paper orientation to be used in the output file. The
valid values for the orientation argument are as follows:

Keyword Meaning

PORTRAIT The page is oriented so that the larger
dimension is the vertical axis.

LANDSCAPE The page is oriented so that the larger
dimension is the horizontal axis.

The default is PORTRAIT.

Exiting CDA Viewer
To exit CDA Viewer, choose Quit from the File menu.
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6
Using Clock

Clock displays the time (in both analog and digital format) and
the date. You can change the Clock display to suit your needs.
You can also set Clock’s alarm to remind you of appointments.

This chapter describes how to

• Start Clock

• Customize the Clock display

• Set the alarm

• Exit Clock

Starting Clock
To start Clock, choose Clock from Session Manager’s Applications
menu.

The Clock display appears on your screen. You can move and
change the size of the display.

HelpFile Options

Clock

Oct 08 Tue

09:00 AM
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Customizing the Clock Display
You can customize the Clock display to include any combination of
the date and time regions.

To change the Clock display, choose Display... from the Options
menu.

Clock displays the Display Options dialog box.
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Clock: Display Options

OK Cancel

Analog

Menu Bar

Digital Date

24 Hour Digital Time

Shaded (enabled) check buttons indicate the current settings.
To change the setting, click MB1 on a check button or its label.
For example, if you want only the analog clock displayed and the
Analog, Digital, and Date check buttons are shaded, click on the
Digital and Date check buttons to disable those settings.

To use the current settings, click on OK. To return to the date and
time display without changing any settings, click on Cancel.

If you disable the menu bar, you can use a pop-up menu to
customize the Clock display:

1. Place the pointer anywhere in the Clock display.

2. Press and hold MB3. A pop-up menu appears.

3. Drag to the Display... menu item.

4. Release MB3. The Display Options dialog box appears.

To save the new settings and the size and placement of the Clock
display on the screen:

1. Make any desired changes to the size, position, and settings of
the Clock display.
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2. Choose Save Settings from the Options menu or the pop-up
menu.

To restore the system defaults, choose Restore System Settings
from the Options menu or the pop-up menu.

Setting the Alarm
You can set the alarm to remind you of an appointment.

To set the alarm

1. Choose Alarm... from the Options menu.

The Alarm Options dialog box appears.
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Clock: Alarm Options

Alarm Settings
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Volume
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2. In the entry box for the hour of the day, type the hour you
want the alarm to sound.
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You can use a 12-hour clock, in which case you need to specify
AM or PM, or you can use a 24-hour clock (military time).

To erase a number that you previously entered or to correct
typing mistakes, use the Delete key (<x ).

3. In the entry box for the minutes of the hour, finish entering
the time you want the alarm to sound.

4. If you are using a 12-hour clock or if the time you specify is
earlier than 13:00, click on either the AM or PM radio button.

5. To display a message on your screen when the alarm sounds,
type your message in the Alarm Message entry box. Alarm
messages can contain up to 200 characters.

6. To use the current settings, click on OK. To return to the date
and time display without changing the previous settings, click
on Cancel.

When the alarm sounds, click on OK in the dialog box to clear the
alarm message from your screen.

Exiting Clock
To exit Clock, choose Exit from the File menu or the pop-up menu.
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7
Using DECsound

DECsound is a software application that you can use to play
and record audio messages, which you can mail to other users or
include in documents.

This chapter describes how to

• Start DECsound

• Use the DECsound control panel

• Make an audio recording

• Play an audio recording

• Edit an audio recording

• Use LiveLink connections

• Mail audio recordings

• Exit DECsound

Starting DECsound
You can start a DECsound session in any of the following ways:

• Using Session Manager or FileView

To start DECsound from Session Manager or FileView, choose
DECsound from the Applications menu. If the Applications
menu does not contain a DECsound menu item, contact your
system manager.

• Using LiveLink connections

You can make LiveLink connections from DECwrite (see Using
LiveLink Connections).

• Using the command line
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To start DECsound from the operating system command line
on an OpenVMS system, enter one of the following commands:

$ RUN SYS$SYSTEM:DECSOUND

You can also define a symbol on the command line or in your
LOGIN.COM file, as follows:

$ DECSOUND :== $DECSOUND

If you define a symbol, you can specify the qualifiers that
control how the DECsound session executes (see Table 7–1).

Table 7–1 Starting DECsound Sessions from the Command Line
Using Qualifiers

Qualifier Description

-file file-spec Starts a DECsound session. If the file exists,
the DECsound window displays the recording.
If the file does not exist, DECsound creates a
new recording. If you do not specify a file type,
DECsound adds the default .AUD file type.

-headphone Plays the DECsound recording to the headphone
jack on your workstation. DECsound ignores the
-headphone qualifier if you do not also specify the
-play qualifier.

-icon Creates a DECsound file that includes an icon.
This qualifier is useful when you make recordings
that you want to include in DECwrite documents,
because the resulting data block in the document
displays an icon that indicates the presence of a
DECsound recording. This option is available for
DECwrite Version 2.1 only.

If you do not insert the icon, the DECsound data
block can be difficult to locate in a document.
However, if you do insert the icon, the icon is also
displayed when you print the document.

-play file-spec Plays the specified file without displaying the
DECsound window.

-speaker Plays the DECsound recording on your workstation’s
built-in speaker. DECsound ignores the -speaker
qualifier if you do not also specify the -play
qualifier.

(continued on next page)
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Table 7–1 (Cont.) Starting DECsound Sessions from the
Command Line Using Qualifiers

Qualifier Description

-volume n Specifies the playback volume, where n is an
integer between 0 and 100. DECsound ignores
the -volume qualifier if you do not also specify the
-play qualifier.

Note

You can specify either the -speaker qualifier or the
-headphone qualifier, but you must not specify both. If you
specify both of these qualifiers, DECsound uses the one
that is last in the command line.

The following example shows how to invoke DECsound to play the
BIRDS.AUD file at a playback volume of 50 without displaying
the DECsound window:

$ DECSOUND -play BIRDS.AUD -volume 50

DECsound Files
DECsound files have a file type of .AUD by default. When you
specify a file name for a DECsound file, you do not need to enter
the default .AUD file type. DECsound adds the default file type
automatically.

DECsound can also read audio files created on Sun™
workstations. These files have a file type of .AU, so when you
open these files, you must specify the .AU file type.

DECsound creates files in the DDIF format. DDIF (Digital
Document Interchange Format) is the standard document format
used by CDA, a component of Digital’s NAS architecture that
defines standards for compound documents and enables file
interchange among all compliant applications.

DECsound is supplied with a number of sample files of file types
.AUD and .AU. These files are located in the DECW$EXAMPLES
directory.
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Clipboard
Like many other windows-based applications, DECsound includes
a clipboard, which is a temporary (invisible) storage area. When
you cut or copy part of a DECsound recording, DECsound stores
the selected part of the recording in the clipboard. When you
use the Paste menu item, DECsound pastes the contents of the
clipboard into the recording.

The clipboard stores only the most recently cut or copied part
of a recording. When you cut or copy part of a recording to the
clipboard, the recording overwrites the current contents of the
clipboard.

Each DECsound session uses a separate clipboard; you cannot use
the Edit menu to cut and paste between two DECsound sessions.
If you need to cut and paste between two DECsound sessions, you
can do so using the mouse, as follows:

1. Choose Display Energy or Display Samples from the View
menu in both DECsound sessions to display the waveforms.

2. Drag MB1 across the waveform to select the part of the
recording you want to cut from the first DECsound session.

3. Position the pointer at the spot in the second waveform where
you want to insert the part of the recording.

4. Click MB2 to paste this recording to the second DECsound
session.
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Using the DECsound Control Panel
When you start a DECsound session, DECsound displays a control
panel, as follows:

HelpViewFile Edit
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Options

DECsound: BIRDS.AUD;2

Volume

Standby Length: .0 Sec

.0

Stop Play Record Rewind Forward

Save Exit

The main functions of the control panel are similar to those of a
tape recorder.

• Stop

Click on the Stop button to stop a play or record operation.

• Play

Click on the Play button to play a recording. While playing
the recording, DECsound displays Playing... in the bottom left
corner of the DECsound window.
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• Record

To start recording, click on the Record button and speak
into the microphone. While recording is in progress,
DECsound displays Recording... in the bottom left corner
of the DECsound window.

• Rewind

To rewind a recording, click on the Rewind button. Each
time you click on the Rewind button, DECsound rewinds the
recording by 1 second. To rewind continuously, press and
hold MB1. DECsound displays the length of the recording, in
seconds, in the bottom right corner of the DECsound window.

• Forward

To advance through a recording, click on the Forward button.
Each time you click on the Forward button, DECsound
advances the recording by 1 second. To advance continuously,
press and hold MB1. DECsound displays the length of the
recording, in seconds, in the bottom right corner of the
DECsound window.

The control panel also contains a Save button, an Exit button, and
sliders for the following:

• Volume control

The Volume slider allows you to control the volume when you
play DECsound recordings.

ZK−6695A−GE

Volume

30

Move the slider to the right to increase the volume. Move it
to the left to decrease the volume. The Volume slider also
indicates the volume level as a percentage of the full volume.
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• Current position in a recording

The Position slider indicates the current position in the
recording. In the following figure, the current position is the
start of the recording.

Standby Length: 3.5 Sec

.0

ZK−6696A−GE

Making an Audio Recording
This section describes how to make an audio recording in
DECsound.

To make a DECsound recording, follow these steps:

1. Choose New from the File menu to start a new recording.

2. Click on the Record button and speak into the microphone or
headset.

3. Click on the Stop button to stop recording.

The Position slider shows the length of the recording.

Making Long Recordings
DECsound allows you to specify the maximum length of a
recording using the Max. Length slider in the Settings dialog
box, as shown in the following figure:
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DECsound: Settings

Play Settings

Record Settings

Internal Speaker

Headphone Jack

2.0 75

Level (%)Max. Length (minutes)

30

Level (%)

Save HelpOK Cancel

The size of a recording is limited by the amount of free memory
available on the system. In some cases, while you are making
a long recording, DECsound displays a message informing you
that there is insufficient memory before your recording reaches
the maximum recording length. If this happens, take one of the
following actions:

• Save the recording and restart DECsound in one of the
following ways:

Click on the Save button.

Choose Save or Save As... from the DECsound File menu.

• Decrease the maximum recording length.
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Save Settings

Settings...

Auto Repeat 

Options 

Restore Saved Settings

Choose Settings... from the Options menu to display the
Settings dialog box. In the dialog box, use the Max. Length
slider to decrease the maximum recording length.

• Ask your system manager to increase the memory quotas for
your account.

When you open a DECsound recording that is longer than the
maximum recording length, you cannot record new material onto
the end of that recording. However, you can bypass this problem
by following these steps:

1. Choose Display Energy or Display Samples from the View
menu.

DECsound displays the waveform for the recording.

2. Choose Select All and then Cut from the DECsound Edit menu
to transfer the record clipboard.

3. Click on the Record button to record the message that you
want to add to the existing recording.

4. Click on the Stop button when you finish recording.

5. Position the pointer at the start of the recording, and choose
Paste from the Edit menu to insert the original recording.

Inserting New Material in a Recording
If the DECsound window already contains a recording when you
click on the Record button, DECsound adds the new recording
to the end of the current recording. To insert new material in a
recording, follow these steps:

1. Position the pointer where you want to insert the new
material and click MB1.

2. Drag MB1 to the end of the recording, and choose Cut from
the Edit menu to remove the selected part of the recording.

3. Click on the Record button and record the new material.

4. Position the pointer at the end of the recording, and choose
Paste from the Edit menu to complete the new recording.
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Playing an Audio Recording
DECsound allows you to play all or part of a recording. To play all
of a recording, click on the Play button.

The Position slider adjusts to indicate the current position in the
recording.

Play part of a recording as follows:

Display Samples

Display Energy

Hide Waveform Display  

View 1. Choose Display Energy or Display Samples from the View
menu.

DECsound displays the waveform for the recording. The
following figure shows the Display Samples waveform, which
displays the amplitude of the audio waveform:
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Options

DECsound: BIRDS.AUD;2

Volume

Standby Length: 3.5 Sec

.0

30

8

Zoom

Stop Play Record Rewind Forward

Save Exit

Note that the Zoom slider is also displayed. The Zoom slider
allows you to view the DECsound waveform in greater or
lesser detail. Move the slider to the left to view the waveform
in greater detail. Move the slider to the right to view the
waveform in lesser detail.
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2. Select part of the recording by dragging MB1 across the
waveform.

DECsound highlights the selected part of the recording.

3. Click on the Play button.

DECsound plays only the part of the recording that you have
selected.

Editing an Audio Recording
DECsound allows you to perform editing operations on your
recordings. This section describes how to

• Select a recording

• Cut a recording

• Copy a recording

• Delete a recording

Selecting a Recording
DECsound allows you to select all or part of a recording for
editing, as follows:

• Selecting an entire recording

To select an entire recording, choose Select All from the Edit
menu.

When you choose an edit operation after selecting the entire
recording, the edit operation applies to the entire recording.

• Selecting part of a recording

Before you can edit a recording, you must select the part of the
recording that you want to modify. Select part of a recording,
as follows:

1. Choose Display Energy or Display Samples from the View
menu.
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Display Samples

Display Energy

Hide Waveform Display  

View DECsound displays the waveform for the recording. The
following figure shows the Display Energy waveform,
which displays the variations in audio energy levels in the
waveform:

HelpViewFile Edit
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Options

DECsound: BIRDS.AUD;2

Volume

Standby Length: 3.5 Sec

.0

30

8

Zoom

Stop Play Record Rewind Forward

Save Exit

2. Drag MB1 across the waveform.

DECsound highlights the selected part of the recording.
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When you select part of a recording, you can extend the
selection by pressing the Shift key while dragging MB1.

When you choose an edit operation after selecting part of
a recording, the edit operation applies to only that part of
the recording.

Cutting a Recording
DECsound allows you to cut all or part of a recording, as follows:

• Cutting an entire recording

Choose Cut from the Edit menu to transfer the entire
recording to the clipboard. DECsound deletes the recording
from the display area.

• Cutting part of a recording

Choose Cut from the Edit menu to transfer the selected part
of a recording to the clipboard. DECsound deletes the selected
part of the recording from the display area.

Copying a Recording
DECsound allows you to copy all or part of a recording, as follows:

• Copying an entire recording

Choose Copy from the Edit menu to copy the entire recording
to the clipboard. The original waveform is still visible in the
display area.

• Copying part of a recording

Choose Copy from the Edit menu to copy the selected part of
a recording to the clipboard. The original waveform is still
visible in the display area.

• Using the QuickCopy function

DECsound provides a QuickCopy function, which copies the
selected part of a recording to the current position in the
waveform. To use the QuickCopy function, follow these steps:

1. In the current waveform, position the pointer where you
want the recording to be copied to by pointing and clicking
MB1.

2. In the other waveform, point to the part of the waveform
you want to copy.

3. Press and hold MB2.
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4. Drag across the part of the waveform you want to copy.

The waveform is highlighted as you drag across it.

5. Release MB2.

The waveform is copied to the new location in the current
waveform.

Note

When you use the QuickCopy function, DECsound does
not copy the selected part of the recording to the clipboard.

Deleting a Recording
DECsound allows you to delete all or part of a recording as
follows:

• Deleting an entire recording

To delete an entire recording, choose Clear from the Edit menu
without selecting part of the recording.

• Deleting part of a recording

To delete part of a recording, choose Clear from the Edit
menu to delete the selected part of the recording. DECsound
deletes the selected part of the recording from the display
area, but the Clear operation does not affect the contents of
the clipboard.

Using LiveLink Connections
You can include DECsound recordings in DECwrite documents
using LiveLink connections. A LiveLink connection puts a
DECsound recording into a document. The following are examples
of when you might find this feature to be useful:

• Your document includes a complex graphic showing a machine
part or a circuit diagram.

Rather than type the description, you can create a LiveLink
connection to a DECsound recording.

• You want to comment on a draft document prepared by a
colleague.
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Rather than insert handwritten comments in the document,
you can use DECsound to insert your comments at appropriate
places in the document.

When you create a LiveLink connection to a DECsound recording,
the recording is maintained in a DECsound file. If you update the
recording, the document is updated automatically to include the
new recording.

When you insert a LiveLink connection into a DECsound file in
a DECwrite Version 2.1 document, you can insert an icon that
indicates the presence of a DECsound recording in the document.

If you do not insert the icon, the DECsound data block may be
difficult to find in a document. However, if you do insert the icon,
the icon is also displayed when you print the document.

Making LiveLink Connections from DECwrite
To create a LiveLink connection between a DECwrite document
and a DECsound recording, follow these steps:

1. Choose Links from the File menu.

Note

You must have the Full Menus option turned on to display
the Links menu. To turn on this option, choose Full Menus
from the DECwrite Options menu.
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DECwrite displays the Links submenu, as follows:

Include Document... 

Delete...
Open...                               Ctrl/O
New...                                Alt/N  

Export to Bookreader...

Import
Import Text File...  

Links 

Print

Export...
Save As...                              
Save                                  Alt/S 

Print...                                Alt/P  

Change Style File... 

Close Document...               Alt/K
Exit                                    Alt/Q 

File 
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Link to Image... 

Link to Picture... 
Link to Document...  

Link to Spreadsheet... 
Link to Chart...  

Link to Builder... 
Link to Database...  

Modify Link... 

Invoke Application

Link to Equation... 

Link...  

2. Choose Link... from the Links submenu.

DECwrite displays the Link dialog box. For information about
the Link dialog box, click on the Help button in the dialog box.

3. Click on a file name in the list box. If you want to create a
new DECsound recording, enter the name of the file in the
Selection entry box.

4. Click on the Options... button in the dialog box.

DECwrite displays the Link Options subdialog box. For
information about the Link Options subdialog box, click on the
Help button in the subdialog box.

In the Link Options subdialog box, enter the LiveLink
connection information, as follows:

a. Specify the file location type for the file that contains the
recording to which you want to link.

The location also affects the way that the audio file is
treated if you mail the DECwrite document.
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b. Specify DECsound in the Application Name entry box, as
follows:

SYS$SYSTEM:DECSOUND

c. If you want the DECwrite document to display an icon to
indicate the presence of the DECsound recording in the
document, specify the -icon qualifier in the Parameters
entry box, as follows:

-icon

Note

This option is available for DECwrite Version 2.1 only.

d. Click on OK to dismiss the Link Options subdialog box.

5. Set the Invoke Application toggle button to the On state if you
want to invoke DECsound.

6. Set the Keep Natural Size toggle button to the Off state if
you want to specify the size of the DECsound icon that is
displayed in the DECwrite document.

7. Click on OK in the Link dialog box.

8. Position the pointer at the spot in the document window
where you want the DECsound data block to be displayed,
drag MB1 to size the data block, then release MB1.

Mailing Audio Recordings
You can mail DECsound recordings to other users using
DECwindows Mail.

To mail a DECsound recording with DECwindows Mail, use
DECsound to create the recording, then send the recording the
same way that you send any mail message.
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Creating and Sending DECsound Recordings with DECwindows
Mail
To mail a DECsound recording using DECwindows Mail, follow
these steps:

1. Click on the Create–Send button in the main DECwindows
Mail window.

DECwindows Mail opens a Create–Send window and, if
you have specified DECsound as the default editor, invokes
DECsound.

2. Enter the address and subject information in the text entry
boxes in the Create–Send window.

Note

If you have not specified DECsound as the default mail
editor, choose DECsound from the Change Editor menu in
the Create–Send window.

3. Click on the DECsound window and create the recording.

When you have finished, save the recording and exit from
DECsound.

4. Click on Send in the Create–Send window.

DECwindows Mail sends a mail message that contains the
DECsound recording.

Specifying DECsound as the Default Editor
You can specify DECsound as the default mail editor to use
when you create mail messages. This means that when you
create a mail message, DECwindows Mail invokes DECsound
automatically.

To specify DECsound as the default mail editor, follow these steps:

1. Choose Send... from the DECwindows Mail Options menu.

DECwindows Mail displays the Send dialog box.

2. Press MB1 on the editor shown in the Default Editor box of
the Send dialog box to see a list of the editors available on the
system.

Choose DECsound from the list.

Using DECsound 7–19



3. Click on OK in the Send Options dialog box.

4. Choose Save Settings from the DECwindows Mail Options
menu to ensure that the default editor setting is saved.

If the list of available editors does not include DECsound, ask
your system manager to modify the list to include DECsound.

Exiting DECsound
Choose Exit from the File menu to exit from DECsound.
DECsound saves the current recording, using the current file
name. If there is no current file name, DECsound displays the
Confirmation dialog box.

DECsound displays the Confirmation dialog box when you try to
exit from DECsound and one of the following conditions applies:

Condition What to do

You edited a recording or made a
new recording, but you did not save
the recording in a file.

Click on OK to exit from
DECsound without saving the
recording, or click on Cancel to
cancel the Exit command and
continue using DECsound.

You made changes in the Settings
dialog box, but you did not click on
Save in the dialog box.

Click on OK to exit from
DECsound without saving the
changes to the dialog box settings,
or click on Cancel to cancel the
Exit command and continue using
DECsound.
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8
Using DECterm

DECterm is video terminal emulator.

This chapter describes how to

• Create a DECterm window

• Choose options

• Copy information

• Clear and resize windows

• Print information

• Compose special characters

• Exit DECterm

Creating a DECterm Window
To create a DECterm window, do one of the following:

• Choose DECterm from the Session Manager’s Application
menu.

• From the DCL command line, enter:

$ CREATE/TERMINAL

For a complete description of the CREATE/TERMINAL
command, see the HP OpenVMS DCL Dictionary: A–M.

A DECterm window is displayed.
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HelpFile Edit Commands PrintOptions

DECterm:     Digital Equipment Corp. 1990, 1991c

$

Give the DECterm window input focus by moving the cursor to
the window and clicking MB1.

Choosing Options
Once you have created a DECterm window, you can choose
operating features and then save these features by using the
Options menu.
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HelpFile Edit Commands Options

$

DECterm 1

Restore System Options

Print

Display...

Keyboard...

General...

Save Options

Restore Options

Save Named Options...

7−Bit NRCS Selection...

Options

Graphics...

Printer...

Restore Named Options...

Window...

Choosing Window Options
Choose Window... from the Options menu to change DECterm
window features. DECterm displays a dialog box.
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DECterm: Window Options

Auto Resize Terminal

Terminal Driver Resize

Big Font

Little Font

German Standard Font

Normal Font (80 Columns)

Condensed Font (132 Columns)

Normal/80, Condensed/132

Auto Resize Window

Window Title

DECterm 1
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OK Apply Cancel Help

Default

Other −*−Terminal−*−*−*−−*−180−*−:

Default

Other

Default

Other

Terminal Size

Icon Name

DECterm 1

−*−Terminal−*−*−*−−*−140−*−:

Rows24

−*−Terminal−*−*−*−GS−*−140−

Columns80

72

24

48

80

132

In DECterm dialog boxes, shaded check buttons indicate the
current settings.

To change these settings:

• Click MB1 on a check button or its label to change the setting.
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• Click on the Apply button to view your changes without
closing the dialog box.

• Click on the OK button to apply your changes and close the
dialog box.

• Click on the Cancel button to cancel your changes.

• Click on the Help button to get help about the displayed
window.

From the Window Options dialog box, you can choose the following
features:

Auto Resize Terminal
Changing the window size does not usually change the size of the
DECterm display area. Clicking on Auto Resize Terminal causes
the display area to match the window size.

Auto Resize Window
Changing the size of the DECterm display area (the number of
rows and columns) usually changes the window size automatically.
Clicking on Auto Resize Window lets you change the size of
the DECterm display without changing the window size. If the
display area is larger than the window, information is not visible.
Use scroll bars to access areas outside the window boundary.

Terminal Driver Resize
When you modify the terminal driver, the terminal size usually
changes. Clicking on Terminal Driver Resize disables this option.

Normal Font (80 Columns)
Clicking on the Normal Font (80 Columns) option causes the
80-column font to be used, regardless of the number of columns.

The default option is Normal/80, Condensed/132.

Condensed Font (132 Columns)
Clicking on the Condensed Font (132 Columns) option causes a
condensed font to be used, regardless of the number of columns.

The default option is Normal/80, Condensed/132.

Normal/80, Condensed/132
The default font size is Normal/80, Condensed/132. This option
changes the font size to match the terminal width. The normal
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font is used for 80 columns or less; the condensed font is used for
more than 80 columns.

Big Font
Clicking on the Big Font option causes DECterm to display an 18-
point font. By default, DECterm displays a 14-point font (10-point
font on 100 dots-per-inch systems).

You can replace the default Big Font with any font that is
available on your system by clicking on Other and typing the
name of the font in the text entry box. For information about the
fonts available on your system and about font naming conventions,
consult your system manager.

Little Font
DECterm displays a 14-point font (10-point font on 100 dots-per-
inch systems) by default.

You can replace the default Little Font with any font that is
available on your system by clicking on Other and typing the
name of the font in the text entry box. For information about the
fonts available on your system and about font naming conventions,
consult your system manager.

German Standard Font
Clicking on the German Standard Font option causes DECterm
to use a font that meets the German Technical Supervision
Association (TÜV) requirements. By default, DECterm displays a
14-point font. This font cannot be condensed.

You can replace the default German Standard Font with any
font that is available on your system by clicking on Other and
typing the name of the font in the text entry box. For information
about the fonts available on your system and about font naming
conventions, consult your system manager.

Window Title
The title DECterm usually appears in the window title bar.
Entering a title of your choice in the text entry box changes the
name in the title bar.

Icon Name
The title DECterm usually appears in the icon. Entering a name
of your choice in the text entry box changes the name in the icon.
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Terminal Size
The default terminal size is 24 rows and 80 columns. You can
change the terminal size by clicking on one of the displayed
default sizes. You can also customize the column and row to
be any number from 1 to 132 by clicking on the text entry box,
deleting any existing numbers and entering the new settings.

Choosing Display Options
Choose Display... from the Options menu to modify display
features, such as the cursor style. DECterm displays a dialog box.

DECterm: Display Options

Vertical Cursor Coupling

Horizontal Cursor Coupling

Horizontal Scroll Bar

Auto Wrap

Display Cursor

Vertical Scroll Bar

Record Lines Off Top

Cursor Blink

Dark Text, Light Background

Light Text, Dark Background

No Status Display

Host Status Display

Block Cursor

Underline Cursor

Batch Scroll Lines0 Record Lines Off Top500
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^

OK Apply Cancel Help

From the Display Options dialog box, you can choose the following
features:
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Record Lines Off Top
Lines that are scrolled off the top of the DECterm display are
saved by default. To view these lines, use the vertical scroll bar.
If you do not want to save lines that are scrolled from the display,
click on the Record Lines Off Top option.

Vertical Scroll Bar
DECterm displays vertical scroll bars by default. If you do not
want vertical scroll bars, click on the Vertical Scroll Bar option.

Horizontal Scroll Bar
DECterm does not display a horizontal scroll bar by default. To
display a horizontal scroll bar at the bottom of your DECterm
window, click on Horizontal Scroll Bar.

Vertical Cursor Coupling
When you change the window or terminal size vertically, the
cursor remains visible by default. For example, if the display
contains 24 rows and you shrink it to 5 rows, the cursor remains
visible and allows you to enter text. Click on Vertical Cursor
Coupling to disable this option.

Horizontal Cursor Coupling
When you change the size of your window or terminal horizontally
(for example, from 132 columns to 80 columns), the cursor is
not visible by default. You can change the display by clicking on
Horizontal Cursor Coupling.

Auto Wrap
When the cursor reaches the right margin it does not move to
the next line by default. Each character typed deletes the last
character. Click on Auto Wrap to allow the cursor to automatically
start a new line.

Display Cursor
DECterm displays a cursor by default. Click on Display Cursor
for the cursor to become invisible.

Cursor Blink
The DECterm cursor blinks by default. Click on Cursor Blink to
display a nonblinking cursor.
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Batch Scroll 0 Lines
DECterm updates the display on a character or line basis by
default. Batch scrolling allows updates on a specified number of
lines. To update the display on a specified number of lines, enter
a number in the text entry box.

Dark Text, Light Background
DECterm displays dark text on a light screen background by
default. You can change the display by clicking on Light Text,
Dark Background.

Light Text, Dark Background
DECterm displays dark text on a light screen background by
default. Click on Light Text, Dark Background to reverse the
display to light text and a dark screen background.

No Status Display
By default, host status messages are not displayed. Click on Host
Status Display to display status messages.

Host Status Display
To receive host status messages, click on the Host Status Display
option. This causes status messages to appear on the bottom line
of the DECterm window. You can set Host Status Display only if
you choose the VT300-Series Terminal ID option.

Block Cursor
By default, the cursor for DECterm is a block. You can change the
shape of the cursor by clicking on Underline Cursor.

Underline Cursor
Click on the Underline Cursor option to get an underline cursor.
By default, the cursor for DECterm is a block.

Record 500 Lines Off Top
DECterm saves 500 lines in the transcript by default. You can
enter a number from 1 to 9999 to increase or decrease the number
of lines saved in the transcript.
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Note

Recording a large number of lines requires an appropriate
amount of virtual memory. Modification of quotas or
SYSGEN parameters may be required for high values.

Choosing General Options
Choose General... from the Options menu to change general
features, such as the terminal type. DECterm displays a dialog
box.
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DECterm: General Options

OK Apply Cancel Help

Normal Cursor Keys

Lock User Features

Appl Cursor Keys

Lock UDKs

Newline VT300 Mode, 8−Bit Controls

Numeric Keypad

Application Keypad

UPSS DEC Supplemental

UPSS ISO Latin 1

8−Bit Multinational Characters

7−Bit NRCS Characters

VT300 Mode, 7−Bit Controls

VT100 Mode

VT52 Mode

Terminal ID

VT330 ID

VT320 ID

VT240 ID

VT220 ID

VT125 ID

VT102 ID

VT101 ID

VT340 ID

DECterm ID

VT100 ID
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Local Echo

Answerback Message

Conceal Answerback Message

From the General Options dialog box, you can set the following
features:

Using DECterm 8–11



Newline
By default, when DECterm receives a line feed (LF), form feed
(FF), or vertical tab (VT) character, the cursor moves to the first
column of the next line. When you press Return, DECterm sends
both a carriage return (CR) and a line feed.

If you choose the Newline option and DECterm receives an LF, FF,
or VT character, the cursor moves to the next line, same column.
When you press Return, DECterm sends only a CR.

Lock UDKs
The keyboard contains keys you can define for your own use. The
system can change the function of the key you have defined back
to the default. Clicking on Lock UDKs ensures your definitions
are not changed.

Lock User Features
DECterm lets you change the Auto Repeat option and the
Foreground and Background Display option. The host system
can override these options unless you click on the Lock User
Features option.

Local Echo
The Local Echo option is useful when you are connected to a host
that does not echo typed characters. When you choose local echo
mode, all characters you type locally are passed to your remote
host as well as echoed on your display.

Normal Cursor Keys
By default, the Normal Cursor Keys option is on. This causes the
arrow keys to move the cursor up, down, left, and right.

Appl Cursor Keys
By clicking on the Appl Cursor Keys option, you can override
the Normal Cursor Keys default and set the arrow keys to
application-specific functions.

Numeric Keypad
The default Numeric Keypad displays the character that appears
on the numeric key that you press.

Application Keypad
Clicking on the Application Keypad option allows user-defined
characters to be displayed.
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UPSS DEC Supplemental
The UPSS DEC Supplemental option is the default that causes
the DEC Multinational Character Set to be used.

UPSS ISO Latin 1
You can override the default character set by clicking on the UPSS
ISO Latin 1 option. This causes the International Standards
Organization (ISO) Latin 1 Character Set to be used.

Note

To use these character sets you must set the Character Set
mode to 8-Bit Characters.

8-Bit Multinational Characters
The default character mode is set to 8 bits for use with either
the DEC Supplemental Character Set or the ISO Latin 1
Supplemental Character Set.

7-Bit NRCS Characters
To use the National Replacement Character Set, click on the
7-Bit NRCS Characters option. This option lets DECterm operate
in 7-bit mode, using the national character set selected in the
7-Bit NRCS dialog box. The default is the 8-Bit Multinational
Character Set.

Answerback Message
The Answerback Message option lets you enter a string of text
that DECterm will display whenever you press Ctrl/F5. You can
use this as a shortcut for entering text strings you use often.

To enter an answerback message, click on the Answerback
Message box. You can enter a message having up to 30 characters.

Conceal Answerback Message
You can conceal your answerback message by clicking on the
Conceal Answerback Message button. The text <concealed>
replaces your answerback message in the Answerback Message
box.

If you conceal the message, you can never redisplay it. If you
click on the Answerback Message box, your concealed message is
erased; you can then enter a new message. You can conceal your
new message by clicking on Conceal Answerback Message.
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VT300 Mode, 8-Bit Controls
By default, DECterm emulates a VT300-series terminal using
7-bit control characters. You can change the mode to VT300 with
8-bit control characters by clicking on the VT300 Mode, 8-Bit
Controls option. This causes DECterm to transmit 8-bit control
characters for function keys, for example, CSIA for the up arrow
key. Not all applications can use 8-bit control characters.

VT300 Mode, 7-Bit Controls
By default, DECterm operates in VT300 mode with 7-bit control
characters. This means that function keys transmit in 7-bit form,
for example, ESC OA for the up arrow key.

VT100 Mode
You can change the VT300 Mode 8-Bit Controls option by clicking
on the VT100 Mode option. This causes DECterm to emulate a
VT100 terminal.

VT52 Mode
You can change the VT300 Mode, 8-Bit Controls option by clicking
on the VT52 Mode option. This causes DECterm to emulate a
VT52 terminal.

Terminal ID
You can let the host system know specific terminal operating
attributes by clicking on the Terminal ID option. The default is
DECterm ID.

You can choose the following terminal IDs:

DECterm ID VT340 ID VT330 ID VT320 ID VT240 ID

VT220 ID VT125 ID VT102 ID VT101 ID VT100 ID

Choosing Keyboard Options
Choose Keyboard... from the Options menu to set keyboard
features. DECterm displays a dialog box.

8–14 Using DECterm



DECterm: Keyboard Options
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From the Keyboard Options dialog box, you can set the following
keyboard features:

Warning Bell
By default, the keyboard warning bell rings when errors occur.
Clicking on the Warning Bell option turns off the warning bell.

Margin Bell
By default, the margin bell does not ring when the cursor reaches
the right margin. Click on the Margin Bell option to cause the
bell to ring.

F11 Key Sends F11
By default, the F11 Key Sends F11 is set. This causes the F11 key
to send an F11 to the host.

F11 Key Sends Escape
You can override the F11 Key Sends F11 default by clicking on the
F11 Key Sends Escape option. This causes the F11 key to function
as an escape (ESC) key.

Tilde Key Sends ‘~
On the North American and Dutch keyboards, the Tilde Key
Sends ‘~ option is set. This causes the ‘~ key to display a left
single quotation mark ( ‘ ) when unshifted and a tilde ( ~ ) when
shifted.

Tilde Key Sends ESC
On the North American and Dutch keyboards, you can override
the Tilde Key Sends ‘~ default by clicking on the Tilde Key Sends
ESC option. This causes the ‘~ key to function as an escape (ESC)
key.

Angle Brackets Key Sends <>
On the North American and Dutch keyboards, the Angle Brackets
Key Sends <> option is set. This causes the angle bracket key to
display a left angle bracket ( < ) when unshifted and a right angle
bracket ( > ) when shifted.

Angle Brackets Key Sends ‘~
On the North American and Dutch keyboards, you can override
the Angle Bracket Key Sends <> default by clicking on the Angle
Brackets Key Sends ‘~ option. This causes the <> key to display
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a left single quotation mark ( ‘ ) when unshifted and a tilde ( ~ )
when shifted.

Auto Repeat
By default, if you press and hold a key, that character is displayed
repeatedly. Clicking on the Auto Repeat option causes only one
character to be displayed.

Ctrl–Q, Ctrl–S = Hold
By default, pressing Ctrl+S causes the display to stop scrolling,
and pressing Ctrl+Q causes the display to resume scrolling.

<x Delete
By default, the <x key functions as a delete key.

<x Backspace
You can change the <x Delete default by clicking on the <x

Backspace option. This causes the <x key to function as a
nondestructive backspace key.

Comma Key Sends ,,
On the North American and Dutch keyboards, the Comma Key
Sends ,, option is the default. This causes a comma ( , ) to be
displayed when you press the comma key, whether or not the key
is shifted.

Comma Key Sends ,<
On the North American and Dutch keyboards, you can override
the Comma Key Sends ,, default by clicking on the Comma Key
Sends ,< option. This causes a comma ( , ) to be displayed when
you press the Shift key and the Comma key, and a left angle
bracket ( < ) to be displayed when you press the comma key
unshifted.

Choosing a National Replacement Character Set
Choose 7-Bit NRCS Selection... from the Options menu to set the
National Replacement Character Set (NRCS) that corresponds to
your keyboard. DECterm displays a dialog box.

The NRCS selection is used only with the 7-Bit NRCS Characters
option. To use a 7-bit national character set, choose the
corresponding keyboard in the Session Manager and also
select the 7-bit NRCS option in DECterm. The Dutch NRCS
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is equivalent to the North American NRCS. The Dutch NRCS is
not supported.

DECterm: 7−Bit NRCS Selection

North American

Flemish

Canadian (French)

British

Danish

Finnish

Austrian/German

Dutch

Apply Cancel HelpOK 

ZK−3453A−GE

You can select the following character sets:

North American Italian

Flemish Swiss (French)

Canadian (French) Swiss (German)

British Swedish

Danish Norwegian

Finnish Belgian/French

Austrian/German Spanish

Dutch Portuguese

Choosing Graphic Options
Choose Graphics... from the Options menu to modify DECterm
graphics features such as color map entries. DECterm displays a
dialog box.
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DECterm: Graphics Options
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From the Graphics Options dialog box, you can choose the
following graphics features:

Share Color Map Entries
By default, Share Color Map Entries is enabled on single-plane
and true-color systems and is disabled on GPX systems. Choosing
this option prevents DECterm from allocating color map entries
for its exclusive use. Instead, DECterm allocates shared, read-
only colors from the default color map. This means not only that
DECterm does not need to create a private color map (which
would prevent the windows from displaying true colors), but also
that DECterm colors may not match the colors used on a terminal.

Enable Backing Store
By default, the Enable Backing Store option causes DECterm to
redraw graphics after the window has changed. Disabling this
option improves performance.

Report Macrograph Contents
By default, DECterm does not respond to a request by an
application to report macrograph contents. Clicking on this
option enables ReGIS commands to report macrograph contents.
This option may risk security in some environments. When
reporting is complete, disable this option.
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Bit Planes
You can choose the number of colors available in ReGIS and sixel
graphics by entering the number of planes supported by your
system. For example, on a system with 2-bit planes, four colors
are displayed simultaneously; on a system with 4-bit planes,
sixteen colors are displayed simultaneously.

By default, DECterm uses 2-bit planes on 4-plane systems and
4-bit planes on all other systems. This reduces the probability
that DECterm must create a private color map.

Applications written for the VT240 terminal require 2-bit planes,
whereas applications written for the VT340 terminal may require
up to 4-bit planes.

Choosing Printer Options
Choose Printer... from the Options menu to change printer
features such as the printing destination. DECterm displays a
dialog box.
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DECterm: Printer Options
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From the Printer Options dialog box, you can choose the following
printing features:
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Queued Printer
From the Queued Printer Options... menu, you can select the
following printer options.

• The Number of Copies option prints one copy of a job. For
additional copies, type the number of copies to be printed.

• The Page Range From_ _ To_ _ option prints the complete job.
To print part of a job or a specific page, type the page number.

• By default, the Print Format option prints a job in text format.
Choosing Line Printer or Terminal changes the print format
for the specified printer.

• The Printer option lists the available print queues.

• By default, the Orientation option prints characters parallel to
the short edge of the paper (portrait). Choosing the Landscape
option prints characters parallel to the long edge of the paper.

• By default, the Print After option submits a print queue at a
specified time.

• The Delete File When Printed option deletes files after the job
is printed.

For detailed information on these options and on advanced print
settings, refer to Using DECwindows Motif for OpenVMS.

Printer Port
By default, the Printer Port option specifies the local printer port.
To choose another port, enter the device name in the text entry
box.

File
By default, information printed on the screen does not create a
file. Choosing the File option saves the printed output to a file.

None
By default, the None option discards the queued job.

Normal Print Mode
By default, received characters are not printed. To print
characters use the Print Screen key or use escape sequences.

Auto Print Mode
By default, a line of information is printed if the cursor leaves that
line because of a line feed, vertical tab, form feed, or autowrap.
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Printer Controller Mode
By default, each character is printed as it is received. If you do
not choose this option, the character is displayed.

Print Full Page
The information on the display is printed. The information saved
in the transcript or status line is not printed.

Print Full Page + Transcript
The information in the transcript, followed by the information on
the display, is printed.

Print Scroll Region Only
The information stored in the scrolling region of the display is
printed.

Print Selection Only
The information in the selected region of the display and
transcript is printed.

Print National Characters Only
Only national characters are printed (for example, ASCII
characters). Other characters are either converted to the
corresponding national characters, or the characters are not
printed.

Print National + Line Drawing
National characters and line drawing characters are printed (for
example, special graphic characters).

Print All Characters
All characters are printed, including multinational and technical
characters.

Form Feed Terminator
By default, a form feed is added at the end of each page.
Optionally, an escape sequence can be used.

Printer To Host
By default, any character that is read on the printer port is sent
back to the host application. This option is available only when
the print destination is a printer port device rather than a print
queue or a file.
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Graphics Printing
By default, graphics (bitmap) and text are printed.

Background Printing
By default, the graphics background color is printed. Omitting
the background color saves ink and toner and increases printing
speed.

Level 1 Sixel Graphics
By default, a sixel introducer that omits the macro parameter is
used. This option does not use the Sixel Set Attributes command
to set the aspect ratio and the horizontal grid size. As a result,
the sixel aspect ratio is 2 to 1 and the horizontal grid size is
approximately 188 x 0.025 mm (7.5 x 0.001 inches).

Level 2 Sixel Graphics
By default, a sixel aspect ratio of 1 to 1 with a variable grid size
is printed using the Sixel Set Attributes command (available with
Level 2 printers).

LA210 Sixel Graphics
By default, a sixel introducer with a 9-macro parameter is used.
The result is a sixel aspect ratio of 1.02 to 1.

Compressed Graphics Printing
By default, a compressed graphics image is printed. In Portrait
mode, the output fits on a 5- x 8-inch page.

Expanded Graphics Printing
By default, an expanded image is printed. In Portrait mode, the
image fits on a 13-inch page.

Rotated Graphics Printing
By default, an expanded image, rotated 90 degrees, is printed.
The output fits on a 8- x 5-inch page.

Monochrome Printing
By default, the Monochrome Printing option prints in black.

Color Printing
By default, the Color Printing option prints color output.
DECterm includes a color map in virtual memory to allow color
printing from a monochrome system.
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7-Bit Printer
By default, DECterm allows the use of 8-bit characters for
printing. Some printers, particularly older ones, cannot interpret
8-bit characters.

If your printer does not support 8-bit characters, click on 7-Bit
Character. DECterm will now modify the text to be compatible
with your printer.

8-Bit Printer
By default, DECterm uses 8-bit characters for printing. If your
printer cannot interpret 8-bit characters, choose the 7-Bit Printer
option.

HLS Color Syntax
By default, the HLS Color Syntax option specifies hue, lightness,
and saturation.

RGB Color Syntax
By default, the RGB Color Syntax option uses a red, green, and
blue format when printed.

Saving and Restoring Options
Once you modify DECterm settings, you can save your changes.
When you save your changes, DECterm uses these settings each
time you create a DECterm window. If you change your mind
and want to use the settings that came with your system, you can
restore the system defaults.

To save the options:

• Choose Save Options to save current options.

• Choose Save Named Options... when you want to save the
current options with a new or different file name. DECterm
displays a dialog box.
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DECterm: Save Named Options

Filter

DECW$USER_DEFAULTS:DECW$TERMINAL_*.DAT

Directories

[     ]DECW$USER_DEFAULTS:

Select Name For Configuration File:

Selection

DISK$:[JONES]DECW$TERMINAL_DEFAULT.DAT

HelpOK Filter Cancel
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The dialog box prompts you for the name of the file you
want to use to save your features. The file list box displays
the names of any files in the current directory that contain
features. By default, these files have a file type of DAT.

To use a file name that is not listed, enter the name of that
file in the Selection text entry box and click on the OK button.

To restore options:

• Choose Restore Options to restore an existing file.

• Choose Restore System Options to restore the system defaults.

• Choose Restore Named Options... to restore previously saved
settings. DECterm displays a dialog box.
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DECterm: Restore Named Options
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The dialog box prompts you for the name of the file in which
you want to save your features. The file list box displays
the names of any files in the current directory that contain
features. By default, these files have the type DAT. Double
click on the file name you want to use.

Alternatively, use the File Filter entry box to list a subset of
files from which you can then choose. To display all files in
another directory with the file type DAT, type the complete
directory specification, for example, [JONES.OPTIONS]*.DAT,
in the File Filter entry box and click on the Filter button.
Then double click on the name of the file you want to use.
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Copying Information
Choose the Edit menu to copy information from within or between
DECterm windows.

ZK−3450A−GE

HelpFile Edit

$

DECterm 1

Commands Print

Paste

Select All

Options

Copy

Edit

To copy information:

1. Select the information you want to copy by pressing and
holding MB1, dragging the pointer over the information, and
releasing MB1. Or, choose the Select All menu item from the
Edit menu to copy the entire display.

The selected area is highlighted.

2. Choose the Copy menu item from the Edit menu to store the
copied information.
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3. Click on the area where you want to place the information.

4. Choose the Paste menu item from the Edit menu.

The selected information is copied to the new location.

Clearing and Resizing Windows
You can clear and resize the DECterm window from the
Commands menu.
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Clear Lines Off Top
You can erase information stored in the transcript by choosing the
Clear Lines Off Top option. The transcript is an area of memory
that contains the last saved lines of your screen display (use the
Display dialog box to change the size of the transcript). You can
read the information stored in the transcript by using the scroll
bars. The transcript exists as long as the Record Lines Off Top
option in the Window dialog box is in effect. By default, Record
Lines Off Top is enabled.
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Clear Display
You can clear all information displayed in a DECterm window by
choosing the Clear Display menu item.

Resize Window
Choose the Resize Window option to resize the window to match
the size (number of rows and columns) of the DECterm display
area.

Clear Communications
Choose the Clear Communications option to reset the
communications buffers. This causes DECterm to read data
to the host system even when DECterm has received an XOFF
signal.

Reset Terminal
Clicking on Reset Terminal causes a Soft Terminal Reset (STR).
Reset Terminal also restores the default color map. On a 4-plane
system, such as the VS2000/GPX, displaying ReGIS or sixel
graphics causes DECterm to create and load its own hardware
color map, so that other windows do not display in their true
colors when the DECterm window has input focus.

To restore the default hardware color map, first erase the graphics
from the window by choosing the Clear Display option from
the Control menu, and then reset the terminal with the Reset
Terminal menu item.

By default, DECterm emulates only two planes of graphics on
a 4-plane system; therefore, DECterm usually does not create a
color map.

Printing Information
Choose the Print menu to print information.
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Print Graphics
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Cancel Printing
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Print

From the Printer menu, you can choose the following printing
options:

Print Text Page
The Print Text Page option prints terminal lines 1 through 24 as
text.

Print Selected Text
The Print Selected Text option prints the selected information.

Print All Text
The Print All Text option prints the information in the display
and transcript as text.

Print Graphics
The Print Graphics option prints the contents of the display in
sixel format.
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Finish Printing
The Finish Printing option completes a print job depending on
the print destination. If queued to a printer, the job is submitted.
If submitted to a dedicated printer port, the job is canceled. If
written to a file, the file is closed. This option is used with Auto
Print mode or Printer Controller mode.

Cancel Printing
The Cancel Printing option stops the print request.

Composing Characters
Use compose sequences to create special characters. A compose
sequence is a series of keystrokes that creates characters that do
not exist as standard keys on your keyboard. You can create any
character from the character set DECterm is currently using. (For
more information about choosing a character set, see Choosing
Options.)

For more information about composing characters, see
Appendix A.

Note

You must simultaneously press the Compose key and
space bar to begin a compose sequence.

Exiting DECterm
To exit DECterm and close the DECterm window, choose Exit
from the File menu or enter the DCL command LOGOUT.
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9
Using LinkWorks Manager

LinkWorks Manager allows you to control your hyperinformation
environment. With LinkWorks Manager, you can set defaults for
certain hyperapplication features; create linknet lists, linknets,
path lists, and paths in one or more hyperinformation linkbases;
and copy objects from linkbases into your hyperinformation
environment.

LinkWorks Manager, represented by the ship’s wheel icon, helps
you to navigate your hyperinformation environment.

This chapter assumes that you are familiar with the concepts and
techniques described in the Using Hyperapplications chapter of
Using DECwindows Motif for OpenVMS.

This chapter describes how to

• Start LinkWorks Manager

• Use the Environment window to control your hyperinformation
environment and to open Linkbase windows

• Use the Linkbase window to create and modify objects in a
linkbase

• Copy objects from a linkbase into your hyperinformation
environment

• Record steps in a path and follow a path

• Exit LinkWorks Manager
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Starting LinkWorks Manager
To start LinkWorks Manager, choose LinkWorks Manager from
the Session Manager’s Applications menu. If you want to have
LinkWorks Manager start automatically when you begin a
DECwindows session, choose the Automatic Startup... item on the
Session Manager’s Options menu and add LinkWorks Manager to
the automatic startup list.

Note

If you start LinkWorks Manager automatically, you
do not need to start the LinkWorks Setup application
automatically also. LinkWorks Setup initializes the
LinkWorks environment (thus enabling the features of
the Link menu in hyperapplications), and by default it is
included in the list of applications that start automatically
when you begin a session. LinkWorks Manager also
initializes the environment, if this has not already been
done.

Using the Environment Window
The Environment window is the main LinkWorks Manager
window. It does the following:

• Displays information about objects in your hyperinformation
environment

• Lets you add objects to and remove them from your
hyperinformation environment

These objects exist in one or more linkbases. You can copy
objects into the Environment window to include them in your
hyperinformation environment, and you can delete them
from the Environment window to remove them from your
hyperinformation environment.

• Lets you set defaults for hyperapplication features for all
hyperapplications

• Lets you open one or more Linkbase windows

Before you use the Environment window, you should understand
the relationship between it and the Linkbase window.
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Relationship Between Environment and Linkbase
Windows
The Environment window shows the linknets and paths in your
hyperinformation environment, and it groups them under the
appropriate linknet lists and path lists (if you have created any
such lists and included them in the environment). The Linkbase
window, which you can open from the Environment window,
shows the linknets, paths, linknet lists, and path lists in a specific
linkbase. If you have access to multiple linkbases, you can open
multiple Linkbase windows; however, you can have only one
Environment window.

The following figure shows an Environment window and a
Linkbase window. The windows are shown as they might appear
after many objects have been created and copied, not as they
appear the first time you use LinkWorks Manager. These windows
are discussed in detail in later sections.
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The first time the LinkWorks Setup application (separate from
LinkWorks Manager) starts up, it creates your default linkbase
and a default linknet called Personal Links in that linkbase, and
adds the Personal Links linknet to your LinkWorks environment.
You must use the LinkWorks Manager Linkbase window to
create additional linknets, linknet lists, paths, or path lists, or to
perform any editing operations on these objects. After you have
created or modified an object in a linkbase, you must copy it into
the Environment window in order to make it available in your
hyperinformation environment (see Copying Objects into Your
Hyperinformation Environment later in this chapter).

9–4 Using LinkWorks Manager



Environment Window Layout
The left side of the Environment window lists the linknet
lists, linknets, path lists, and paths in your hyperinformation
environment.

The right side of this window has columns marked Active, Record,
and Linkbase. You can double click to enable (represented by
a check mark) or disable the Active and Record status for each
object. (Double clicking is a shortcut for selecting the object and
using the Control menu’s Activate/Deactivate and Start/Stop
Recording items.)

• An active linknet is one whose links are enabled; that is, you
can see its links if highlighting is enabled, and you can follow
its links. If a linknet is not active, you cannot see or follow its
links.

You can have multiple active linknets. The sequence of the
linknets in the window is not significant.

• The recording linknet (check mark in Record column) is the
one in which any links you make are stored.

You can have no more than one recording linknet. You cannot
store links in two or more linknets simultaneously. If you
have no recording linknet, you cannot make any links.

• An active path is one whose steps are followed when you use
the Step Forward item on the Link menu.

You can have multiple active paths. The sequence of active
paths is significant because the Step Forward menu item
uses this sequence; if you are at the last link in a path, Step
Forward takes you to the first link in the next active path. If
you have no active path, the Step Forward item is disabled.

• The recording path (check mark in Record column) is the one
in which your Visit and Go To operations are stored (one step
for each operation). After you have created the path by storing
navigation operations in it, you and other users can follow the
path by making it active and stepping forward through it.

You can have no more than one recording path. You cannot
store steps in two or more paths simultaneously. If you have
no recording path, your navigation operations are not stored
in any path.
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The Linkbase column identifies the linkbase that contains each
item. You can double click on the linkbase name to display the
Linkbase window, which you can use to view and edit the contents
of that linkbase. (Double clicking is a shortcut for selecting the
Linkbase name and then choosing the File menu’s Open... item.)

Customizing LinkWorks Manager and Your
Hyperinformation Environment

Manager...

Environment ...

Save Settings

Restore Settings

Restore System Settings

Options The Options menu allows you to customize LinkWorks Manager,
that is, to set defaults for the LinkWorks Manager startup state
and for your hyperinformation environment.

The Manager... menu item displays a dialog box in which you can
specify whether LinkWorks Manager should start up as a window
or as an icon.

LinkWorks: Manager Options

Window Icon

Startup State

HelpCancelOK
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The Environment... menu item displays a dialog box in which
you can display and modify the following hyperinformation
environment attributes:

• Highlight Defaults

• Link Defaults

• Go To/Visit Defaults

These defaults apply to all hyperapplications, but you can
override the defaults for any specific hyperapplication by making
appropriate Link menu choices and dialog box entries in that
hyperapplication.
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The following figure shows the Environment Options dialog box.
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Linkworks: Environment Options

Default

OK HelpCancel

The Highlight Defaults buttons affect:

• Whether or not highlighting is enabled (Highlight button). If
highlighting is enabled, linked objects are highlighted by their
hyperapplications.

• Which types of objects are to be highlighted (object type
buttons).

You can override these values for any hyperapplication by using
the Turn Highlight On/Off and Highlight... menu items in the
application’s Link menu.
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The Link Defaults entries establish defaults for each link that you
make.

• The Retain Source check button determines whether or not
the source remains pending (selected as the source for the
next link) after a link is created.

• The Relationship entry box describes the relationship between
the source and target objects. The default is ‘‘Is Linked To,’’
and you should keep that unless you have text that is more
suitable for most of the links that you plan to create.

For each link that you create, you can edit the Relationship
text for each link by using the Show More... dialog box when
you create the link. For example, you can document links that
you expect other users to follow.

The Go To/Visit Defaults entries determine the defaults for Go To
and Visit operations.

• Select Destination determines whether or not the destination
object is already selected when it is displayed.

• Destination Operation is a pop-up menu that lets you set a
default operation to be performed on the destination object.
The available choices are Default (performs the default
operation as defined by the object’s hyperapplication), View,
Edit, and Activate.

The Save Settings item on the Options menu saves:

• Any changes you have made to the LinkWorks Manager or
Environment options

• The current position and size of any active LinkWorks
Manager windows

The Restore Settings menu item restores the options and the
window positions and sizes to what they were at the last save
operation. The Restore System Settings item restores the default
values for all options and the window positions and sizes.
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Using the Linkbase Window
The Linkbase window displays the contents of a specific linkbase.
To display this window, use the Environment window and do one
of the following:

• Double click on the linkbase name.

• Choose Open Linkbase... from the File menu and specify the
linkbase in the dialog box that appears.

The following figure shows the Linkbase window.

ZK−3363A.GE

LinkWorks Linkbase: Personal

ABC project

Impressionists

CreateEditFile

Name

My projects

Linkbase

View Help

DEF project

DEF project

Arts linknet

Personal Links

Group linkbase

Creating a New Linkbase
To create a new linkbase, choose one of the following menu items:

• Open Linkbase... on the File menu in the Environment
window

• Open... on the File menu in the Linkbase window

• Open in New... on the File menu in the Linkbase window

The Open Linkbase... and Open in New... items open the linkbase
in a new Linkbase window. The Open... item opens the linkbase
in the current Linkbase window.
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In the Selection entry box of the dialog box, enter a file name
that does not match an existing linkbase file name. LinkWorks
Manager creates the linkbase and opens it in a Linkbase window.
You can then create objects in the new linkbase.

Linkbase Window Layout
The left side of the Linkbase window lists any linknet lists,
linknets, path lists, and paths in the linkbase.

The right side of the window lists the name of the linkbase in
which the specific linknet list or linknet is stored. If the linknet
list or linknet is stored in the linkbase you are viewing, no
linkbase name appears beside it. However, if the item is merely a
pointer to a linknet list or linknet in another linkbase, the name
of the other linkbase is listed.

Creating Linkbase Objects

Linknet List.. .

Linknet...

Path List...

Path...

Create To create a linknet, linknet list, path, or path list, use the Create
menu. The Create menu has an item for each object type.

Choose the appropriate item from the menu. In the dialog box
that is displayed, enter the name and (optionally) a description of
the object to be created. The following figure shows entries that
create a path named ‘‘XYZ justification.’’
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LinkWorks: Create Path

ApplyOK Reset HelpCancel

Name

Description

Steps

Author

Creation Date

XYZ justification

Arguments supporting XYZ project

0

CMURRAY

October 15, 1991 05:39 PM

You can use lists to group objects and other lists. A linknet list
can include linknets and linknet lists. A path list can include
paths and path lists. The following figure shows a linkbase
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display in which two lists (Group net list and XYZ project path
list) are expanded to show the objects included in them.

LinkWorks Linkbase: Group linkbase

CreateViewEditFile

Name

Finance net list

Group net list

XYZ project

ABC project

XYZ justification

XYZ overview

Linkbase

ZK−3368A.GE

Help

Finance net list

XYZ project

ABC project

XYZ project path list

XYZ justification

XYZ overview

In the Linkbase window, the items listed in the first (nonindented)
column are objects, and any items in indented columns are
pointers to objects. For example, in the preceding figure, the
XYZ project linknet appears indented under the Group net list
linknet list; it also appears on a separate line and not indented.
A nonindented line represents the object; you select this line to
perform operations on it (for example, to copy the linknet into
another linknet list).

To put an object in a linknet list or path list, use either the
quick-copy method (MB1 to select, MB2 to copy) or the following
method:

Note

With either method, the position of the pointer before
you click MB2 or the position of the object you selected in
step 3 below determines where the copied object is placed.
If you select a linknet list or path list, the copied object
is inserted at the end of the list. If you select a linknet
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or path in a list, the copied object is placed before the
selected object.

1. Select the object to be put in the list (for example, a linknet).

Cut

Copy

Paste

Delete

Shift+Remove

Ctrl+Insert

Shift+Insert

Edit 2. Choose the Copy (not Cut) item from the Edit menu.

3. Select the object into which the object is to be put (for
example, a linknet list).

4. Choose the Paste item from the Edit menu.

Repeat these steps for each object you want to include in a list.

Note

Changes you make in the Linkbase window are not
stored in the linkbase until you save them, close the
linkbase, or exit the Linkbase window. If you create
an object and plan to include it immediately in your
hyperinformation environment, use the File menu’s Save
item before you copy the object into the Environment
window (described in the next section, Copying Objects
into Your Hyperinformation Environment).

Copying Objects into Your Hyperinformation Environment
To include any linkbase objects in your hyperinformation
environment, you must copy them from the Linkbase window to
the Environment window. The quick-copy method is the most
convenient. Follow these steps:

1. Move the pointer to the object in the Linkbase window.

2. Click MB1 to select the object.

3. Move the pointer to the position in the Environment window
where the object should appear.

If the pointer is over an object of the same type as the object to
be copied (for example, over a linknet when you have selected
a linknet for copying), the copied object is inserted before the
object under the pointer.
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If the pointer is over any other type of object or over a segment
header (Linknets or Paths), the copied object is inserted at the
end of the appropriate segment.

4. Click MB2 to copy the object into the Environment window.

You can also use the Copy and Paste items on the Edit menu to
perform the copy operation.

Using Paths
A path is a stored sequence of navigation steps (Visit and Go To
operations). You can create a path and record steps in it, and
afterward you can follow the path as often as you want. You can
follow paths created by other users, and others can follow your
paths. You must have access to another user’s linkbase file to use
paths or other objects in that person’s linkbase.

Recording Steps in a Path
To create a path that contains meaningful steps, you must do
substantial preliminary work before you actually record the
steps. You should devote the same planning and preparation to a
path as you would to a paper explaining a difficult subject or an
instructional manual. For a path to be useful to you and others,
it must contain precisely the right steps in the right sequence, so
that the ‘‘flow’’ is helpful to the user who follows the path.

To record steps in a path:

1. Identify the objects to be linked.

For example, you might identify several Bookreader topics and
Cardfiler cards that explain and illustrate a particular topic.

2. Identify the sequence in which the objects should appear.

3. Create the links. Make the first object the source of a link
and the second object the target. Make the second object the
source of another link and the third object the target. Make
the third object the source of another link and the fourth
object the target, and so on, until you have linked to the final
object.

4. If you have not already done so, create the path (as explained
in Creating Linkbase Objects), and copy the path into your
hyperinformation environment (as explained in Copying
Objects into Your Hyperinformation Environment).
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5. Double click in the Record column in the Environment window
to enable recording in the path.

6. Use the appropriate hyperapplication to select and view
the first object. For example, invoke Bookreader, open the
appropriate book, and read the topic that introduces the
subject of your path.

7. Choose the Go To or Visit item from the hyperapplication’s
Link menu to display to the second object.

If your path includes objects from two or more hyperap-
plications, you might find Go To useful in reducing screen
clutter.

8. Select the object that was just displayed.

9. Choose the Go To or Visit item from the hyperapplication’s
Link menu to display to the next object.

10. Repeat steps 8 and 9 as often as needed until you display the
final object in the path.

11. Double click on the Record column to disable recording of
steps into the path.

Following a Path
To follow a path:

1. If you have not already done so, include the path in your
hyperinformation environment, as described in Copying
Objects into Your Hyperinformation Environment.

2. Double click on the Active column of the Environment window
to make that path active. If other paths are active, double
click on them to make them inactive.

3. Choose the Step Forward item in the Link menu of any active
hyperapplication to go from one step to the next.

You must follow the steps in sequence. You cannot skip steps
or selectively repeat steps.

If you want to start over on the path at any time, double click
on the Active column to make the path inactive and then
double click again to make the path active again. If you now
step forward, you are at the first step in the path.

9–14 Using LinkWorks Manager



When you are finished following a path, you can double click in
the Active column of the Environment window to make the path
inactive.

Exiting LinkWorks Manager
To exit LinkWorks Manager, choose the Exit item on the
Environment window File menu.

If there are unsaved changes in any open Linkbase windows, you
are asked whether you want to save the changes before exiting.
Click on the appropriate button.
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10
Using Mail

Mail allows you to exchange messages with other computer users.
You can use Mail to send messages; read messages sent to you;
and print, file, delete, reply to, and forward messages.

This chapter describes how to

• Send messages

• Read messages

• Reply to messages

• Forward messages

• Print messages

• Create files from messages

• Work with drawers and folders

• Customize your Mail environment

• Exit Mail

Starting Mail
To start Mail, choose Mail from the Session Manager’s
Applications Menu. Mail displays the main window. You can also
start Mail automatically by using the Applications Definitions,
Applications Menu, and AutoStart entries from the Session
Manager’s Customize menu. (See Using DECwindows Motif for
OpenVMS for more information.)
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HelpFile Edit Pick Create−Send Read Maintenance Options

Mail

Link

8−APR−1994 NABOB::SMITH

27−APR−1994 SOIREE::JONES

4−MAY−1994 DARCY::MORRIS

16−MAY−1994 UDO::GREEN

18−MAY−1994 BRONTE::BLACK

Team Meeting, 1:00

lunch invitation

RE: review schedule

poetry reading

dog class canceled

1

2

3

4

5

MAIL

INBOX − 5 messages

DeleteMovePrintCreate−SendReceive MailRead New Mail

MAIL
WASTEBASKET

STATUS REPORTS

WASTEBASKET
REPORTS
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Note

You can choose an alternate display style for the main
window. See Using Alternative Main Window Styles for
more information.

The Main Window
The main window lists your Mail drawers, folders, and messages.
Drawers and folders help you organize your mail messages. You
use Mail drawers and folders as you would use drawers and
folders in your office filing cabinet. You might file all messages
on a related topic in one folder and group related folders in one
drawer. You can create as many drawers and folders as you need.
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Drawers and Folders
You can open drawers and folders to reveal their contents and
close them to conceal their contents. To open a drawer or folder,
double click MB1 on the drawer or folder name. To close a drawer
or folder, double click MB1 on the name of an open drawer or
folder.

When you enter Mail for the first time, a drawer named MAIL is
automatically created and opened. The two objects in the MAIL
drawer, INBOX and WASTEBASKET, appear indented below the
drawer name. The INBOX folder contains messages that have
been sent to you. The WASTEBASKET contains messages that
you have deleted. The icon representing the WASTEBASKET is a
trash container.

The INBOX folder is also automatically opened when you enter
Mail, as indicated by the open folder icon in front of INBOX.
If there are any messages in the INBOX folder, they are listed.
Messages are chronologically arranged by date received.

Drawers, folders, and messages are identified by unique icons.
These icons also indicate whether the object is open or closed.

Note

If you have used the OpenVMS Mail utility, Mail
automatically changes the names of your Mail folders
to correspond to OpenVMS Mail folders. See Making
Mail Perform Like the OpenVMS Mail Utility for more
information.

Push Buttons
Near the bottom of the window is a row of push buttons. These
buttons allow you to perform the functions most commonly used
with messages. Many of the push buttons are disabled when you
first start Mail and remain so until you select a specific message.
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Pop-up Menus
Pressing MB3 on an object in a Mail window displays a pop-up
menu. Pop-up menus list many commonly performed tasks. The
items on a pop-up menu vary according to the type of object
(drawer, folder, or message) on which you are positioned, and they
act on the object on which you are positioned.

Pop-up menu items and push buttons duplicate pull-down menu
items. In cases where you can choose a push button, pop-up
menu, or pull-down menu to perform a task, instructions in this
chapter list one way to accomplish the task. You might prefer to
use one of the other methods once you are familiar with Mail.

Accelerators
You can use certain key combinations, called accelerators, to
perform common Mail tasks quickly. Accelerators act on objects in
the window with input focus. For example, one way to delete the
message you are reading is to pull down the Read window’s Edit
menu and choose Delete. Another way to delete the message you
are reading is to use the accelerator for this function by pressing
the Ctrl key and the D key simultaneously. Functions that have
accelerators also list the accelerators next to them on the menu.
See the table at the end of this chapter for a list of functions that
have corresponding accelerators.

Scroll Bars and Stepper Arrows
The vertical scroll bar in Mail’s main window contains top and
bottom stepper arrows and a navigation window, which are not
present in standard DECwindows Motif scroll bars. The top and
bottom stepper arrows, located at the top and bottom of the scroll
bar, scroll the window to the next drawer or folder in the direction
indicated. The navigation window is displayed in the upper right
corner of the main window when you drag the vertical slider
through the scroll region of the scroll bar. This window shows the
drawer or folder that would appear at the top of the index if you
released the slider.

Creating and Sending Messages

Create−Send
You can create and send a mail message or an existing file to one
user or many users with Mail.
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Creating a Message
To send a mail message to any user on your system or another
system, click on the Create–Send button in the main window. A
Create–Send window opens. You can have multiple Create–Send
windows open at one time.

HelpFile Edit Change Editor

Mail: Create

Search

ZK−2779A−GE

SendResetClose

From: THACKER

To:

CC:

Subject:

^

Timothy Thacker

THACKER

The Create–Send window is divided into an envelope area and a
message area. The envelope area contains the following items:
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Field Description

From Your user name.

If you specified a personal name in your mail profile,
it is displayed to the right of your user name. Your
mail profile, available from the main window’s Options
menu, allows you to customize specific features in Mail.
See Customizing Your Mail Environment for more
information about specifying a personal name. You
can alter your personal name for the current message by
entering a change in this text entry box.

To The name of the user or users receiving the message. If
you are sending mail to people on your node, specify only
their user names. If you are sending mail to people on
another node, you must enter their node names and user
names using the following format: node-name::user-name.
If you are using a message router, enter the address in
the appropriate format for your router.

You can send the same message to several users by
separating their user names with commas. Press the
Return key if you need more space.

For information about sending a message to a
distribution list, see Sending a Message to a Distribution
List.

CC (Optional) The name of the user or users you want to
receive a copy of the message. If you have set the Copy
Self on Send option in your mail profile, your user name
is displayed.

For information about sending a copy to a distribution
list, see Sending a Message to a Distribution List.

Subject (Optional) The subject of the message. Press the Return
key if you need more space.

To enter text in a text entry box, point to the text entry box and
click MB1. Use the Tab key to advance to the next text entry box,
and use Shift+Tab to move to the previous text entry box. Use the
DECwindows editing commands, described in Using DECwindows
Motif for OpenVMS, to correct mistakes. When the envelope is
complete, press the Tab key to move to the message area.

In the message area, enter the text of your message.

By default, you can use the DECwindows editing commands
described in Using DECwindows Motif for OpenVMS to edit your
message. If more than one editor is available on your system,
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you can use a different editor. See Changing Editors for more
information.

Sending a Message
To send the message, click on the Send button. Mail displays a
message box informing you of the progress of the send operation.
The Send button in the Create–Send window dims after the
message has been sent successfully to all addressees. It remains
dimmed until you change something in the window (for example,
if you enter text in one of the fields).

Once a message has been sent, you can edit it, resend it to other
users, or choose an option from the File pull-down menu. To
continue to use this message, click on Acknowledged in the Send
In Progress box. The dialog box disappears and the message
remains in the window.

To create another message, click on the Reset button. This clears
the message and envelope areas in the window and allows you to
enter information for a new message.

To close the window, click on the Close button. This removes the
Send In Progress box, deletes all text in the window, and closes
it. You can also have Mail automatically close your Create–Send
window after a successful send operation. This option is disabled
by default in your Send options. See Modifying Your Send Options
for more information about changing your default Send options.

If you change the header or text of a message in a Create–Send
window and then close the window without sending the message,
a caution dialog box is displayed. The message ‘‘Changes have
been made to the Create–Send window. Do you really want to
close it?’’ appears. To close the window, click on Yes. To keep the
window open, click on No.

You can prevent this dialog box and message from appearing by
changing your default Send options. See Modifying Your Send
Options.
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Saving a Draft of a Message
Saving a draft of a message allows you to begin composing a
message now and continue working on it later. If you are creating
a long mail message, you should save the message occasionally. To
save a draft of a new message you are creating:

1. Choose Save As... from the Create–Send window’s File menu.

Mail displays a dialog box.

Mail: Save As

Draft:

OK Cancel

ZK−2780A−GE

2. Enter the name of the draft message.

The name can be no longer than 39 characters. It must begin
with a letter or number, and it can contain letters, numbers,
underscores ( _ ), hyphens ( - ), and dollar signs ( $ ). By default,
the file extension DRAFT is appended to the file name, and
the file is stored in your default draft directory. If you specify
a different file extension or directory, Mail does not list this
file when you request a list of your draft files.

3. Click on the OK button to save the draft message.

The complete text of the message is saved, but the envelope
information is not preserved.

You can still send or cancel the message after you have saved it.

Saved draft messages are OpenVMS files and cannot be deleted
through Mail. You can delete draft messages by choosing Delete
from FileView’s Files menu or in a DECterm window.

Resuming Work on a Draft Message
You can continue working on a draft of a message that you
previously saved.

To resume work on a draft message:

1. Choose Include Draft File... from the Create–Send window’s
File menu.
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Mail displays a file selection dialog box.

Mail: Send Draft File

Filter

SYS$USERS:[  ]*.DRAFT

Selection

Directories Files
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$USERS:[  ]

[JONES.DECWMAIL]

RESOURCES.DRAFT;3

REVIEW_PROCESS.DRAFT;1

OK Filter Cancel Help

The dialog box prompts you for the name of the draft file on
which you want to continue working. The file list box lists the
names of any draft files in your default draft directory.

2. Double click on the name of the draft file you want.

The draft message is displayed in the Create–Send window,
where you can continue working on it.

If you want to work on a draft file that is not listed, enter the
name of that file in the Selection entry box and click on the OK
button. Alternatively, use the File Filter entry box to list a subset
of files from which you can select. For example, to list all files
in another directory with the file extension DRAFT, enter the
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complete directory specification—[JONES.LETTERS]*.DRAFT—in
the File Filter entry box and click on the Filter button. Then
double click on the name of the file on which you want to continue
working.

Including a File in a Message
You can insert an existing file into a mail message. If the file is
a text file, you can edit it. If it is a nontext file, such as a DDIF
file, you cannot edit the file in Mail or add any other text to the
message.

To include a file in a message:

1. Choose Include File... or Include File (no editor) from the
Create–Send window’s File menu.

Mail displays a file selection dialog box.

The dialog box prompts you for the name of the file you want
to include. The file list box lists the names of all files in the
default directory.

2. Type the name of the file you want to include and click on OK.

If you chose Include File..., the contents of the file are
displayed in the Create–Send window. You can edit the
file.

If you chose Include File (no editor)..., a message indicating
the file specification of the file you are sending appears in the
Create–Send window.

3. Click on the Send button to send the message.

Including the Last Sent Message in a New Message
You can send a message using the last message you sent.

To include the last sent message in a new message:

1. Click on the Create–Send button in the main window.

Mail opens a Create–Send window.

2. Choose Include Last Sent or Include Last Sent (no editor) from
the Create–Send window’s File menu.

Mail displays the last message you sent, including the header
information, in the message area of the window.
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3. You can now enter addressing information if you have not
already done so. Unless you chose Include Last Sent (no
editor), you can edit the message and add any new text.

4. To send the message, click on the Send button.

Sending a Message to a Distribution List
If you need to send one message to many users, you can create
a file, called a distribution list, that contains a list of users. You
then specify an at sign ( @ ) and the file name in the To entry box
when you send the message (for example, @PROJECT).

Distribution lists are not created within Mail. Use an editor,
such as EVE, to create your distribution lists. When creating
distribution lists, enter one user name per line. Exclamation
points ( ! ) delimit comments; Mail ignores everything to the right
of the exclamation point. You can also include the names of other
distribution lists by specifying an at sign ( @ ) followed by the
name of the distribution list. For example, a distribution list file
could contain the following:

MIASMA::FORD ! Craig, project leader
YONKIN
TUTTLE ! Mona, product manager
DARCY::MORRIS
@PROJECT

When naming distribution list files, use a DIS file extension
because that is what Mail looks for by default.

To send mail to the users on a distribution list:

1. Move to either the To or CC entry box in the envelope area of
the Create–Send window and press MB3.

A pop-up menu is displayed.

2. Choose Distribution List... from the pop-up menu.

Mail displays a file selection dialog box.

The dialog box prompts you for the name of the distribution
list file you want to use. The file list box lists the names of
any distribution list files (files that have the extension DIS) in
your default directory.

3. Double click on the file name of the distribution list you want
to use.
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The distribution list file name is displayed in the To or CC
entry box in the Create–Send window’s envelope area.

If you want to use a distribution list file that is not listed, enter
the name of that file in the Selection entry box and click on the
OK button.

Searching for Text in Messages
Search

Find Next Selected

Find Prev Selected

Find...

Find Incremental...

Shift+Find

Ctrl+Shift+Find

Find

Replace... Ctrl+Find

You can search an ASCII text message that you are creating or
reading for the text you specify.

To start the search from the beginning of the message area, click
MB1 on the beginning of the message.

To search for text:

1. Choose Find... from the Create–Send or Read window’s Search
menu.

Mail displays a dialog box.

Mail: Find
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Search

Previous CancelNext

Case Sensitive Searches

2. In the Search entry box, type the word or text for which you
want to search.

3. If you want to search for only exact matches of text, including
uppercase and lowercase letters, click on Case Sensitive
Searches. For example, if you enter ‘‘gOod’’ and choose Case
Sensitive Searches, Mail finds occurrences only of ‘‘gOod’’ and
disregards ‘‘good’’, ‘‘GOOD’’, or any other combination that
does not match exactly.

You can customize your User options to enable or disable
Case Sensitive Searches as the default. For more information
on customizing your User options, see Modifying Your User
Options.
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4. Click on Next to search forward through the message from the
current cursor position. Click on Previous to search backward
from the current cursor position.

When Mail finds the first occurrence of specified text, it
highlights the text.

5. To continue searching, click on Next or Previous.

If Mail finds no more occurrences of the specified text in the
direction you are searching, it issues an audible beep.

6. To end the search and dismiss the dialog box, click on Cancel.

You can also use Find Next Selected and Find Previous Selected
on the Search menu to find the next or previous occurrence of
the specified text. You can customize your User options to enable
or disable Case Sensitive Searches as the default. For more
information on customizing your User options, see Modifying Your
User Options.

Searching for text with the Search menu’s Find Incremental menu
item is similar to using Find. With Find Incremental, the search
is performed as each character is typed in. This method is useful
if you need to find a name that can be spelled several ways (for
example, Sloan, Sloane, or Slone).

Replacing Text in Messages
You can replace text in a message that you are creating with
different text.

To replace text:

1. Choose Replace from the Create–Send window’s Search menu.

Mail displays a dialog box.
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Mail: Replace
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Old

New

Case Sensitive Searches

Replace Once

Replace Within Selected Area

Replace All

CancelReplaceFind

2. In the Old entry box, type the existing word or text you want
to search for; this is the text that will be replaced.

3. In the New entry box, type the new word or text that should
replace the existing text.

4. If you want to find only exact matches of text, including
uppercase and lowercase letters, click on Case Sensitive
Searches.

You can customize your User options to enable or disable
Case Sensitive Searches as the default. For more information
on customizing your User options, see Modifying Your User
Options.

5. Choose Replace Once, Replace Within Selected Area, or
Replace All by clicking on the appropriate button.

Replace Once replaces one occurrence of the old text at a time.

If you choose Replace Once and click on Find, Mail searches
forward in the message from where the cursor is currently
positioned to find the first occurrence of old text. To move to
the next occurrence of old text without making any changes,
click on Find again. To replace the old text with the new text,
click on Replace; the cursor automatically moves to the next
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occurrence of the old text. If there is no match, Mail issues an
audible beep.

Replace Within Selected Area replaces all occurrences of the
old text in a selected area of text. When all substitutions have
been made, the Replace dialog box is automatically dismissed.

Replace All replaces all occurrences of the old text in the
entire message. When all substitutions have been made, the
Replace dialog box is automatically dismissed.

6. Click on Replace to replace the old text.

If you chose Replace Once, you can first click on Find to verify
that the text found is the text you want to replace.

The Find function is not available with Replace Within Selected
Area or Replace All.
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Changing Editors

DECterm EVE

DECwindows EVE

Change Editor Mail uses the DECwindows editing commands, described in Using
DECwindows Motif for OpenVMS, as the default editor you can
use to create messages. If more than one editor is available on
your system, you can choose a different default editor to create a
message. To change your default editor, see Modifying Your Send
Options.

You can also change the editor for a specific message by doing the
following:

1. Choose the desired editor from the Create–Send window’s
Change Editor menu.

A new window opens, containing any text you already entered
in the message.

2. Click on the new window to give it input focus.

3. Enter the text of the message using editing commands that
are appropriate for your chosen editor.

4. Exit the editor.

You cannot edit the message after you exit the editor. You
cannot extract the message to a file or create a draft of the
message. You can edit the message envelope by clicking on a
field in the Create–Send window.

5. To send the message, click on the Send button in the
Create–Send window.

To send another message, click on the Reset button. The
DECwindows Text Editor is once again the default, and all
Create–Send options become available.

Sending PostScript Files
When you send POSTSCRIPT files, do not use an editor. Instead,
choose File (no editor)... from the Main window’s Create–Send
menu. Using the File (no editor)... option ensures that the files
contain only POSTSCRIPT language and are formatted correctly.
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Selecting Messages
Before you work with an object (message, drawer, or folder), you
first have to select that object.

To select a message, folder, or drawer, point to the object in the
main window and click MB1.

To select multiple objects, press and hold the Ctrl key while
clicking MB1 on each desired object.

To select a range of drawers, folders, or messages, click MB1
on the first object to be selected, then press the Shift key while
clicking MB1 on the last object to be selected.

To select all messages in an open folder, choose Select All from
the main window’s Edit menu. If more than one folder is open, all
messages in those folders are selected.

To cancel the selection of one object, select another object by
clicking MB1, or point to the selected object and press and hold
the Ctrl key and click MB1.

Reading Messages
INBOX

5

4

3

2

1

You can use Mail to read an old or a new mail message. New
messages are added to the INBOX folder; old messages (messages
that have been read) are held in the INBOX folder until you move
them elsewhere. (This default can be changed in your mail profile.
See Customizing Your Mail Environment for more information
about your mail profile.)

Reading a New Message
When you receive new mail, a message is displayed in your
Session Manager window. The number of new messages is
displayed in the Mail icon.

To read a new message, start the Mail application if it is not
already running. The messages in the INBOX folder are
listed; unread messages are identified by an icon resembling
an addressed envelope. Double click MB1 on the message to be
read. Mail displays the message in a Read window.
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HelpFile Edit Create−Send Read

Mail: Read 1[D] MAIL INBOX #1

ZK−2784A−GE

Search

Please make sure there are 1500 lbs. of ice for today’s luncheon.

Date:
From:
Subj:
To:
CC:

26−APR−1994 10:56:34.67
SOIREE::JONES
luncheon
@Staff

DeleteClose ReplyRead New Mail Move Message

A message that you have read remains in the INBOX folder until
you move it to another folder or delete it. You can specify that
messages be placed automatically in another folder once they
are read. See Customizing Your Mail Environment for more
information.

Read New Mail Button
If Mail is running on your system when you receive new mail, the
Mail icon in your icon box changes and the Read New Mail and
Receive Mail buttons in the main window become active. To read
a new message, click on the Read New Mail button. This adds
new messages to the INBOX folder, opens the INBOX folder, and
displays the first unread message in the INBOX folder.
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You cannot use the Read New Mail button if you are reading a
message from the INBOX folder in a Read window other than the
default Read window, or if you are replying to a message in the
INBOX folder. (For a description of default Read windows, see
Multiple Read Windows.)

The Read Window
A Read window is divided into an envelope pane and a message
pane.

The envelope pane displays the name of the person who sent the
message and other address information. Use the scroll bar to
display additional information about the message, such as text
indicating that the message is marked or has been replied to,
the message size, message ID, and whether the message is in a
foreign format.

The message pane displays the mail message. Use the scroll bar
to display any text that does not fit in the pane.

Adjusting Pane Size
You can adjust the relative size of the panes by using MB1 to drag
the border between the panes. Press MB1 on the pane knob (box)
on the far right of the dividing line, drag the line to the desired
location, and release MB1. Making one pane smaller makes the
other pane larger. This allows you to view more text in either
pane without resizing the window.

The Message Button
You can click on the Message button at the bottom of the Read
window to display the next page of a message, or the next message
if you are at the end of the current message. If there are no more
messages, Mail issues an audible beep.

Clicking on the left arrow of the Message button displays the
beginning of the previous message in the current folder. Clicking
on the right arrow of the Message button displays the beginning
of the next message in the current folder.
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Reading Nontext Messages
If you receive a message whose contents are not text or are not
in POSTSCRIPT, DDIF, or DTIF format, you cannot view the file
in Mail. Mail displays a message informing you of the problem.
You can print, forward, extract, or reply to the message. See the
appropriate sections of this chapter for information about printing,
forwarding, extracting, and replying to messages.

Close Button
To close a Read window, click on the Close button.

Displaying a List of New Messages

Receive Mail
You can add new messages to your INBOX folder and update
the list of new messages without reading a message. To update
the INBOX folder, click on the Receive Mail button in the main
window.

If you click on the Receive Mail button while you are reading a
message in the INBOX folder, Mail closes the Read window before
delivering your mail. If you are reading a message in the INBOX
folder in a Read window other than the default Read window,
you cannot receive your messages, and Mail displays a message
informing you of the problem. See Multiple Read Windows for a
description of default Read windows.

You cannot receive new mail if you are replying to a message in
the INBOX folder.

Reading an Old Message

Delete

Read

Move...

Extract...

Undo Move/Delete

Read in new window

Reply

Forward

To read an old message (one that you have already read), open the
drawer and folder containing the message and double click on the
appropriate message. The message is displayed in a Read window.

To read a series of old messages that are in different folders or are
not consecutive:

1. Select the messages to be read.

2. Point to one of the selected messages, press MB3, and choose
Read or Read in New Window from the pop-up menu.

3. In the Read window, click on the right or left arrow of the
Message button to display the next or previous selected
message.
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Multiple Read Windows
You can open more than one Read window at one time. This
allows you to read multiple messages at once or to read new mail
without disrupting the message you are currently reading.

The first Read window you open is your default Read window. It is
identified by the symbol [D] in the window’s title bar. Additional
Read windows are identified by the number in their title bar, for
example, Read 2, Read 3, and so on.

Mail displays your mail messages in the default Read window
unless you specify another window. For example, clicking on the
Read New Mail button or double clicking on a message in the
main window displays the message in your default Read window.

To read new mail in another Read window, display the main
window’s Read menu and choose New Mail in New Window. A
new Read window is opened, and the first message received since
the INBOX folder was last opened is displayed. This is possible
only if the default Read window is displaying a message from a
folder other than the INBOX folder.

To read an old message in another Read window, select the
message, display the main window’s Read menu, and choose In
New Window.

Replying to Messages

Reply
You can reply to a message that is selected in the Main window or
to the message currently displayed in a Read window.

To reply to the currently displayed message, click on the Reply
button in the Read window.

To reply to the first selected message, choose Reply from the main
window’s Create–Send menu. If you want to use the text of the
message in your reply, choose Reply Using Selected Message
instead.

To include a file or the text of another message in your reply,
pull down the File menu in the Create–Send window. Choose the
appropriate menu item from the list displayed:

• Include File... or Include File (no editor)...

Include File... and Include File (no editor)... allow you to
send an OpenVMS file that resides in your account. For more
information, see Including a File in a Message.
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• Include Draft File...

Include Draft File... allows you to send a draft file that you
have created. For more information, see Saving a Draft of a
Message.

• Include Original

Include Original allows you to reply using a copy of the
original message.

• Include Last Sent or Include Last Sent (no editor)

Include Last Sent and Include Last Sent (no editor) allow you
to include in your reply a copy of the last message you sent
during this Mail session.

Replying to a message opens a Create–Send window. In the To
entry box, Mail inserts the name of the sender of the original
message. In the Subject entry box, Mail inserts RE: followed by
the subject of the original message. If you chose to reply using
a message or file, the text of the message or file appears in the
message area.

Unless you chose Include File (no editor)... or Include Last Sent
(no editor), enter text and make any desired edits.

To send the reply, click on the Send button. To close the
Create–Send window, click on the Close button.

Forwarding Messages

Forward
You can forward either a message selected in the Main window
or the message currently displayed in a Read window to another
user.

To forward the selected or currently displayed message:

Create−Send

New Message

File...

File (no editor)...

Reply

Reply using selected message

Ctrl+B

Ctrl+A

With Header (no editor)

Without Header

Without Header (no editor)

Ctrl+FWith HeaderForward

1. Pull down the Create–Send menu in the main or Read window
and display the Forward submenu.

2. Choose With Header, With Header (no editor), Without
Header, or Without Header (no editor).

In most cases, the header (address information) is included in
the forwarded message. Headers are not included in messages
that are created with editors that do not produce ASCII files,
such as files created with the Paint application.
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Forwarding a message opens a Create–Send window. In the
Subject entry box, Mail inserts FWD: followed by the subject of
the forwarded message. In the message area, Mail inserts the
forwarded message with its header unless you chose Without
Header. If you chose With Header (no editor) or Without Header
(no editor), Mail displays a message in the message area showing
the name of the file it is sending.

Enter the address information and make any desired changes to
the text. If you change the original message and want to include
the unedited version in your forwarded message, choose Include
Original from the Create–Send window’s File menu.

Click on the Send button to send the message. Click on the Close
button to close the window.

Printing Messages

Prin t
You can print either selected messages or the message currently
displayed in a Read window. You can print messages using your
default print settings, or you can modify the print settings for the
messages being printed.

To print the selected or currently displayed message using your
default print settings, click on the Print button in the main
window, or choose Print from the Read window’s File menu.

Using Mail 10–23



To print the selected or currently displayed message using altered
print settings:

File

Print

Extract...

Move...

Copy...

Open−Close

Receive Mail

Exit

Print...

Ctrl+P

Ctrl+M

Ctrl+E

1. Choose Print... on the File menu in the main or Read window.

Mail displays a dialog box.

Mail: Print

ZK−2791A−GE

Include message header and contents

Include message contents only

Options...

OK

Cancel

The Include Message Header and Contents radio button is set
to indicate that the header (sender’s name, date, subject, and
so on) and the contents of the message are to be printed. To
exclude the header information, click on the Include Message
Contents Only radio button.

If you are printing a nontext message, such as a message
created with the Paint application or a message containing
special formatting commands (such as a POSTSCRIPT file),
you must click on the Include Message Contents Only radio
button.

2. To change additional print settings, click on the Options...
button.

You must also click on the Options... button to specify an
appropriate print format and printer if you are printing a
nontext message or a message containing special formatting
commands, such as a POSTSCRIPT file.

Mail displays a dialog box.
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Mail: Print Options

OK

Cancel

Options...

Help

Print Format Printer

Line Printer
Terminal
ANSI2
ANSI

Text CLUSTER_PRINT

LN03$PRINT

Print After

Number of Copies

Page Range:  From

Orientation: Default Portrait Landscape

To

ZK−2792A−GE

ARNO$LIA0
ARNO$TXA0
KODIAK
LN03$PRINT

now

Delete File When Printed

See Using DECwindows Motif for OpenVMS for more
information about the Print Options dialog box.

3. Click on the OK button to print the messages.

Extracting a Mail Message to a File
File

Print

Move...

Copy...

Open−Close

Receive Mail

Exit

Print...

Ctrl+P

Ctrl+M

Ctrl+E

Extract...

You can create an OpenVMS file from a mail message. You can
select an existing message to be copied to a file, or you can create
a file from a message you are reading or creating.

To create a file from the selected or currently displayed message:

1. Choose Extract... from the File menu in the main,
Create–Send or Read window. Mail displays a dialog box.
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ZK−2794A−GE

File:

Input Format:

Mail: Extract

Include Header Information

Append to Existing File

Output Format:

Conversion Options File:

As Is

Same As Input

CancelOK

The Include Header Information button is set to indicate
that the message’s header will be included in the file you are
creating if it is an ASCII file. You can disable this feature by
clicking on the check button.

If you want to append the extracted message to an existing
file, enable the Append to Existing File option by clicking on
the check button. By default, this option is disabled.

2. Enter the name of the file to be created. If you want to append
the message to an existing file, enter the name of that file.

The default file extensions are:

TXT for text and untagged files
DDIF for DDIF files
DTIF for DTIF files
DDIF or DTIF for DOTS files, depending on whether the
primary file’s extension is DDIF or DTIF

You can enter a different file extension.

3. To select a different format for the file being created, move to
the Output Format entry box, press MB1, and choose one of
the listed file formats.
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The input format is determined by the editor used to create
the message. By default, the output format is the same as the
input format.

If you choose a different format for the file to be created, data
converters are invoked. You should select a different output
format only in cases where you understand the actual data
format of the message you want to extract and the format in
which you want the extracted file. The header information of
the message is not converted to the new data format; only the
body of the message is converted. You might want to disable
the Include Header Information and Append to Existing File
options.

4. To use a conversion options file, enter the name of the file.
Conversion options files contain special processing commands.
These files are not created within Mail. Refer to Chapter 5 for
more information about conversion options files.

5. Click on the OK button to create the file.

If more than one message is selected and the messages have
different data types, non-ASCII messages are converted to ASCII
if possible. If they cannot be converted to ASCII, the messages are
not extracted.

Deleting and Retrieving Messages

Delete
You can delete mail messages and retrieve deleted messages.

To delete selected messages or the message currently displayed in
the Read window, click on the Delete button in the main or Read
window.

The index is updated to show which messages have been marked
for deletion. Messages are not deleted until the folder is closed.
You can still perform many Mail tasks on messages that are
marked for deletion, such as moving, copying, and printing. When
the folder is closed, the messages are deleted and reference to
them is removed.

Once the folder is closed, deleted messages are moved to the
WASTEBASKET in the drawer from which the message was
deleted.
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Deleted messages collect in the WASTEBASKET folder until
you empty it. To empty the WASTEBASKET, select the
WASTEBASKET or the drawer in which the WASTEBASKET
resides, and choose Empty Wastebasket from the main window’s
Maintenance menu. (An option in your mail profile allows you to
specify that the WASTEBASKET be emptied whenever the drawer
is closed.) Once the WASTEBASKET is emptied, the deleted
messages are irretrievable.

You can also delete entire folders and drawers of messages. See
Removing Drawers from the Index and Deleting Folders for more
information.

To reverse the delete operation in the main window, before the
folder is closed select the messages to be retrieved, pull down the
Edit menu, and choose Undo
Move/Delete.

To reverse the delete operation in a Read window, press MB3
in the message pane of the deleted message and choose Undo
Move/Delete from the pop-up menu.

To update the index of messages to reflect that the messages have
been moved to the WASTEBASKET, either select Update Folder
from the Maintenance menu in the main window, or reopen the
folder that contains the deleted message.

Once you have moved a message to the WASTEBASKET, you can
retrieve the message by moving it to another folder. See Moving
and Copying Messages to Another Folder for more information
about moving messages between folders.

Working with Drawers and Folders

Delete Folder...

Create Folder...

Empty Wastebasket

Remove Drawer...

Add drawer to index...

Modify Drawer...

Compress Drawer

Scan mail directory for mail drawers

Ctrl+UUpdate Folder

Maintenance You can add and remove drawers in your index, modify a drawer’s
file name and display name, create and delete folders, move and
copy messages between folders, and reclaim unused space in
drawers.

Adding New Drawers to the Index
There are two ways to add new drawers to your index. You can
add (create) a drawer that does not currently exist, or you can add
an existing drawer to the index.
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When you create a drawer in DECwindows Mail, the drawer is
automatically created in your default mail directory and is listed
in your main window. If you create drawers with the OpenVMS
Mail utility or if you create drawers in a different directory, they
are not automatically added to the list in your main window. To
access these drawers, you must add them specifically to the main
window.

To add drawers created with the OpenVMS Mail utility in your
default mail directory, choose Scan Mail Directory for Mail
Drawers from the main window’s Maintenance menu. All drawers
in your default Mail directory are added to the main window.

To create a new drawer or add a drawer created in a different
directory:

1. Choose Add Drawer to Index... from the main window’s
Maintenance menu.

Using Mail 10–29



Mail: Add Drawer

Filter

SYS$USERS:[JONES]*.MAI

Directories Files

ZK−2796A−GE

SYS$USERS:[JONES]

SYS$USERS:[JONES.TEMP]

Selection

Display Name

PERSONAL.MAI;1

OK Filter Cancel Help

A file selection dialog box displays all files in your default
login directory that have a extension of MAI. Ignore the
files beginning with the prefix MAIL$. These are messages.
Drawer names do not have this prefix.

2. Double click on the file name of the drawer you want to add.

If you want to add (create) a drawer whose file name is not
listed, enter the name of that file in the Selection entry box
and click on the OK button.
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3. In the Display Name entry box, enter the name to be displayed
in the main window. If you do not enter a name, the drawer’s
file name is used by default.

When you add new drawers, a WASTEBASKET is automatically
included in each new drawer. You can choose a different name
for your folder for deleted mail when you create new drawers by
changing your User options. See Modifying Your User Options for
more information.

Modifying Drawer Names
You can enter a new file name or display name, or both, for a mail
drawer. You can change the display name for the default MAIL
drawer, but you cannot change the file name.

To modify the file name and display name of a drawer:

1. Choose Modify Drawer... from the main window’s Maintenance
menu.

Mail displays a dialog box.

Mail: Modify Drawer

ZK−2817A−GE

Drawer File Name:

Drawer Display Name:

SYS$USERS:[JONES]NEWDRAWER.MAI

Cancel

NEWDRAWER

OK

2. To change the drawer’s file name, type the new file name for
the drawer in the Drawer File Name entry box.

A drawer file name is an OpenVMS file specification and has
the same limitations. The prefix MAIL$ is reserved by Mail
and should not be used as a prefix for drawer file names. All
drawer file names must be unique.

3. To change the drawer’s display name, type the new display
name for the drawer in the Drawer Display Name entry box.
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The drawer display name is listed in your main window index
and can be different from the drawer name. A display name
is limited to 39 characters. It must begin with a letter or
number, and it can contain letters, numbers, underscores ( _ ),
hyphens ( - ), and dollar signs ( $ ).

Display names are case sensitive. That is, the display names
IMPORTANT and Important are not the same.

4. Click on the OK button to make the change.

Removing Drawers from the Index
When you no longer need to have a drawer listed in your index,
you can eliminate it in one of two ways: you can remove the
drawer from the index or you can delete it.

Removing a drawer removes only the drawer’s name from the
index; the drawer’s contents are not affected and the drawer is not
deleted. You can retrieve it by choosing Scan Mail Directory for
Mail Drawers... or Add Drawer to Index... from the Maintenance
menu.

Deleting a drawer removes the drawer’s name from the index and
deletes the drawer and its contents.

To remove or delete a drawer:

1. Select the drawers to be removed.

2. Choose Remove Drawer... from the main window’s
Maintenance menu.

Mail displays a dialog box.
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Mail: Remove Drawer

ZK−2818A−GE

Drawer "NEWDRAWER" contains 2 folders.

Remove Drawer
Only affects the index. It does not
affect the contents of the drawer.

Delete Drawer

Affects the index in addition to permanently
deleting the contents of the drawer.

CancelOK

3. Click on the Remove Drawer radio button to remove the
drawer’s name from the index, or click on the Delete Drawer
radio button to remove the drawer’s name from the index and
delete the drawer and its contents.

4. Click on the OK button to remove or delete the drawer, or
click on the Cancel button to cancel the request.

If you selected multiple drawers, you must confirm or cancel
the delete request for each drawer separately.

You cannot delete or remove an open drawer or the MAIL drawer.

When you delete a drawer, any folders that existed in the drawer
are deleted and the messages in them cannot be retrieved. If you
attempt to delete the MAIL drawer, all messages and all folders
except INBOX and WASTEBASKET are deleted, but the drawer
itself is not deleted.

Creating New Folders
Choosing Create Folder... allows you to create a new folder in
which to store your messages.

To create a new folder:

1. Choose Create Folder... from the main window’s Maintenance
menu.
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Mail displays a dialog box.

Mail: Create Folder

ZK−2819A−GE

Drawer:     MAIL

Folder:

OK Cancel

2. Type the name of the new folder to be created in the Folder
entry box.

A folder name is limited to 39 characters. It must begin
with a letter or number, and it can contain letters, numbers,
underscores ( _ ), hyphens ( - ), dollar signs ( $ ), spaces, and
periods ( . ).

Folder names are case sensitive. That is, the folder names
INBOX and Inbox are not the same.

3. Click on the OK button to create the folder.

Mail automatically deletes empty folders when the drawer is
closed.

You can also create a new folder when you move or copy a
message. If you specify a destination drawer or folder that does
not exist, the drawer or folder is created.

Deleting Folders
To delete folders:

1. Select the folders to be deleted.

2. Choose Delete Folder... from the main window’s Maintenance
menu.

Mail displays a dialog box.
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Mail: Delete Folder

ZK−2797A−GE

? Folder "PERSONAL" in drawer "NEWDRAWER" contains 1 message.
Press OK to delete.

HelpCancelOK

3. Click on the OK button to delete the folder, or click on the
Cancel button to cancel the delete request.

If you selected multiple folders, you must confirm or cancel
the delete request for each folder separately.

You cannot delete an open folder.

When you delete a folder, any messages that existed in the folder
are placed in the WASTEBASKET and can be retrieved until the
WASTEBASKET is emptied. If you attempt to delete the INBOX
or the WASTEBASKET, all messages in them are deleted but the
INBOX and the WASTEBASKET are not deleted.

If you delete all messages in a folder, the folder is automatically
deleted when you close the drawer.

Moving and Copying Messages to Another Folder

Move
You can move or copy a message or group of messages from one
folder to a different folder. Moving a message to another folder
removes it from the original folder. Copying a message to another
folder does not remove it from the original folder.

You can move and copy messages from either the main or the
Read window.

To move or copy a selected message or the message currently
displayed in the Read window:

1. Choose Move or Copy from the File menu in the main or Read
window.
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Mail displays a dialog box.

Mail: Move/Copy

ZK−2798A−GE

MAIL

NEWDRAWER

TEMP

Enter destination drawer and folder.

Drawer:

Folder:

MAIL

CancelOK

Initially, MAIL is inserted in the Drawer entry box. If you
selected a folder, the name of the folder and the name of
the drawer that contains the folder are displayed in their
respective text entry boxes. If no folder is currently selected,
the Drawer and Folder entry boxes contain whatever was last
entered in those boxes.

2. Type the name of the drawer and folder to receive the message
in the appropriate text entry boxes.

If you specify a drawer or folder that does not exist, that
drawer or folder is created.

3. Click on the OK button.

When you perform a move operation, Mail displays a message
in the message pane of a Read window or in the index entry
in a main window to show which messages have been marked
for moving.
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You can still perform many Mail tasks on messages that are
marked for moving, such as deleting, copying, and printing.
When the folder is closed, the messages are moved. The
moved or copied messages are listed in the index of the
destination folder when the destination folder is next opened.

If you are using the Outline style main window, you can also move
messages by dragging. You can drag messages within a single
window only. Press and hold MB2 on the selected message, and
drag MB2 to the folder to which you want to move the message.
Release MB2.

You can also move multiple messages at one time. Select the
messages by holding the Ctrl key down while clicking MB1 on
the messages you choose. Press and hold MB2 on one of the
messages, and drag MB2 to the folder to which you want to move
the messages. Release MB2.

To reverse the move operation in the main window, select the
messages to be retrieved and choose Undo Move/Delete from
the main window’s Edit menu. You can also reverse the move
operation by dragging messages back to their original folders.

To reverse the move operation in a Read window, in the message
pane of the moved message, press MB3 and choose Undo
Move/Delete from the pop-up menu.

An alternative method for moving messages is to select the
messages, point to the destination folder, press MB3, and choose
Move Selected Here or Move Read Message Here from the pop-up
menu. The read message is the message currently displayed in
your default Read window.

Updating Folders
Messages are deleted and moved when a folder is closed. If you
have deleted or moved several messages from a folder and would
like to have your changes take effect without leaving the folder,
Mail can automatically close and reopen the folder for you.

To close and reopen a folder, completing all pending delete and
move operations, point to the folder name, press MB3, and choose
Update Folder from the pop-up menu.

To update several folders at once, select the folders and choose
Update Folder from the main window’s Maintenance menu.
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If you update a folder while you are reading a message from
that folder in your default Read window, the window is closed
when the folder is closed. The window will not be reopened.
(For a description of default Read windows, see Multiple Read
Windows.)

Compressing Drawers
When you delete messages and folders, empty space is left in
the drawer from which the messages or folders were deleted.
To make this space available for reuse, select the drawer to be
compressed and choose Compress Drawer from the main window’s
Maintenance menu.

You cannot compress an open drawer. Close the drawer before
choosing Compress Drawer.

When a drawer is compressed, the original (uncompressed) drawer
is saved in a file. A message is displayed indicating that this file
has been created and showing the name of the file. Once you have
used the compressed drawer, the uncompressed file should be
deleted. The file cannot be deleted within Mail; you must delete it
from FileView.

If you selected multiple drawers, all selected drawers are
compressed. Individual messages appear prompting you to
delete each uncompressed drawer.
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Marking and Unmarking Messages

Delete

Copy to Clipboard

Select All

Unmark

Full Information...

Undo Move/Delete Alt+Delete

Ctrl+D

Ctrl+Inser t

Mark

Edit Marking messages allows you to identify messages of particular
importance to you. For example, you might mark the messages
you want to print at the end of the day, or the messages you want
to reread or reply to at another time.

When a message is marked, an asterisk is displayed in the index
entry for this message. The message itself is unaffected.

To mark selected messages or the currently displayed message,
choose Mark from the main window’s or the Read window’s Edit
menu.

To unmark the currently displayed or selected messages, choose
Unmark from the main or Read window’s Edit menu.

Picking Messages

Pick from open folder...

Pick from selected folder...  Find

Pick Mail can search the open or selected folder for messages that have
something in common. For example, you could pick messages that
were sent by a specific user on a specific day, or messages that
contain a specific word in the subject line.

Once it finds messages that meet your criteria, Mail displays a list
of these messages. You can then perform tasks such as copying,
moving, extracting, or reading on this set of messages.

To pick messages:

1. Open or select the folder containing the messages. If you
selected multiple folders, the first folder is used for the pick
operation.

2. Choose Pick from Open Folder... or Pick from Selected
Folder... from the main window’s Pick menu.

Mail displays a dialog box.
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Mail: Pick
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From:

To:

CC:

Subject:

In Text:

Replied To Marked Opened SelectedOn:

Before:

After:
Yes

No

Yes

No

Yes

No

Yes

No

CancelOK

The dialog box allows you to specify the criteria for picking
messages.

3. Click on the option to be used and enter the pick criteria.

4. Click on the OK button to pick the designated messages, or
click on the Cancel button to cancel the pick operation.

The following table describes the options in the Pick dialog box.

Option Description

From The user name of the sender whose messages you
want to pick.

To The user name of the addressee (or the name of a
distribution list) whose messages you want to pick.
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Option Description

CC The user name of the addressee (or the name of
a distribution list) who received courtesy copies of
messages you want to pick.

Subject Text included in the subject line of messages you want
to pick.

In Text Any text string included in the body of messages you
want to pick.

On Messages received on the date you specify. Click MB1
to display the Date dialog box. To specify the day,
month, or year, click MB1 on the appropriate box,
then click on the up arrow or down arrow to specify
the date. Click on the OK button to enter this date
in the entry box, or click on the Clear button to clear
the date in the entry box. The time is ignored for this
option.

Before Messages received before the date and, optionally,
the time you specify. Click MB1 to display the date
dialog box. See the description of the On option for
information about the Date dialog box. The time can
be used as a criterion for this option.

After Messages received after the date and, if desired,
the time you specify. Click MB1 to display the Date
dialog box. See the description of the On option for
information about the Date dialog box. The time can
be used as a criterion for this option.

Replied To Messages to which you have or have not replied. You
activate this option by clicking on Replied To and
choosing Yes or No.

Marked Messages that you have or have not marked. You
activate this option by clicking on Marked and
choosing Yes or No.

Opened Messages that you have or have not read. You activate
this option by clicking on Opened and choosing Yes or
No.

Selected Messages that you have or have not selected. You
activate this option by clicking on Selected and
choosing Yes or No.

When you enter text in any of the first five text entry boxes in
the dialog box, Mail searches for matching text anywhere in the
corresponding fields of all messages in the open or selected folder.
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Searches are not case sensitive. That is, entering the text John in
the From entry box might pick messages from Jane Johnson, John
Doe, Olav Bejohnesson, and JOHN::Smith.

Once you have picked a set of messages, the message index is
updated to list only the picked messages. When the folder is
closed, the picking criteria are lost and all messages are again
available.

You cannot perform a pick operation if a folder is open in multiple
windows and contains messages to be moved or deleted. Close the
folder in all additional windows to complete the move or delete
operation before performing a pick operation.

Displaying Additional Index Information
Edit

Delete

Copy to Clipboard

Select All

Unmark

Full Information...

Undo Move/Delete Alt+Delete

Ctrl+D

Ctrl+Inser t

Mark

The main window’s message index lists one line of information
about each message. This line contains the message number, the
date it was received, the name of the sender, and the subject of
the message.

To display additional information about messages, select the
messages and choose Full Information... from the main window’s
Edit menu. The following is displayed:

• Message number.

• Envelope of the message.

• Relative size of the message. For ASCII messages, the size is
shown in records. For non-ASCII messages, such as those in
DDIF format, the size is shown in blocks.

• External message ID (if one exists). External message IDs are
assigned to non-ASCII files and to messages that are too large
to be stored within the Mail file.

• Attributes of the message. Attributes would consist of Replied
To if you replied to the message; Marked if you marked the
message; New if you have not read the message; and the
message type of non-ASCII messages, such as DDIF.
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Opening a New Main Window

Open

Move Selected Here

 

Move read message here

Update Folder

Close

Open in new window

Opening folders containing numerous messages often fills the
window, leaving no room to display other folders and messages.
You can display additional messages by creating multiple main
windows. You can create a new main window in which all of your
drawers and folders are present.

To create a new main window, point to the folder or drawer to be
opened in the new window, press MB3, and choose Open in New
Window from the pop-up menu. A new main window is displayed,
and the current folder or drawer is opened.

You can perform all Mail tasks on the drawer, folders, and
messages displayed in this window.

Sending and Receiving CDA Documents
You can send CDA documents as messages. The format of these
compound documents is usually DDIF or DTIF. DDIF and DTIF
documents cannot be edited with the DECwindows editing
commands used by Mail.

To send a CDA document to another user:

1. Choose File... from the Create–Send menu.

Mail displays a dialog box that prompts you for the name of
the file you want to use.

2. Double click on the name of the file you want to use.

The CDA document is displayed in the Create–Send window,
but you cannot edit it. Enter the address information in the
envelope area.

3. Click on the Send button to send the message.

If the recipient of a message that contains a CDA document
is using a configuration that does not use DECwindows Motif
for OpenVMS (such as a character-cell terminal), the recipient
receives a message indicating that the mail message is in a
foreign format. The recipient can view the mail envelope (address,
sender, subject) or can forward, file, reply to, extract, or delete the
message, but might not be able to view the message.
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If you attempt to mail a CDA document to a user whose mail
system does not support CDA, the message is not sent. You are
notified that the transmission cannot be completed. You can
create a copy of the message in another format and send that file.

To create a copy of a message in another format:

1. Choose Extract... from the Create–Send window’s File menu.

2. Enter appropriate information in all text entry boxes, as
described in Extracting a Mail Message to a File.

3. In the Output Format entry box, press MB1, point to an
output format that would be supported by the receiving
system, such as Text, and release MB1.

4. Click on the OK button to extract the message to a file.

To send the file in the new format:

1. Choose Include File... from the Create–Send window’s File
menu.

2. Choose the file to be sent, as described in Including a File in a
Message.

3. Click on the OK button to include the file.

4. Click on the Send button to send the message.

Displaying PostScript Files
Mail can display POSTSCRIPT files, provided the files you send or
receive contain only POSTSCRIPT language.

A POSTSCRIPT file always begins with a percent sign and an
exclamation point (%!). If any other text precedes the %!, Mail
cannot display the file. For example, when you forward mail,
additional text (in the form of extra mail headers) is often inserted
at the beginning of the file. Because this additional text precedes
the %!, Mail cannot display the POSTSCRIPT file correctly.

To make sure a POSTSCRIPT file does not contain any text
preceding the %!, use an editor to remove all headers before you
forward a mail message in POSTSCRIPT format:

1. Display the main window’s Create–Send menu.

2. Choose Without Header from the Forward submenu.
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3. Edit the file.

Similarly, if you receive a POSTSCRIPT file that does not display
properly, use an editor to remove all headers (or any other text
that precedes the %!), and forward the file to yourself. If a
POSTSCRIPT file does not contain the %! at the beginning of the
file, you can use the same procedure to add it. The POSTSCRIPT
file should then be displayed properly.

Customizing Your Mail Environment

User...

Window...

Icon...

Send...

Read...

Receive...

Print...

Save Settings

Restore Settings

Restore System Settings

Options You can customize many Mail features to suit your working
environment. You can alter your Mail user profile, your
DECwindows environment, the way your Mail icon is displayed,
and the options that control the way your messages are sent,
stored, displayed, and printed.

The Options menu in the main window lists the types of options
that you can change. Each category of options has a corresponding
dialog box in which you choose the changes you want to make. In
each of the dialog boxes, an option is enabled when its button is
shaded. To enable or disable an option, click on the corresponding
button or its label.

The following sections list and describe the Mail options you can
change.

Note

If you have used the OpenVMS Mail utility on your
system, some of your OpenVMS Mail defaults are
displayed. See Making Mail Perform Like the OpenVMS
Mail Utility for more information.

Modifying Your User Options
To change the default settings for your Mail User options, choose
User... from the main window’s Options menu. Mail displays a
dialog box.
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Forwarding Address:

Mail Directory:

Name of folder for deleted mail:

Empty wastebasket upon closing drawer

Confirm folder creation on Move or Copy

WASTEBASKET

$USERS:[JONES]

Mail: User

Uppercase folder names on creation

Case sensitive searches

CancelOK Apply

The following table describes the options in the User dialog box.

Option Description

Forwarding Address The node name and user name to which
your messages are sent. This option is
frequently used when you want to read your
mail in a different account.

Mail Directory The directory in which you want to store
your mail messages. Mail stores your
messages in the same directory used by
the OpenVMS Mail utility. If you have
not specified a directory to be used by
the OpenVMS Mail utility, your default
directory is used. Depending on the number
of mail messages you receive and keep, this
directory can become cluttered with mail
messages. This option allows you to choose
a different directory in which to store your
mail messages.
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Option Description

Name of folder for deleted
mail

The name of the folder to which deleted
messages are moved in new drawers you
create. By default, WASTEBASKET is
specified. Existing drawers are unaffected
by changing this setting.

Empty wastebasket upon
closing drawer

When this option is enabled, the
WASTEBASKET is emptied whenever you
close a drawer. This option is set by default.

Confirm folder creation on
Move or Copy

Automatically confirms the creation of new
folders. When you move or copy a message
to a folder that does not exist, Mail creates
the folder. The Confirm New Folder dialog
box prompts you to confirm the creation
of a new folder. This option, which is set
by default, allows you to suppress the
confirmation message.

Uppercase folder names
on creation

When you move or copy a message to a
folder that does not already exist, Mail
creates the new folder. This option allows
you to set whether the new folder name is
automatically displayed in uppercase letters.

Case sensitive searches Allows you to set the default for whether
all searches are to be case sensitive. For
example, if case-sensitive searches are
enabled, Important and IMPORTANT are
not considered the same.

Click on the OK or Apply button to save the profile settings for
the current session only. To save the settings permanently, choose
Save Settings from the main window’s Options menu. Click on the
Cancel button to reinstate the original profile settings.

Modifying Your Window Options
Modifying your window options allows you to choose the main
window style, the color of each type of window you work with (the
main window, Read window, Create–Send window, dialog boxes,
and message boxes), and whether Mail starts as an icon or as a
window.

To change the default settings for your DECwindows environment,
choose Windows... from the main window’s Options menu. Mail
displays a dialog box. The following illustration shows the Window
options dialog box as it appears on a color system; there are slight
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differences in the Window options dialog box on a black-and-white
system.
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Mail: Window

Main Window Style

Paned

Outline

Tree

Columns

Window

Icon

Main Window Color

Read Window Color

Create−Send Window Color

Dialog Box Color

Message Box Color

Background

Foreground

Startup State

CancelOK Apply

Set Colors...

The following table describes the options in the Window dialog
box. Some options apply to color systems, others apply to black-
and-white systems. The options that do not apply to your system
do not appear in your Window dialog box.

Option Description

Main Window Style The window style used to display the index
of messages in the main window: Paned,
Outline, Tree, or Columns. The default index
style is Outline. See Using Alternative Main
Window Styles for information about different
window style options.
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Option Description

Startup State This option allows you to choose whether
DECwindows Mail starts as a window or as
an icon. The default startup state is Window.

Main Window Color Allows you to change the colors for the main
window.

Read Window Color Allows you to change the colors for the Read
window.

Create–Send Window
Color

Allows you to change the colors for the
Create–Send window.

Dialog Box Color Allows you to change the colors for dialog
boxes.

Message Box Color Allows you to change the colors for message
boxes.

Background On color systems only. Allows you to set the
color for the background.

Foreground On color systems only. Allows you to set the
color for the foreground.

Set Colors... On color systems only. Allows you to choose
the foreground and background colors for the
selected windows.

Black on White On black-and-white systems only. Causes the
selected windows to be displayed with a black
foreground on a white background.

White on Black On black-and-white systems only. Causes the
selected windows to be displayed with a white
foreground on a black background.

You can change among the main window styles Outline, Tree, and
Columns simply by clicking on OK or Apply. Changing from one of
those window styles to the Paned style (or from the Paned style to
another style window) does not take effect until you choose Save
Settings from the Options menu and then exit and reenter Mail.

The colors you choose for Main Window Color, Read Window
Color, Create–Send Window Color, Dialog Box Color, and Message
Box Color affect future windows you create, not those already in
existence. The color changes are applied to the types of windows
that are enabled when you select the colors. Initially, all windows
are enabled.
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Modifying Your Icon Options
You can modify your icon options to customize the text displayed
in the DECwindows Mail icon in the icon box. You can also control
whether the number of new messages is displayed in the icon.

To change the default settings for your Mail icon, choose Icon...
from the main window’s Options menu. Mail displays a dialog
box.

Mail: Icon
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Mail

OK CancelApply

Number of new messages

The Number of New Messages option controls whether Mail
displays in the Mail icon the number of new (unread) messages.
By default, this option is enabled. If you do not want Mail to
display the number of new messages in the Mail icon, disable this
option.

The two text entry boxes in the upper left and upper right corners
of the Icon dialog box allow you to customize the text that appears
in the Mail icon. The text in these boxes is displayed before and
after the number of unread messages in the Mail icon. By default,
the text that appears in the left text entry box is Mail, and the
right text entry box is blank.

To add or change text in either text entry box, click MB1 on the
appropriate box and enter the text you want to be displayed.

Click on the OK or Apply button to save the profile settings for
the current session only. To save the settings permanently, choose
Save Settings from the main window’s Options menu. Click on the
Cancel button to reinstate the original profile settings.
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Modifying Your Send Options
To change the default settings for mail messages that you send,
choose Send... from the main window’s Options menu. Mail
displays a dialog box.
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Mail Transport:

Copy Self on:

Mail: Send

Send Reply Forward

Default Editor: DECwindows Text Editor Change Editor List...

Confirm closing from Create−Send window

Close Create−Send window after successful Send

Wrap long lines

Display Send In Progress box

Courtesy Copy Option

CancelOK Apply

The following table describes the options in the Send dialog box.

Option Description

Personal Name (Optional) Text that is inserted in the
From entry box of messages you send.
Your personal name can be your full
name or any other information and must
start with a letter. It cannot contain
double spaces.
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Option Description

Mail Transport The transport mechanism you want
to use, if any. A transport mechanism
is a product that affects when and
how your messages are sent. Mail
does not use a transport mechanism by
default. Messages are sent immediately.
Products such as Message Router or VAX
P.S.I. are optional.

Copy Self on: Send Includes your name as an addressee
in the CC entry box in Create–Send
windows when sending a new message.
You can delete your name from the
Create–Send window if you want.

Copy Self on: Reply Includes your name as an addressee in
the Create–Send window when you reply
to a message. You can delete your name
from the Create–Send window if you
want.

Copy Self on: Forward Includes your name as an addressee
in the Create–Send window when you
forward a message. You can delete your
name from the Create–Send window if
you want.

Default Editor Mail uses the DECwindows editing
commands, described in Using
DECwindows Motif for OpenVMS, as the
default editor for creating messages. If
more than one editor is available on your
system, you can choose a different editor
to create a message. Pressing MB1 on
the editor name in the box displays
a list of other editors from which you
can choose. The editors supplied with
DECwindows Mail are DECwindows
EVE and DECterm EVE.

Change Editor List... Allows you to customize the list of
available editors to use for creating
messages. More information on changing
the list of editors follows this table.
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Option Description

Confirm closing from Create–
Send window

If you change the header or text of a
message in a Create–Send window and
then close the window without sending
the message, a caution dialog box is
displayed. The message ‘‘Changes have
been made to the Create–Send window.
Do you really want to close it?’’ appears.

This option allows you to suppress the
confirmation message.

Close Create–Send window
after successful Send

Allows you to set the Create–Send
window to close automatically after
successfully sending a message.

Wrap long lines Allows you to set the default for whether
to wrap long lines in a message. Disable
this option when sending POSTSCRIPT or
other files with long lines that you do not
want wrapped.

Display Send In Progress box Allows you to set the default for whether
Mail displays the Send In Progress
box in the Create–Send window after
successfully sending a message. If an
error occurs while sending the message,
the Send in Progress box is displayed
even if this option is disabled.

Courtesy Copy Option Prompts you with a courtesy copy
prompt when using OpenVMS Mail.
This option does not affect DECwindows
Mail.

Changing the Editor List
To add a new editor to the list of available editors that you can
use to create and edit messages:

1. Click on Change Editor List... in the Send dialog box.

Mail displays a dialog box showing the current editors in a list
box.
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Mail: Change Editor List
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OK Apply Cancel

2. In the Editor Name entry box, type the name of the new editor
as you want it displayed on the menu.

3. In the Editor Command entry box, type the DCL command
you use to invoke the editor.

For DECwindows and DECterm applications, the command
must contain the string ‘‘%S’’ twice, first where the input file
specification should appear on the command line, and again
where the output file specification should appear; for example,
EDIT/TPU %S /OUT=%S. The input file specification should
precede the output file specification.

4. For the Method option, choose the method of invocation—
DECwindows, DECterm, or Direct Invocation—by clicking on
the appropriate radio button.

If the editor is a DECwindows application, such as
DECwindows EVE, choose DECwindows as the invocation
method.

If the editor is a character-cell application, such as EDT,
choose DECterm as the invocation method. Mail opens a
DECterm window and starts the editor in that window.
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If the editor is a DECwindows application that sup-
ports Application Control Architecture (ACA), such as
DECwrite or DECpaint, choose Direct Invocation as the
method. If you choose Direct Invocation, the command line
should contain the file name of the editor image, such as
SYS$SYSTEM:DECWRITE, rather than a DCL command line.

5. Click on Add to add the new editor to the list of default
editors.

To remove an editor from the list, select it and click on
Remove.

6. Click on OK or Apply to save the changes, or click on Cancel
to cancel any changes made and to dismiss the dialog box.

Modifying Your Read Options
Read options specify the action that Mail automatically takes on
the Read window after you delete or move the current message.

To change the default settings, choose Read... from the main
window’s Options menu. Mail displays a dialog box.

Mail: Read
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Action to perform upon deleting or moving a message

Leave read window blank

Read next message

Read previous message

Close read window

Apply CancelOK

Leave Read Window Blank causes the Read window to be left
blank. This is the default.

Read Next Message causes the next message in the folder to be
displayed automatically in the Read window.

Read Previous Message causes the previous message in the folder
to be displayed automatically in the Read window.
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Close Read Window causes the Read window to be closed.

Modifying Your Receive Options
To change the default settings for mail messages that you receive,
choose Receive... from the main window’s Options menu. Mail
displays a dialog box.

Mail: Receive
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INBOXName of folder which receives new mail:

Receive mail when the receive folder is opened

Automatically refile opened messages to MAIL folder

OK CancelApply

The following table describes the options in the Receive dialog box.

Option Description

Name of folder which receives
new mail

The name of the folder to which your
new messages should be delivered. (If
the folder does not exist, it is created.)
By default, INBOX is specified.

Receive mail when the
receive folder is opened

This option, which is set by default,
causes new mail to be delivered
whenever the receive folder (INBOX
by default) is opened. If you disable this
option, mail is delivered only when you
click on the Receive Mail or Read New
Mail button.

Automatically refile opened
messages to MAIL folder

This option, which is usually disabled,
causes a message to be moved to the
MAIL folder once you have read it.
If the MAIL folder does not exist, it
is created. The refile operation is not
completed until you close the receive
folder and reopen the MAIL folder.

Changes made to the Name of Folder Which Receives New Mail
option do not take effect until you choose Save Settings from the
Options Menu and then exit and reenter Mail.
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Modifying Your Default Print Settings
You can modify your default print settings to alter the way your
messages are printed.

To modify your default print settings, choose Print... from the
main window’s Options menu. Mail displays a dialog box.

Mail: Print Options

OK

Cancel

Options...

Help

Print Format Printer

Line Printer
Terminal
ANSI2
ANSI

Text CLUSTER_PRINT

LN03$PRINT

Print After

Number of Copies

Page Range:  From

Orientation: Default Portrait Landscape

To
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ARNO$LIA0
ARNO$TXA0
KODIAK
LN03$PRINT

now

Delete File When Printed

Refer to Using DECwindows Motif for OpenVMS for a description
of the options in this dialog box.

Changing your print defaults affects the way messages are printed
during the current Mail session only. When you exit Mail, any
print defaults you have changed revert to their original settings.
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Saving and Restoring Settings
If you have changed the size or position of the windows or any
other user options except print settings, you can save these
changes permanently. After you have made the desired changes,
choose Save Settings from the main window’s Options menu. If
you do not save the changes now, Mail asks you whether to save
the changes when you exit Mail. Print settings are not saved.

To restore changed settings to the last saved settings, choose
Restore Settings from the main window’s Options menu.

To restore your settings to the system defaults, choose Restore
System Settings from the main window’s Options menu.

Making Mail Perform Like the OpenVMS Mail Utility
If you use both the OpenVMS Mail utility and DECwindows Mail
to access the same mail messages, Mail automatically sets certain
options in your mail profile to make DECwindows Mail perform
like OpenVMS Mail.

DECwindows Mail automatically sets the following options in your
mail profile:

• Name of folder to receive new mail

Mail specifies NEWMAIL for this option.

• Automatically refile opened messages

Mail enables this option.

Set the remaining options to match your OpenVMS Mail settings.
See Customizing Your Mail Environment for more information on
modifying your DECwindows Mail options.

Once you have set these options, you will find that using
DECwindows Mail is very similar to using OpenVMS Mail.
Mail provides most OpenVMS Mail functions with the exception of
SPAWN, ATTACH, EDIT, and DEFINE/KEY. These functions
are unnecessary in the DECwindows Motif for OpenVMS
environment.
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Using Alternative Main Window Styles
Mail’s default main window displays your drawers, folders, and
messages in Outline style. When you open an object, its contents
are revealed directly beneath it, similar to the format of a table of
contents.

You can choose an alternative style for displaying the objects
in your main window. The other styles are Columns, Tree, and
Paned.

The Columns style main window is similar to the Outline style
except that the window is divided into two panes. The right pane
can be scrolled vertically. Each pane can be scrolled horizontally
independently of the other. Horizontal scrolling allows you to read
a long subject line of a message while still being able to view the
message number, date, and so on.

The Tree style main window displays your file cabinet hierarchy
as a graphical tree.

A Paned style main window uses two horizontal panes to display
your drawers, folders, and messages. The top pane lists your
folders or drawers. The bottom pane lists the messages in the
open folder.

To change to a different main window style, choose Window... from
the Options menu. Choose one of the window styles listed in the
Window dialog box.

Changing among the Outline, Tree, and Columns style windows
takes effect immediately. Changing to the Paned style main
window from a different style window—or changing from the
Paned main window to a different style— takes effect when you
choose Save Settings from the Options menu, and then exit and
reenter Mail.

In a Paned style main window, the names of your folders are
always displayed, regardless of the number of messages in the
open folder. (In Outline style, opening a folder frequently fills the
window with the contents of that folder, pushing all other drawer
and folder names out of the display.) Having folder names readily
available is useful for certain Mail functions, such as moving and
copying messages.
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RE: review schedule

poetry reading

dog class canceled

1

2

3

4

5

DeleteMovePrintReceive Mail

The Paned style main window differs from the other window
styles in the following ways:

• The main window is divided into two panes. The top pane
contains the Drawer/Folder index and lists the folders in the
open drawer. To display a list of drawers, click on the Display
Drawers button near the bottom of the Drawer/Folder index.
Double clicking MB1 on a drawer name opens the drawer and
displays its folders.

The bottom pane of the main window contains the Message
index, which lists messages in the currently open folder.

• You can open only one folder at a time when using Paned
style. To view messages in multiple folders simultaneously,
you must open multiple main windows.
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• In a Paned style window, you cannot select a range of drawers
or folders by clicking, dragging, and releasing MB1 over the
range of objects. However, you can select a range of messages.
To select multiple messages, press and hold the Shift key
while clicking MB1 on each desired message.

Changing Directories for Drafts and Distribution Lists
When you save a draft of a message, Mail stores the draft in your
default directory. Perform the following steps to specify a different
directory for storage of draft files.

Note

The following procedures assume you are familiar with
your LOGIN.COM file. If you are unfamiliar with this
file, ask your system manager for more information before
following these procedures.

1. From the Session Manager window, create a DECterm window.

2. Edit your LOGIN.COM file to include the following command:

$ DEFINE DECW$MAIL_DRAFTS directory-spec

where directory-spec is the name of the directory in which
drafts are to be stored. For example, [SMITH.DRAFTS] is a
valid directory name.

You can also change the default directory for distribution lists.
When you display a list of your distribution lists, Mail lists all
files in your default directory with a DIS file extension. To specify
a different directory to be searched for DIS files:

1. From the Session Manager window, create a DECterm window.

2. Edit your LOGIN.COM file to include the following command:

$ DEFINE DECW$MAIL_DISTRIBUTIONLISTS directory-spec

where directory-spec is the name of the directory
in which distribution lists are stored. For example,
[JONES.DISTLISTS] is a valid directory name.
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Using Accelerators
The following table shows how you can use certain key
combinations, called accelerators, to perform common Mail
tasks quickly.

Press To Produce

Ctrl+M Move...

Ctrl+P Print

Ctrl+O Open Folder

Ctrl+N Open folder in new window

Alt+Del† Undo Move/Delete

Ctrl+D Delete

Ctrl+Insert Copy to Clipboard

Find Find

Shift+Find Find Next Selected

Ctrl+Shift+Find Find Previous Selected

Ctrl+Find Replace

Find Pick from selected folder...

Ctrl+B Create New Message

Ctrl+A Create Reply

Ctrl+F Forward With Header

Ctrl+R Read new mail in default window

Ctrl+U Update Folder

KP3 Read Next Message

KP1 Read Previous Message

Remove Cut

Shift+Insert Here Paste

Ctrl+Z Send

Help Help

Ctrl+Q Close

Ctrl+E Exit

†Alt is the Compose Character key.
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Using Hyperapplication Features

Visit

Show Links...

Step Forward

Go To

Go Back

Start Link

Turn Highlight Off

Show History...

Highlight...

Shift+Find

Alt+Find

Alt+Next

Alt+up

Alt+Selec t

Complete Link Alt+down

Complete Link...

Link Mail is a hyperapplication. Through the Link menu, you can make
and follow links between pieces of information (linkable objects).
The information at the other end of any link can be another
Mail object or an object accessed by any other hyperapplication.
For detailed information about hyperapplications and the Link
menu, see the chapter on hyperapplication features in Using
DECwindows Motif for OpenVMS.

Mail’s linkable objects are drawers, folders, and messages. For
example, you can link messages to messages or a message to a
Calendar timeslot.

If highlighting is enabled, Mail highlights linked objects by using
the light bulb icon. If highlighting is not enabled and you want
to see which objects have links, choose Turn Highlight On from
the Link menu to enable highlighting. (To prepare for the reverse
action, the menu item changes to read Turn Highlight Off.)

Exiting Mail
To exit the Mail application, choose Exit from the main window’s
File menu. The main window and any open Read or Create–Send
windows are closed. If you have made changes in a Create–Send
window and the window is still open, Mail asks whether you
really want to exit. Open folders and drawers are closed. The
WASTEBASKET folder is emptied unless you have disabled that
option in your user profile.

If multiple main windows are open, the File menu contains the
Close menu item rather than Exit. Choosing Close closes only the
main window from which Close is chosen. When only one main
window remains, its File menu contains the Exit menu item.

If you have made any changes to your user profile, Mail asks
whether you want to save them. Click MB1 on Yes to save the
changes or on No to cancel any changes you have made.
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11
Using Paint

Paint is a graphics application that lets you create a simple
picture, such as a sketch or an illustration, using an assortment of
art tools. If you have a color monitor, you can choose colors from a
color palette.

Paint can save your pictures, print them on different kinds of
printers, or copy them to other applications. You can also display
the pictures on your screen with the CDA Viewer application (see
Chapter 5).

This chapter describes how to

• Start Paint

• Choose tools and menu items

• Draw lines and shapes

• Introduce patterns

• Choose colors (for color monitors only)

• Use the paintbrush

• Edit pictures

• Insert text

• Size the canvas

• Exit Paint
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Starting Paint
To start Paint, choose Paint from the Session Manager’s
Applications menu.

The Paint window appears, which contains a tool palette and a
work area where you draw your picture.
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The Paint window frames a portion of the canvas. At the bottom
of the tool palette, you see this portion of the canvas in the bolded
box that is enclosed in a larger box. To display different areas of
the canvas, press MB1 in the bolded box and drag until the box is
in the position you want. Alternatively, you can use the horizontal
and vertical scroll bars to move about the canvas.

Learning the Basics
Paint is a bitmap graphics application, which means that it treats
pictures as a collection of dots called pixels. Different drawing
tools, such as the Pencil, the Paintbrush, and the Text tool, edit
the color of the pixels to create a pattern. Because the canvas
has so many pixels in every square inch, you do not actually see
patterns of dots. Instead you see a collection of lines, shapes, and
text.

You can learn the basic steps in Paint by modifying a sample
picture called the Clock Tower.

To display the Clock Tower:

1. Choose Open... from the File menu.

The Open dialog box appears with the names of the graphics
files in your current directory.
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Paint: Open

File Filter

$USERS:[JONES]*.IMG

Selection

OK Filter Cancel Help

ZK−3312A−GE

Files

ICONS.IMG;1

Directories

CONTROLS.IMG;1

S:[JONES]

S:[JONES]ART.DIR;1

^

2. In the Selection entry box, enter the picture file name
DECW$EXAMPLES:CLOCK.IMG. IMG is the standard
format of a Paint file.

3. Click on OK. Paint displays the Clock Tower picture. You can
now practice choosing tools and using some of the Paint menu
items.
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Choosing Tools

A

The tool palette offers a variety of art tools and basic shapes. You
can work with the Pencil, the Paintbrush, the Spray Can, or the
Paint Bucket. The shapes on the tool palette let you compose
pictures quickly and easily.

When you first start Paint, the Paintbrush is highlighted,
indicating that it is the current default. Only one tool on the
tool palette is active at a time, and that tool remains active until
you make another selection.

The tools are as follows, starting with the Box tool in the upper
left corner of the tool palette:

Use This Tool To

Box Select a rectangular area for editing.

Scissors Select a shape for editing.

Spray Can Apply paint in a mist. (The slower you drag the
tool, the denser the coverage.)

Pencil Draw a thin line. To draw at 90-degree angles,
position the pointer, then shift click.

Eraser Delete the image in the path of the pointer. To
erase at 90-degree angles, position the pointer,
then shift click.

Paintbrush Paint a free stroke. To paint at 90-degree angles,
position the pointer, then shift click.

Text Include text that you type at the keyboard.

Paint Bucket Fill a closed shape with the current fill pattern.

Line Draw a straight line. To draw at 45- or 90-degree
angles, position the pointer, then shift click.

Arc Draw an arc. To draw a quarter of a circle, position
the pointer, then shift click.

Rectangle Draw a rectangle. To draw a square, position the
pointer, then shift click.

Square Draw a square.

Ellipse Draw an oval shape. To draw a circle, position the
pointer, then shift click.

Circle Draw a circle.
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Use This Tool To

Freehand Stroke Draw a freehand line in the selected line width
and pattern.

Polyline Draw a multisided figure. To specify a corner, click
MB1. To complete a shape, click at the starting
point. To terminate the polyline, double click MB1
anywhere other than the starting point. To draw
at 45- or 90-degree angles, position the pointer,
then shift click.

Dropper Pick up a current pixel color (for color monitors
only).

To change the time on the Clock Tower, choose the eraser and
delete the current time. To use the Eraser:

1. Click on the eraser in the tool palette.

2. Point to the center of the clock face. Press and hold MB1. The
Eraser is now active in the window.

3. Gently drag the eraser along each hand of the clock,
eliminating the current time.

Now, using the Line tool, draw in the current time:

1. Click on the Line tool in the tool palette.

2. Point to the center of the clock face and press MB1.

The Line tool is now active, and one end of the line is anchored
at the center of the clock. To stretch and swing the line from
the center point, move the mouse.

3. Drag the pointer from the center of the clock to the current
hour position. Once the line points to the correct time, release
MB1.

4. For the minute hand, add a second line in the same manner.

If you make a mistake, choose Undo Line from the Edit menu.

Inverting an Image
To create a reverse image of a picture, choose the Invert menu
item from the Edit menu.

To reverse the tones of the Clock Tower, switching the foreground
color and the background color:
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1. Click on the Box tool in the tool palette.

2. Select the Clock Tower by positioning the pointer outside one
corner of the Clock Tower area and dragging the pointer over
the image.

3. Choose Invert from the Edit menu. A reverse image of the
original Clock Tower appears. For color images, the color of
the reverse image depends on the arrangement of colors in the
palette.

Saving a Picture
To save your version of the Clock Tower:

1. Choose Save As... from the File menu. The Save As dialog box
appears.
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Paint: Save As

File Filter

$USERS:[JONES.ART]*.IMG

Selection

OK Filter Cancel Help

ZK−3314A−GE

Files

ICONS.IMG;1

Directories

CONTROLS.IMG;1

S:[JONES]

S:[JONES]ART.DIR;1

DDIF X11

Color Gray B/W

2. In the Selection entry box, type a file name using the form
SYS$LOGIN:filename.IMG so that Paint saves the picture in
your login directory.

3. Click on OK.
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Printing a Picture
To print the Clock Tower, choose either Print or Print... from the
File menu.

The first time you choose one of the Print menu items, Paint
displays the Print dialog box. You can change Paint’s default print
formats. To see the printer options, click on Options... and change
them if you want. Thereafter, the Print menu item sends the
picture to the default printer, whereas Print... always displays the
Print dialog box.

Erasing
You can erase in several ways:

• To erase selected portions of your drawing, use the Eraser
tool.

• To erase an entire area, select the area using the Box tool or
the Scissors tool. Then choose Cut from the Edit menu.

• To erase the entire visible portion of the canvas, choose Clear
Window from the Edit menu.

• To erase the last action you made, choose Undo from the Edit
menu. In the Edit menu, Undo is followed by the name of
the tool you chose. For example, the Undo Line menu item
appears when you choose the Line tool.

Drawing Lines and Shapes
The bottom half of the tool palette contains a collection of line and
shape tools that you use in a similar way.

Whenever you draw a straight line or a shape, the point where
you press MB1 becomes the reference point. You can stretch and
swing the line or shape from this reference point by dragging the
pointer. When the shape is correct, anchor it in place by releasing
MB1.

Use the Polyline tool as follows:

• To end one line and start another, click MB1.

• To terminate the polyline, double click MB1.

• If you are back at the starting point of a figure, click MB1
once to close the figure.
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To use the Freehand Stroke tool, press and drag MB1, then
release MB1 when you finish drawing that particular line.

To draw a rectangle:

1. Click on the Rectangle tool.

2. Point to where you want one corner of the rectangle to be.
Press MB1 and drag the pointer diagonally across the drawing
surface until the rectangle has the width and height you want.
(Notice how you can stretch and shrink the rectangle; you can
even flip it over.)

3. To anchor the shape, release MB1.

To line up a series of shapes or draw them equidistant from each
other, choose Grid On from the Options menu. A horizontal and
vertical pattern of dots is superimposed on the drawing window.
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The pattern of dots serves as a guide yet does not become part of
your picture. One advantage to using a grid is that a grid makes
geometric figures easier to draw because lines ‘‘snap into place’’ on
the dots.
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To change the size of the grid:

1. Choose Grid Size... from the Options menu. The Grid Size
dialog box is displayed.

2. Press MB1 on the slider bar and drag to the number you
want.

3. Click on OK.

Changing the Line Width
Lines drawn with the shape tools can be thick or thin. To change
the current line width:

1. Choose Line Width... from the Options menu.

The Line Width dialog box appears.

Paint: Line Width

OK

ZK−3316A−GE

2. Click on the line thickness you want.

3. Click on OK.

Most of the time, geometric shapes or figures are opaque; that
is, you cannot see what lies behind them. Opaque figures are
the default, as indicated by the shaded radio button next to the
Opaque menu item on the Options menu. Choosing Transparent
from the Options menu causes background images to show
through foreground images. The Transparent and Opaque settings
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affect not only figures but images you move, as well as the output
of the Spray Can, Paintbrush, and Text tools.

Using Patterns
Lines and shapes need not be solid colors. They can be striped,
speckled, woven, dotted, and so on.

ZK−3317A−GE
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The line and shape tools, the Spray Can, and the Paintbrush can
paint patterned lines.

To use patterned outlines or centers:

1. Choose Patterns... from the Options menu.

Paint displays the Patterns dialog box, which contains
a selection of designs that are a mixture of foreground
and background colors. The default Outline Pattern is a
solid foreground color. The Default Fill Pattern is a solid
background color.

Paint: Patterns

OK

Outline Pattern

Fill Pattern

None

ZK−3318A−GE

2. Click on either the Outline Pattern or Fill Pattern radio
button.

3. Click on any pattern.

Notice that the pattern you click on is displayed in the Outline
Pattern or Fill Pattern option box, indicating that it is the
active pattern.
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4. Click on OK.

5. Click on the tool you want to use. The Paintbrush, the Spray
Can, and the Line use the outline pattern only. The Paint
Bucket uses the fill pattern only. The geometric shape tools
use both the outline pattern and the fill pattern.

6. After positioning the pointer in the drawing window, drag the
pointer to create a patterned line or center.

To fill existing shapes using the Paint Bucket tool, click inside the
shape you want to fill. You must enclose the shape; any opening
in the border causes the paint to spill out onto the canvas. To
erase the fill, choose Undo Flood from the Edit menu.

Filling works only on the visible part of the canvas. For example,
if you attempt to flood the entire canvas, only the visible portion
is affected.

Creating Your Own Patterns
With Paint, you can create your own patterns and store them in
the pattern palette during a Paint session. You create your own
pattern from any of the patterns on the palette except the solid
foreground, solid background, and None patterns.

To create your own pattern:

1. Decide whether you want an outline or a fill pattern, then
click on the appropriate radio button in the Patterns dialog
box.

2. From the palette, choose a pattern that is closest to the design
you want and click on it. Paint also provides a few blank
patterns at the end of the palette so you can create your own
patterns from scratch.

3. Choose Edit Pattern... from the Options menu.

A dialog box appears, which contains two large option boxes.

11–16 Using Paint



Edit Pattern...

CancelOK

ZK−3319A−GE

In the left-hand box you see the pattern you chose from the
palette. In the right-hand box you see the same pattern
magnified.

While you are editing a pattern, the Edit Pattern dialog box
has input focus, and the pointer assumes the shape of a pencil.

4. In the Edit Pattern dialog box, edit the magnified version of
the pattern (in the right-hand box) to create the effect you
want.

To draw over pixels or click on individual pixels, use the Pencil
tool. When you click the Pencil on a pixel, that pixel inverts
its color. The new color of the pixel becomes the pencil color,
and until MB1 is released, all pixels you pass the Pencil over
take on the color of the Pencil.

For example, if you are working with a black-and-white
canvas and you start the Pencil in a white area, the Pencil
draws black until you release MB1, even if it passes through
a black area. Conversely, if you start the Pencil in a black
area, the Pencil draws white until you release MB1, even if it
passes through a white area.

To see how the magnified pattern looks under normal
conditions, refer to the pattern shown in the left-hand box.
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5. To complete the pattern and return to the drawing window,
click on OK.

The edited pattern is available on the Patterns palette for the rest
of the session, replacing the original pattern. You cannot recover
the original pattern for that session.

Choosing Colors
If you have a color monitor, you can create pictures in your choice
of colors.

To choose a color:

1. Choose Palette... from the Options menu. A basic spectrum of
colors appears in the Palette dialog box, with black set as the
default.

2. To choose one of the basic spectrum colors, click on the color.

3. To mix and choose other colors of your choice, choose Mix
Color... from the Options menu. The Mix Color dialog box
appears, with options for a wide range of colors.

Complete the Mix Color dialog box as described in Using
DECwindows Motif for OpenVMS.

4. To add a color from the Mix Color dialog box to your Paint
palette, click on Add. The color appears as the default in the
Palette dialog box and takes effect immediately.

5. To dismiss the Palette dialog box, click on OK.

6. To change paint colors quickly when you are working in
your Paint window, click on the Dropper tool. Then click on
the color you want from the colors you see currently in the
window. The Dropper picks up that color. To proceed with the
new color, click on any tool.

Using the Paintbrush
For an elegant stroke, one that creates a calligraphic effect, use
the Paintbrush tool. The Paintbrush applies paint along the path
of the pointer. Initially, the paintbrush has a solid stroke, but you
can choose a patterned stroke by changing the border pattern on
the Patterns palette, as described in Using Patterns.
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To shape the tip of the Paintbrush:

1. Click on the Paintbrush from the tool palette.

2. Choose Brushes... from the Options menu.

The Brushes dialog box appears, which contains an assortment
of brush-stroke styles.

Paint: Brushes

OK

ZK−3320A−GE

3. Click on the brush-stroke style you want.

4. Click on OK.

5. Move the pointer into the drawing window and try out the
new brush stroke.
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Editing Pictures
With Paint’s electronic canvas, you can rearrange images easily in
the window. You can delete images entirely, move them to another
part of the window, copy them, or quick copy them. Paint can
shrink or enlarge selected images. Paint can also crop a picture,
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retaining one section of the canvas and deleting the rest. For
further effect, Paint can reverse the foreground and background
colors in a selected area.

Selecting Images
Two selection tools, the Box and the Scissors, mark a portion of
the drawing window for a graphics operation. The Box marks
a rectangular area, while the Scissors marks an area with an
arbitrary shape. To select the visible portion of the canvas, choose
Select Window from the Edit menu.

To use the Box tool, position the pointer in one corner of the area
you want to select and drag the pointer over the image.

To use the Scissors tool, drag the pointer around the boundary of
the object until you reach the starting point.

To cancel a selection, click in another part of the window or choose
another tool.

Moving Images
You can move an image from one location in the Paint window to
another. To move an image:

1. Using the Scissors tool, select the image.

2. Press MB1 inside the selected area and drag the image to the
desired location.

3. Release MB1.

Using Paint 11–21



ZK−3322A−GE

HelpFile Edit Text Options

A

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

.

Paint: untitled

To cancel the selection, click in another part of the window or
select another tool.
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Copying Images
Once you select an image on the canvas, you can copy the image,
leaving the original image intact. You can then paste the image
onto the canvas. Paint can paste graphic images that have been
copied to the clipboard from other applications, but it cannot paste
text from other applications.

To copy an image in the same window:

1. Using the Box or Scissors tool, select the image.

2. Choose Quick Copy from the Edit menu.

Paint puts a copy of the image on the canvas, leaving it
selected.

3. Position the pointer in the selected image and drag it to the
location you want.
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To copy an image to the clipboard for use in another window:

1. Using the Box or Scissors tool, select the image.

2. Choose Copy for the Edit menu.

Paint copies the image to the clipboard.
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3. Choose Paste from the Edit menu.

Paint puts a copy of the image on the canvas, leaving it
selected. A copy of the image remains in the clipboard.

To cancel the selection, click in another part of the window or
select another tool.

To copy a selection to the clipboard without leaving a copy of it in
the original location, choose Cut from the Edit menu.

Sizing Images
You can modify the proportions of selected images.

To scale an image:

1. Using the Box or Scissors tool, select the image.

2. Choose Scale... from the Edit menu.

The Scale dialog box appears.

3. For both the x scale and the y scale, click on one of the percent
buttons to change the scale. If you want to specify your own
percentages, enter a number less than 100 to shrink the figure
or a number greater than 100 to enlarge the figure.

For example, clicking on 25% reduces the selected area to
one-fourth the original size, while clicking on 200% makes the
area twice as large as the original.
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Paint: Scale

200X Scale % Y Scale %

25%

50%

100%

200%

300%

400%

25%

50%

100%

200%

300%

400%

200

CancelApplyOK

4. To complete the operation, click on OK.

To reverse the process and return to your original picture,
choose Undo Scale from the Edit menu.

To scale the entire canvas, choose Scale Picture... from the
Edit menu.
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Cropping a Picture
One section of a picture might develop so well that you decide to
keep it but want to discard the rest. To extract a portion of the
picture, you use the Crop menu item.

To crop a picture:

1. Using the Box or Scissors tool, select the section of the picture
you want to keep.

2. Choose Crop from the Edit menu.

Paint repositions the cropped picture in the upper left corner
of the window and discards the rest of the picture. To restore
the original picture, choose Undo Crop from the Edit menu.

Viewing Portions of the Canvas
By choosing Full View from the Options menu, you can display
the entire canvas. In Full View mode, the only tool available is
the Box. To crop your picture in Full View mode, select the area
using the Box tool and then choose Crop from the Edit menu.

To return to only a portion of the canvas, choose Paint View from
the Edit menu.

Editing in Detail
Not only does Paint magnify patterns in the Edit Patterns dialog
box so you can see them better, it also magnifies portions of the
canvas with the Zoom On menu item. The Zoom magnifying frame
acts like a magnifying glass in the drawing window, enlarging an
image to eight times its original size.

To magnify a portion of a picture:

1. Choose Zoom On from the Options menu.

The Zoom window appears beside the Paint window, and
a magnifying frame appears in the Paint window. The
magnifying frame demonstrates the size of the image that
Paint magnifies in the Zoom window. To magnify a larger area
of the canvas, you can resize the Zoom window.
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Paint: Zoom

2. Press MB1 inside the magnifying frame and drag the frame
over the area you want to edit. Release MB1.

Notice that the Zoom window contains an enlarged version of
the area that shows in the magnifying frame.

3. Choose the Pencil from the tool palette.
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4. Bring the pointer into the Zoom window and use the Pencil
tool to add fine details to the image. Either click on individual
pixels or draw over them.

Notice that the image in the drawing window changes as you
edit in the Zoom window, so you can see how the modified
figure looks in normal proportions. Continue editing pixels
until you are satisfied with the overall effect.

5. To edit other areas of the drawing window, drag the
magnifying frame to the next location.

Edit the pixels in the Zoom window as before.

To close the Zoom window, choose Zoom Off from the Options
menu.

Including an Image File
You can copy an image from a file into your current Paint window,
as long as the image is not larger than the size of the screen.

To copy an image from a file into your window:

1. Choose Include... from the Edit menu. The Include dialog box
appears.

2. In the Files list box, double click on the file name of the image
file you want to copy to your window. By default, image files
have the IMG extension.

3. Click on OK. The image file is copied to your window.

Inserting Text
You can insert text anywhere in the Paint window. The text
can be different fonts, sizes, and styles. You can change the
appearance of text in the drawing window up until the moment
you click to complete the text entry. After that, Paint incorporates
the text into the graphic image.

To insert text:

1. Choose the Text tool from the tool palette.

2. Position the pointer in the Paint window where you want to
insert text and click MB1.

Paint inserts a left corner bracket to mark the left margin of
the text entry and displays the insertion cursor next to it.
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3. Type in text from the keyboard, formatting it with the Tab
and Return keys.

4. To modify the text font, pull down the Text menu and drag the
pointer to the submenu icon next to the Family menu item to
view the submenu. Release MB1 over your choice of font.

5. To change the text from regular to boldface, pull down the
Text menu and drag the pointer to the submenu icon next to
the Style menu item to view the submenu. Release MB1 over
the Bold menu item.

You can also choose an italic font from the Style submenu.

6. To adjust the size of the text, pull down the Text menu and
drag the pointer to the submenu icon that appears next to the
Size menu item to view the submenu. Release MB1 over your
choice of pica size.

Paint applies the choices you make to the text you entered.

7. To complete the entry with its current characteristics, either
move the pointer to another part of the window and click
MB1, or click on another tool.

The inserted text becomes part of the picture; you can no longer
erase text with the Delete key (<x ) or change its characteristics
with items from the Font menu. To erase the text, choose Undo
Text from the Edit menu.
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Sizing the Canvas
You can tailor the size of a Paint canvas.
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To alter the size of the canvas:

1. Choose Picture Size... from the Options menu. The Picture
Size dialog box appears.

Paint: Picture Size

ZK−3327A−GE

Crop Scale

Size Letter

Width

Height

Pixels

Inches

Centimeters

Resolution

Dots per inch 75

75 DPI

600

750

OK Apply Cancel

The Picture Size dialog box shows the current canvas size
with its dimensions converted to pixels, inches, or centimeters.

2. In the dialog box, click on either the Crop or Scale radio
button to specify how you are changing the Paint window.
You can then set the dimensions to be in pixels, inches, or
centimeters by clicking MB1 on the appropriate radio button.
If you choose Non-Standard from the Size option menu, you
can type in the height and width you want in the associated
text entry boxes.

To display the Size option menu, press MB1 inside the Size
option box. You can then choose Non-Standard, Letter (8 x 10
inches; 20 x 25 centimeters) or Screen (size of the screen in
pixels). Non-Standard enables you to supply your own value.
Letter is the default.
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Additionally, you can modify the number of dots per inch
(DPI). This option lets you manipulate high-resolution images.

To modify the DPI, press MB1 on the Resolution Options box.
The Resolution menu appears. Choose 75, 100, or 300 DPI, or
the Non-Standard menu item. Non-Standard lets you type in
the resolution you need. The change is evident when you print
the picture rather than in the Paint display.

3. Click on OK.

Using Accelerators
You can use certain key combinations, called accelerators, to
perform common Paint operations quickly. The following table
shows each key combination and its corresponding function.

Press To Produce

Alt+Delete Undo†

Ctrl+Z Exit

Shift+Remove Cut

Ctrl+Insert Here Copy

Ctrl+O Open

Shift+Insert Here Paste

Ctrl+P Print

Ctrl+S Save

Ctrl+Q Quick Copy

†Alt is the Compose Character key.

In addition to using accelerators, you can also use key
combinations to manipulate Paint tools. To produce the results
listed in the following table, press and hold the Shift key while
you drag MB1.

Tool Effect

Rectangle Causes the rectangle to become a square

Line Causes the line to be at an angle that is a multiple
of 45 degrees
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Tool Effect

Paintbrush Causes the image to be horizontal or vertical

Pencil Causes the image to be horizontal or vertical

Ellipse Causes the ellipse to become a circle

Polyline Causes angles to be multiples of 45 degrees

Eraser Causes the eraser to erase vertically and
horizontally only

Arc Causes the image to be a quarter circle (instead of a
quarter ellipse)

Exiting Paint
To exit Paint, choose Exit from the File menu. If you try to exit
without saving your picture, Paint asks whether you want to save
the picture before exiting. Click on Yes, No, or Cancel.
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12
Using Print Screen

Print Screen lets you take a snapshot of the entire screen or just a
portion of the screen. You can save the snapshot to a file or print
it, or both.

This chapter describes how to

• Start Print Screen

• Take screen snapshots

• Change the Print Screen settings

• Exit Print Screen

Starting Print Screen
To start Print Screen, choose Print Screen from Session Manager’s
Applications Menu.

Print Screen options and settings appear in the Print Screen
window.
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Print Screen:      Digital Equipment Corp.  1988, 1993.

Output Format

Positive Image

Time Delay (seconds)

Output File Name

0

Output Color Black and White

Fit−To−Paper

PostScript

Crop Excess

sys$login:decw$capture.tmp
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Capture P ortion of Screen

Send to File

Ribbon Saver

Print Orientation Portrait

c

The default Print Screen settings let you capture screen snapshots
in a file formatted for POSTSCRIPT printers. However, you can
change the settings to accommodate your particular needs. For a
description of the Print Screen settings, see Changing the Print
Screen Settings.

Taking Screen Snapshots

Printer
File

Both

Send to

To take a snapshot of your screen, you use the Send to options
menu. You can choose to save a screen snapshot to a file, print
the snapshot, or do both.

To take a screen snapshot:

1. Arrange the windows on the screen as you want them
captured.

2. From the Send to options menu, choose to save the snapshot
to a file, to print it, or both.

3. Specify a file name in the Output File Name entry box or
accept the default file name.
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4. From the Capture options menu, choose to capture the entire
screen or a portion of the screen.

5. Choose Print or Print... from the File menu.

If you chose Send to Printer or Send to Both in step 2, Print
sends the snapshot to the default printer, whereas Print...
displays a dialog box for you to choose a specific printer.

If you chose Send to File in step 2, Print saves the snapshot to
a file; the file is not immediately printed.

If you chose Capture Entire Screen in step 3, the snapshot
operation proceeds immediately, and Print Screen displays a
watch cursor until the snapshot is completed.

If you chose Capture Portion of Screen, continue with the next
step.

6. The pointer changes to a capture cursor ( + ). Move the capture
cursor to the upper left corner of the area you want to capture.

7. Press and hold MB1.

8. Drag the capture cursor until a box surrounds the area you
want to capture.

9. Release MB1.

The cursor changes to a watch cursor until the snapshot is
completed.

Using a Time Delay
When you capture the entire screen or a portion of the screen, you
might need some time to rearrange your screen display before the
snapshot activates. For example, you might want to minimize a
window or click on a buried window to give it input focus.

To take a snapshot of all or part of the screen display after a time
delay

1. Set the Capture and Send to options menus to the settings
you want. (See Taking Screen Snapshots.)

2. Specify how many seconds to delay by pointing to the Time
Delay slider, pressing MB1, and dragging the slider to the
number of seconds you want.

3. Choose Print or Print... from the File menu.
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If you choose Print..., the Queue Options dialog box appears.

a. Enter the options you want.

b. Click on the OK button.
The time delay begins.

4. During the time delay, arrange the objects on your screen as
you want them captured.

5. The time delay ends.

If you chose Entire Screen from the Capture options menu,
the whole screen is immediately saved to a file or printed, or
both.

If you chose Portion of Screen, the pointer changes to a
capture cursor ( + ), and you do the following:

a. Move the capture cursor to the upper left corner of the
area you want to capture.

b. Press and hold MB1.

c. Drag the capture cursor until a box surrounds the area
you want to capture.

d. Release MB1.

The portion of the screen you captured is saved to a file or
printed, or both.

Specifying Output File Names
By default, Print Screen names the output file that contains a
screen snapshot DECW$CAPTURE.TMP. This file is placed in
your SYS$LOGIN directory, which is your top-level directory.

To direct the output to another directory or file, click on the
Output File Name entry box and type another file name. Do not
use any logical names that are already defined in the system login
command file (SYLOGIN.COM) or in your login command file
(LOGIN.COM).
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Changing the Print Screen Settings
To change the settings in the Print Screen window:

1. Place the pointer on the setting you want to change.

2. Press MB1. An options menu appears.

3. Choose the setting you want.

4. Release MB2. The new setting appears.

To save your settings or to specify the system defaults, choose the
appropriate menu item from the Options menu.

You can change any of the following settings in the Print Screen
window.

Output Format
By default, DECwindows captures a screen snapshot in a file
formatted for POSTSCRIPT printers. You can change the output
format by choosing Sixel or DDIF from the Output Format options
menu.

You can view sixel files in a DECterm window or on a VT screen
and print them on certain printers. Choose Sixel Options from
Print Screen’s Options menu to display a dialog box where you
can select screen and printer options for viewing or printing sixel
files.

DDIF (Digital Data Interchange Format) files can be used with
applications such as Paint, CDA Viewer, and DECwrite.

Ribbon Saver
By default, screen snapshots are printed as a positive image (a
black image on a white background).

To reverse the black and white portions of the printed output,
choose Negative Image from the Ribbon Saver options menu.

Print Orientation
By default, the Portrait orientation is used for printing snapshots.

You can change the print orientation by choosing Landscape or
Best Fit. The Best Fit option automatically determines the print
orientation based on the shape of the snapshot.
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Output Color
The Output Color settings are Black and White, Color, and Gray
Scale. Only the settings applicable to your workstation appear.
By default, Print Screen captures screen snapshots in black and
white.

If your workstation or printer supports color or gray-scale output,
you can use the Color or Gray Scale options.

For example:

• If you are using a color workstation and a color printer and
you choose Color from the Output Color options menu, the
printed image matches (as closely as possible) the colors you
see on the screen.

• If you have a color workstation and you choose Gray Scale, the
printed output reflects the range of colors in shades of gray.

• If you have a color workstation and you choose Black and
White, the captured output is high-contrast black-and-white
image.

Fit-To-Paper
By default, Print Screen prints as much of the image as will fit on
the paper at full size and crops the excess.

If you do not want to use the Crop Excess option, you can choose
one of the following options:

• Scale to Fit

Scales the snapshot up or down so that the entire snapshot is
printed and fills as much of the paper as possible.

• Reduce Only

Reduces the size of a snapshot to fit the printer paper.

• Increase 2:1

Doubles the size of a printed snapshot or of a snapshot saved
to a file.

• Decrease 2:1

Halves the size of a printed snapshot or of a snapshot saved to
a file.
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Exiting Print Screen
To exit Print Screen, choose Exit from the File menu.
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13
Using Puzzle

1 5
6 3 8
2 7 4

Puzzle is a video version of a number puzzle with sliding squares.
To play with Puzzle, you can either use the mouse or type
corresponding numbers from the keypad.

This chapter describes how to

• Start Puzzle

• Play with Puzzle

• Start a new game

• Exit Puzzle

Starting Puzzle
To start Puzzle:

1. Choose Menu Bar... from the Session Manager’s Options
menu. A dialog box appears.

2. Click on Games.

3. Click on OK or Apply. The Games menu appears on the
Session Manager’s menu bar.

4. Choose Puzzle from the Session Manager’s Games menu.
Puzzle appears on the screen.
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Playing with Puzzle
The puzzle squares are scrambled. The trick is to arrange them in
ascending order in the fewest possible moves. Puzzle keeps track
of the number of moves you make.

Click on the square you want to move. Alternatively, you can type
the corresponding number on the keypad and press the Enter key.
Although you can move only those squares that are adjacent to
the blank square, you can slide an entire row at a time.

You can make Puzzle easier or more challenging by changing the
settings. To change the Puzzle settings, choose Settings... from
the Options menu. A dialog box appears.
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4

Puzzle: Settings

Squares per Side

CancelOK

Try increasing the number of squares per side. To do so, press
and hold MB1 on the number in the slider and drag to the right.
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To change the settings, click on OK. To return to Puzzle without
changing any settings, click on Cancel.

To save the changes you made, choose Save Settings from the
Options menu before you exit Puzzle. To restore the system
settings, choose Restore System Settings from the Options menu.

Starting a New Game
You can end an existing game at any time. To rescramble the
squares and start a new game, choose New Game from the File
menu.

Exiting Puzzle
To exit Puzzle, choose Exit from the File menu.
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A
Composing Characters

In a DECterm window, you can use compose sequences to
create special characters. A compose sequence is a series of
keystrokes that create characters that do not exist as standard
keys on your keyboard. You can create any character from
the character set that DECterm is currently using. (For more
information about choosing a character set, see Chapter 8.)

Depending on the keyboard type, you compose characters in either
of the following ways:

• Use three-stroke sequences on a VT320 keyboard, including
the North American/United Kingdom, Dutch, and Norwegian/
Danish keyboards.

• Use two-stroke sequences on other keyboards.

To compose a character:

1. Find the character you want to create in column 1 of the three
tables that follow.

2. To compose a three-stroke sequence, simultaneously press and
then release the Compose key and the space bar, and type the
two characters in column 2.

Note

You must simultaneously press the Compose key and the
space bar to begin a compose sequence.

3. To compose a two-stroke sequence, type the two characters in
column 3. The desired character is displayed.
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4. Press the Compose key and space bar, <x key, Tab key,
Return key, or Enter key to cancel a compose sequence.

Note

The North American, United Kingdom, and Dutch
keyboards do not have diacritical marks. If you use a
diacritical mark, DECterm uses an equivalent character.

The characters that you compose in Multinational Character Mode
are as follows:

Character
Three-Stroke
Sequence

Two-Stroke
Sequence

" double quotation
mark

" space bar " space bar

# number sign ++

’ apostrophe ’ space bar ’ space bar

@ commercial at A A

[ opening bracket ( (

\ backslash / / or / <

] closing bracket ) )

^ circumflex accent ^ space bar ^ space bar

‘ grave accent ‘ space bar ‘ space bar

{ opening brace ( -

| vertical line / ^

} closing brace ) -

~ tilde ~ space bar ~ space bar

¡ inverted ! !!

¢ cent sign C / or C |

£ pound sign L- or L=

¥ yen sign Y- or Y=

§ section sign SO or S! or S0

¤ currency sign XO or X0

© copyright sign CO or C0
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Character
Three-Stroke
Sequence

Two-Stroke
Sequence

ª feminine ordinal A_

« open angle brackets < <

° degree sign 0 ^

± plus-or-minus sign + - -

² superscript 2 2 ^

³ superscript 3 3 ^

µ micro sign / U

¶ paragraph sign P!

· middle dot . ^

¹ superscript 1 1 ^

º masculine ordinal O_

» closed angle
brackets

>>

¼ fraction one-
quarter

1 4

½ fraction one-half 1 2

¿ inverted ? ??

À A grave A‘ ‘A

Á A acute A’ ’A

Â A circumflex A^ ^A

Ã A tilde A~ ~A

Ä A umlaut A" or "A "A

Å A ring A* or A° °A

(degree sign)

Æ A E diphthong AE

Ç C cedilla C,

È E grave E‘ ‘E

É E acute E’ ’E

Ê E circumflex E^ ^E

Ë E umlaut E" or "E "E

Ì I grave I‘ ‘I
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Character
Three-Stroke
Sequence

Two-Stroke
Sequence

Í I acute I’ ’I

Î I circumflex I^ ^I

Ï I umlaut I" or "I "I

Ñ N tilde N ~ ~ N

Ò O grave O‘ ‘O

Ó O acute O’ ’O

Ô O circumflex O^ ^O

Õ O tilde O~ ~O

Ö O umlaut O" or "O "O

Œ O E diphthong O E

Ø O slash O /

Ù U grave U‘ ‘U

Ú U acute U’ ’U

Û U circumflex U^ ^U

Ü U umlaut U" or "U "U

Ÿ Y umlaut Y" or "Y "Y

ß German small
sharp s

ss

à a grave a‘ ‘a

á a acute a’ ’a

â a circumflex a^ ^a

ã a tilde a~ ~a

ä a umlaut a" or "a "a

å a ring a* or a° °a

(degree sign)

æ a e diphthong a e

ç c cedilla c , (comma)

è e grave e‘ ‘e

é e acute e’ ’e

ê e circumflex e^ ^e

ë e umlaut e" or "e "e
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Character
Three-Stroke
Sequence

Two-Stroke
Sequence

ì i grave i‘ ‘i

í i acute i’ ’i

î i circumflex i^ ^i

ï i umlaut i" or "i "i

ñ n tilde n~ ~n

ò o grave o‘ ‘o

ó o acute o’ ’o

ô o circumflex o^ ^o

õ o tilde o~ ~o

ö o umlaut o" or "o "o

œ o e diphthong o e

ø o slash o/

ù u grave u‘ ‘u

ú u acute u’ ’u

û u circumflex u^ ^u

ü u umlaut u" or "u "u

ÿ y umlaut y" or "y "y

ISO Latin 1 Characters1

no break space sp sp

| | broken vertical bar | | or ! ^

-, logical not - ,

SHY soft (syllable)
hyphen

- -

RO registered
trademark

R O

�� macron - ^

3/4 three quarters 3 4

-: division sign - :

xx multiplication sign x x

1In the ISO Latin 1 mode, the characters ÷, ×, and Ý are not available.
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Character
Three-Stroke
Sequence

Two-Stroke
Sequence

’ acute accent ’ ’

, cedilla , ,

" diereses " " " space bar

Y’ Y acute Y’ ’Y

y’ y acute y’ ’y

TH capital Icelandic
thorn

T H

th small Icelandic
thorn

t h

-D capital Icelandic
Eth

- D

-d small Icelandic Eth - d

The characters that you compose in National Replacement Mode
using the typewriter keys are as follows:

Character
Three-Stroke
Sequence

Two-Stroke
Sequence

British

£ pound sign L- or L=

‘ grave accent ‘ space bar

Danish

# number sign ++

’ apostrophe ’ space bar

@ commercial at AA

‘ grave accent ‘ space bar

Dutch

£ pound sign L- or L=

’ apostrophe ’ space bar

¼ one quarter 1 4

½ one half 1 2

3/4 three quarters 3 4
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Character
Three-Stroke
Sequence

Two-Stroke
Sequence

ij i j sign i j

fl florin f -

‘ grave accent ‘ space bar

’ acute accent ’ ’
�� diereses " ^

Finnish

# number sign ++

’ apostrophe ’ space bar

Flemish and French/Belgian

£ pound sign L- or L=

’ apostrophe ’ space bar

‘ grave accent ‘ space bar

French Canadian

’ apostrophe ’ space bar

à a grave ‘a ‘a

â a circumflex ^ a ^ a

è e grave ‘e ‘e

ê e circumflex ^ e ^ e

î i circumflex ^ i ^ i

ô o circumflex ^ o ^ o

ù u grave ‘u ‘u

û u circumflex ^ u ^ u

German/Austrian

’ apostrophe ’ space bar

‘ grave accent ‘ space bar

Italian
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Character
Three-Stroke
Sequence

Two-Stroke
Sequence

’ apostrophe ’ space bar

Norwegian

’ apostrophe ’ space bar

‘ grave accent ‘ space bar

Portuguese

’ apostrophe ’ space bar

‘ grave accent ‘ space bar

Ã A tilde ~ A

Õ O tilde ~ O

ã a tilde ~ a

õ o tilde ~ o

Spanish

£ pound sign L- or L=

’ apostrophe ’ space bar

§ section sign !S or OS or 0S

‘ grave accent ‘ space bar

~ tilde ~ space bar

Swedish

# number sign ++

’ apostrophe ’ space bar

É E acute ’ E

é e acute ’ e

Swiss/French and Swiss/German

’ apostrophe ’ space bar

ê e circumflex ^ e ^ e

î i circumflex ^ i ^ i
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Character
Three-Stroke
Sequence

Two-Stroke
Sequence

ô o circumflex ^ o ^ o

ù u grave ‘ u ‘ u

û u circumflex ^ u ^ u

The characters that you compose in National Replacement Mode
using data processing keys are as follows:

Character
Three-Stroke
Sequence

" double quotation
mark

" space bar

# number sign + +

’ apostrophe ’ space bar

@ commercial at aa or AA or aA

[ opening bracket ( (

\ backslash / <

] closing bracket ^ space bar

’ apostrophe ’ space bar

{ opening brace ( -

| vertical bar ^ /

} closing brace ) -

~ tilde ~ space bar

Composing Characters A–9





Index

A
Active linknet (hyperinformation), 9–5
Active path (hyperinformation), 9–5
Alarms, setting

in Calendar, 3–7
in Clock, 6–3

B
Bookreader

arrows
in navigation window, 1–5
in topic window, 1–6

Close button, 1–6
closing books, 1–7
closing sections, 1–7
closing topic windows, 1–7
copying text from, 1–8
creating book files for, 1–4
creating links between sections, 1–11
cross-references, 1–7
examples

displaying, 1–6
exiting, 1–11
extracting text to a file, 1–8
figure

displaying, 1–6
footnotes, 1–7
Go Back button, 1–6
hotspots

description of, 1–7
library

description of, 1–2

Bookreader (cont’d)
LinkWorks features, 1–11
menu items

Expand, 1–5
Fully Expand, 1–5
Open Book..., 1–5

opening books, 1–4
from your directory, 1–5

printing text from, 1–9
Screen arrows, 1–6
scroll bars, 1–6
search error messages, 1–11
searching for text in, 1–9
starting, 1–1
stopping searches, 1–10
subtopics

displaying, 1–5
table of contents, 1–5

displaying graphics, 1–6
tables

displaying, 1–6
Topic arrows, 1–6
topics

locating, 1–5
reading, 1–6

topic window, 1–6
windows

library, 1–1
navigating, 1–4
topic, 1–5
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C
Calculator

accumulator display
order of precedence, 2–1

arithmetic functions, 2–8
copying data between applications, 2–11
customized settings

saving, 2–13
entering data

with mouse or keyboard, 2–4
exiting, 2–13
memory display, 2–1
mistakes

correcting, 2–7
mode

changing to hexadecimal, 2–3
changing to octal, 2–4

percentages, 2–8
special functions

in decimal mode, 2–9
in hexadecimal and octal modes,

2–10
starting, 2–2
storing values, 2–8

Calendar
alarms

setting, 3–7, 3–10
calendars

closing, 3–16
creating, 3–15
deleting, 3–16
multiple, 3–15
opening, 3–15
renaming, 3–15

clock, 3–12
displays, 3–2
entries

deleting, 3–11
moving, 3–11
sending and receiving through Mail,

3–28
exiting, 3–29
hyperapplication features

Calendar
hyperapplication features (cont’d)

description of, 3–27
icons

selecting and removing, 3–5
marking special days, 3–13
options

customizing, 3–17 to 3–27
printing files, 3–28
starting, 3–2
timeslot

resizing, 3–7
timeslots

creating an entry, 3–3
deleting an entry, 3–11
moving an entry, 3–11
using the Entry Editor, 3–5

Cardfiler
card files

creating, 4–2
merging, 4–11
opening, 4–2
renaming, 4–11
saving, 4–11
scrolling, 4–2
searching, 4–2
viewing contents of, 4–5

cards
creating, 4–4
deleting text, 4–8
editing, 4–7
including images, 4–9
moving and copying text, 4–8
moving the text cursor, 4–7
opening, 4–5
renaming, 4–7
saving in a file, 4–2
selecting text, 4–8

customized settings
saving, 4–12

exiting, 4–12
hyperapplication features

description of, 4–10
images

adding, 4–9
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Cardfiler
images (cont’d)

copying from Paint, 4–10
deleting, 4–10

searching the text, 4–5
starting, 4–2

CDA Viewer
exiting, 5–17
file formats, 5–12
PostScript paper size options

Orientation, 5–10
Scale Factor, 5–10
Use Bitmap Widths, 5–10
Use Comments, 5–10
Use Fake Trays, 5–11
Watch Progress, 5–11

starting, 5–1
viewing files, 5–3, 5–6

using the Files list box, 5–11
Characters

composing, 8–32, A–1
Clock

customized settings
saving, 6–2

customizing display, 6–2
exiting, 6–4
setting alarm, 6–3
starting, 6–1

Close button (Bookreader), 1–6
CREATE/TERMINAL command, 8–1

D
DDIF, 7–3
DECsound

control panel, 7–5
Play button, 7–10
Position slider, 7–7
Volume slider, 7–6
Zoom slider, 7–11

creating and sending recordings, 7–19
deleting recordings, 7–15
editing recordings, 7–4, 7–12

deleting selected portions, 7–14, 7–15
selecting portions, 7–12
using QuickCopy, 7–14

DECsound (cont’d)
ending sessions, 7–20
file types, 7–3
including recordings in documents, 7–15
mailing recordings, 7–18
making recordings, 7–6, 7–7

inserting new material, 7–9
playing recordings, 7–5, 7–10
starting sessions

from FileView, 7–1
from Session Manager, 7–1
from the command line, 7–1
using LiveLink connections, 7–1

using DECwrite with, 7–16
using LiveLink connections, 7–15

DECterm
composing characters, 8–32, A–1
copying information, 8–28
display options, 8–7
exiting, 8–32
general options, 8–10
graphics options, 8–18
keyboard options, 8–16
National Replacement Character Set

(NRCS)
choosing, 8–17

options
customizing, 8–2 to 8–27

print options, 8–31
restoring options, 8–26
saving options, 8–25
window

clearing, 8–29
creating, 8–1
resizing, 8–29

DECwindows Mail
using DECsound with, 7–18

choosing default editor, 7–19
creating and sending recordings,

7–19
DECwrite

using DECsound with, 7–16
Dialog box

Search Results, 1–10
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E
Entry Editor (Calendar)

creating an entry with, 3–5
Environment window (LinkWorks Manager),

9–2
relationship to Linkbase window, 9–3

F
File types

DECsound, 7–3
Sun, 7–3

G
Go Back button (Bookreader), 1–6

H
Hotspots (Bookreader), 1–7
Hyperapplication features

Calendar, 3–27
Cardfiler, 4–10
Mail, 10–63

I
INBOX folder (Mail), 10–17

L
Library window

using, 1–2
Linkbase (hyperinformation)

creating, 9–9
creating objects, 9–10
grouping objects, 9–10

Linkbase window (LinkWorks Manager),
9–9

layout, 9–10
relationship to Environment window, 9–3
using, 9–9

Linknet (hyperinformation)
active and recording, 9–5

LinkWorks Manager
copying objects into environment, 9–12
creating linkbase objects, 9–10
customizing environment defaults, 9–6

Go To/Visit, 9–8
highlighting, 9–7
linking, 9–8

customizing startup state, 9–6
Environment window, 9–2

layout, 9–5
relationship to Linkbase window, 9–3

grouping linkbase objects, 9–10
Linkbase window, 9–9

layout, 9–10
relationship to Environment window,

9–3
options, 9–6
paths, 9–13

following, 9–14
recording steps, 9–13

starting, 9–2
LinkWorks Setup (environment

initialization), 9–2

M
Mail

accelerators, 10–4
changing default settings, 10–45

editor list, 10–53
icon options, 10–50
main window, 10–63
print options, 10–57
read options, 10–55
receive options, 10–56
send options, 10–51
user options, 10–45
window options, 10–48

Create–Send window, 10–5
opening, 10–5

drawers, 10–2
adding, 10–28
compressing, 10–38
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Mail
drawers (cont’d)

deleting, 10–32
modifying, 10–31
removing, 10–32

editing, 11–20
exiting, 10–63
folders, 10–2

creating, 10–33
deleting, 10–34
updating, 10–37

hyperapplication features, 10–63
index information

displaying additional, 10–42
interaction with OpenVMS Mail utility,

10–58
Mail environment options, 10–45
main window

Columns style, 10–59
opening a new, 10–43
Paned style, 10–59 to 10–61
Tree style, 10–59

Message button, 10–19
messages

See also Mail messages
creating, 10–5
sending, 10–7

pane size
adjusting, 10–19

pop-up menus, 10–4
PostScript files

displaying, 10–44
sending, 10–16

push buttons, 10–3
Read window, 10–17, 10–19

closing, 10–20
default, 10–21
illustrated, 10–17
multiple, 10–21
opening, 10–18

scroll bars, 10–4
starting, 10–1

Mail applications
using DECsound with, 7–18

Mail messages
CDA documents, 10–43
changing editor, 10–16
copying, 10–35
creating, 10–5

changing editor, 10–16
including a draft, 10–8
including a file, 10–10
including last sent message, 10–10

creating a file from, 10–25
creating a subset of, 10–39
deleting, 10–27
extracting, 10–25
forwarding, 10–22
index information

displaying additional, 10–42
marking, 10–39
moving, 10–35
new, 10–17, 10–20
old, 10–17
picking, 10–39
printing, 10–23

changing default settings, 10–57
reading, 10–17

multiple, 10–20, 10–21
new, 10–17
nontext, 10–20
old, 10–17, 10–20

replacing text, 10–13
replying to, 10–21
resuming work on draft, 10–8
retrieving deleted, 10–28
saving, 10–8
searching text, 10–13
selecting, 10–17
sending, 10–7

PostScript files, 10–16
to a distribution list, 10–11

unmarking, 10–39
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N
National Replacement Character Set (NRCS)

See DECterm

P
Paint

accelerators, 11–33
basic functions, 11–3 to 11–7
canvas

moving the display, 11–3
sizing, 11–31
viewing portions of, 11–27

colors
choosing, 11–18

drawing lines and shapes, 11–10, 11–11
editing

inserting text, 11–29
pictures, 11–20
using Zoom window, 11–27

erasing, 11–10
exiting, 11–34
files

including, 11–29
opening, 11–3
standard type, 11–4

grid, 11–11
image file

including, 11–29
images

copying, 11–23
inverting, 11–7
moving, 11–21
selecting, 11–21
sizing, 11–25

line width
changing, 11–13

menu items
Brushes..., 11–19
Clear Window, 11–10
Copy, 11–24
Crop, 11–27
Cut, 11–10

Paint
menu items (cont’d)

Edit Pattern..., 11–16
Exit, 11–34
Full View, 11–27
Grid On, 11–11
Include..., 11–29
Invert, 11–7
Line Width..., 11–13
Mix Color..., 11–18
Opaque, 11–14
Paint View, 11–27
Palette..., 11–18
Paste, 11–24
Patterns..., 11–15
Picture Size..., 11–32
Print, 11–10
Print As..., 11–10
Quick Copy, 11–23
Save As..., 11–8
Scale..., 11–25
Scale Picture..., 11–26
Select Window, 11–21
Transparent, 11–14
Undo, 11–10
Undo Flood, 11–16
Undo Scale, 11–26

patterns
creating, 11–16
using, 11–14

pictures
cropping, 11–27
editing, 11–20
inserting text, 11–29
magnifying, 11–27
printing, 11–10
saving, 11–8

starting, 11–2
text

inserting, 11–29
tool palette

location of, 11–2
tools

description of, 11–6
window
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Paint
window (cont’d)

clearing, 11–10
Zoom window, 11–27

Play button, 7–10
Pop-up menus

in Clock, 6–2
Position slider, 7–7
PostScript

displaying files with Mail, 10–44
Print Screen

changing default settings, 12–5
exiting, 12–7
naming output files, 12–4
screen snapshots, 12–2
starting, 12–1
taking screen snapshots, 12–2

after a time delay, 12–3
Puzzle

changing default settings, 13–2
exiting, 13–3
playing with, 13–2
starting, 13–1
starting a new game, 13–3

R
Recording linknet (hyperinformation), 9–5
Recording path (hyperinformation), 9–5

S
Scroll bars

Bookreader
in topic window, 1–6

Cardfiler
in Cardfiler window, 4–5

Search Results dialog box
using, 1–10

Starting DECsound sessions
from the command line, 7–2

T
Terminal emulator (DECterm)

creating, 8–1

V
Volume slider, 7–6

W
WASTEBASKET folder (Mail), 10–27

Z
Zoom slider, 7–11
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